gnu: libressl: Update to 2.2.5.
[jackhill/guix/guix.git] / gnu / packages / aria2.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages aria2)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pkg-config))
25
26 (define-public c-ares
27 (package
28 (name "c-ares")
29 (version "1.10.0")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append
33 "http://c-ares.haxx.se/download/" name "-" version
34 ".tar.gz"))
35 (sha256
36 (base32
37 "1nyka87yf2jfd0y6sspll0yxwb8zi7kyvajrdbjmh4axc5s1cw1x"))))
38 (build-system gnu-build-system)
39 (native-inputs
40 `(("pkg-config" ,pkg-config)))
41 (home-page "http://c-ares.haxx.se/")
42 (synopsis "C library for asynchronous DNS requests")
43 (description
44 "C-ares is a C library that performs DNS requests and name resolution
45 asynchronously. It is intended for applications which need to perform DNS
46 queries without blocking, or need to perform multiple DNS queries in parallel.
47 The primary examples of such applications are servers which communicate with
48 multiple clients and programs with graphical user interfaces.")
49 (license (license:x11-style "http://c-ares.haxx.se/license.html"))))