gnu: guix: Update snapshot.
[jackhill/guix/guix.git] / gnu / packages / ed.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages ed)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages compression))
26
27 (define-public ed
28 (package
29 (name "ed")
30 (version "1.11")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/ed/ed-"
34 version ".tar.lz"))
35 (sha256
36 (base32
37 "0d518yhs3kpdpv9fbpa1rhxk2fbry2yzcknrdaa20pi2bzg6w55x"))))
38 (build-system gnu-build-system)
39 (native-inputs `(("lzip" ,lzip)))
40 (arguments
41 '(#:configure-flags '("CC=gcc")
42 #:phases (alist-cons-before 'patch-source-shebangs 'patch-test-suite
43 (lambda _
44 (substitute* "testsuite/check.sh"
45 (("/bin/sh") (which "sh"))))
46 %standard-phases)))
47 (home-page "http://www.gnu.org/software/ed/")
48 (synopsis "Line-oriented text editor")
49 (description
50 "Ed is a line-oriented text editor: rather than offering an overview of
51 a document, ed performs editing one line at a time. It can be executed both
52 interactively and via shell scripts. Its method of command input allows
53 complex tasks to be performed in an automated way. GNU ed offers several
54 extensions over the standard utility.")
55 (license gpl3+)))