Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / rdf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015, 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages rdf)
22 #:use-module ((guix licenses)
23 #:select (non-copyleft isc gpl2 lgpl2.1 lgpl2.1+))
24 #:use-module (guix packages)
25 #:use-module (guix git-download)
26 #:use-module (guix download)
27 #:use-module (guix build-system cmake)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system python)
30 #:use-module (guix build-system waf)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages autotools)
33 #:use-module (gnu packages boost)
34 #:use-module (gnu packages check)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages curl)
37 #:use-module (gnu packages cyrus-sasl)
38 #:use-module (gnu packages documentation)
39 #:use-module (gnu packages dbm)
40 #:use-module (gnu packages gnupg)
41 #:use-module (gnu packages linux)
42 #:use-module (gnu packages multiprecision)
43 #:use-module (gnu packages pcre)
44 #:use-module (gnu packages perl)
45 #:use-module (gnu packages pkg-config)
46 #:use-module (gnu packages python)
47 #:use-module (gnu packages python-web)
48 #:use-module (gnu packages python-xyz)
49 #:use-module (gnu packages qt)
50 #:use-module (gnu packages time)
51 #:use-module (gnu packages tls)
52 #:use-module (gnu packages xml))
53
54 (define-public raptor2
55 (package
56 (name "raptor2")
57 (version "2.0.15")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "http://download.librdf.org/source/" name
61 "-" version ".tar.gz"))
62 (patches
63 (search-patches "raptor2-heap-overflow.patch"))
64 (sha256
65 (base32
66 "1vc02im4mpc28zxzgli68k6j0dakh0k3s389bm436yvqajxg19xd"))))
67 (build-system gnu-build-system)
68 (inputs
69 `(("curl" ,curl)
70 ("libxml2" ,libxml2)
71 ("libxslt" ,libxslt)
72 ("zlib" ,zlib)))
73 (arguments
74 `(#:parallel-tests? #f))
75 (home-page "http://librdf.org/raptor/")
76 (synopsis "RDF syntax library")
77 (description "Raptor is a C library providing a set of parsers and
78 serialisers that generate Resource Description Framework (RDF) triples
79 by parsing syntaxes or serialise the triples into a syntax. The supported
80 parsing syntaxes are RDF/XML, N-Quads, N-Triples 1.0 and 1.1, TRiG,
81 Turtle 2008 and 2013, RDFa 1.0 and 1.1, RSS tag soup including all versions
82 of RSS, Atom 1.0 and 0.3, GRDDL and microformats for HTML, XHTML and
83 XML. The serialising syntaxes are RDF/XML (regular, abbreviated, XMP),
84 Turtle 2013, N-Quads, N-Triples 1.1, Atom 1.0, RSS 1.0, GraphViz DOT,
85 HTML and JSON.")
86 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
87
88 (define-public clucene
89 (package
90 (name "clucene")
91 (version "2.3.3.4")
92 (source (origin
93 (method url-fetch)
94 (uri (string-append "mirror://sourceforge/clucene/"
95 "clucene-core-unstable/2.3/clucene-core-"
96 version ".tar.gz"))
97 (sha256
98 (base32
99 "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))
100 (patches (search-patches "clucene-pkgconfig.patch"
101 "clucene-contribs-lib.patch"))))
102 (build-system cmake-build-system)
103 (inputs
104 `(("boost" ,boost) ; could also use bundled copy
105 ("zlib" ,zlib)))
106 (arguments
107 `(#:test-target "cl_test"
108 #:configure-flags '("-DBUILD_CONTRIBS_LIB=ON")
109 #:tests? #f)) ; Tests do not compile, as TestIndexSearcher.cpp uses
110 ; undeclared usleep. After fixing this, one needs to run
111 ; "make test" in addition to "make cl_test", then
112 ; SimpleTest fails.
113 ; Notice that the library appears to be unmaintained
114 ; with no reaction to bug reports.
115 (home-page "http://clucene.sourceforge.net/")
116 (synopsis "C text indexing and searching library")
117 (description "CLucene is a high-performance, scalable, cross platform,
118 full-featured indexing and searching API. It is a port of the very popular
119 Java Lucene text search engine API to C++.")
120 (license lgpl2.1)))
121
122 (define-public lrdf
123 (package
124 (name "lrdf")
125 (version "0.6.1")
126 (source (origin
127 (method git-fetch)
128 (uri (git-reference
129 (url "https://github.com/swh/LRDF.git")
130 (commit (string-append "v" version))))
131 (file-name (git-file-name name version))
132 (sha256
133 (base32
134 "00wzkfb8y0aqd519ypz067cq099dpc89w69zw8ln39vl6f9x2pd4"))))
135 (build-system gnu-build-system)
136 (arguments
137 '(#:phases
138 (modify-phases %standard-phases
139 (add-after 'unpack 'remove-out-of-tree-references
140 (lambda _
141 ;; remove_test depends on an out-of-tree RDF file
142 (substitute* "examples/Makefile.am"
143 (("instances_test remove_test") "instances_test")
144 (("\\$\\(TESTS\\) remove_test") "$(TESTS)"))
145 #t))
146 ;; The default bootstrap phase executes autogen.sh, which fails.
147 (replace 'bootstrap
148 (lambda _ (invoke "autoreconf" "-vif") #t)))))
149 (inputs
150 `(("raptor" ,raptor2)
151 ("cyrus-sasl" ,cyrus-sasl)
152 ("zlib" ,zlib)))
153 (native-inputs
154 `(("autoconf" ,autoconf)
155 ("automake" ,automake)
156 ("libtool" ,libtool)
157 ("pkg-config" ,pkg-config)))
158 (home-page "https://github.com/swh/LRDF")
159 (synopsis "Lightweight RDF library for accessing LADSPA plugin metadata")
160 (description
161 "LRDF is a library to make it easy to manipulate RDF files describing
162 LADSPA plugins. It can also be used for general RDF manipulation. It can
163 read RDF/XLM and N3 files and export N3 files, and it also has a light
164 taxonomic inference capability.")
165 (license gpl2)))
166
167 (define-public rasqal
168 (package
169 (name "rasqal")
170 (version "0.9.33")
171 (source (origin
172 (method url-fetch)
173 (uri (string-append "http://download.librdf.org/source/" name
174 "-" version ".tar.gz"))
175 (sha256
176 (base32
177 "0z6rrwn4jsagvarg8d5zf0j352kjgi33py39jqd29gbhcnncj939"))))
178 (build-system gnu-build-system)
179 (native-inputs
180 `(("perl" ,perl)
181 ("perl-xml-dom" ,perl-xml-dom) ; for the tests
182 ("pkg-config" ,pkg-config)))
183 (inputs
184 `(("libgcrypt" ,libgcrypt)
185 ("libxml2" ,libxml2)
186 ("mpfr" ,mpfr)
187 ("pcre" ,pcre)
188 ("util-linux" ,util-linux)))
189 (propagated-inputs
190 `(("raptor2" ,raptor2))) ; stipulated by rasqal.pc
191 (arguments
192 `(#:parallel-tests? #f
193 ; test failure reported upstream, see
194 ; http://bugs.librdf.org/mantis/view.php?id=571
195 #:tests? #f))
196 (home-page "http://librdf.org/rasqal/")
197 (synopsis "RDF query library")
198 (description "Rasqal is a C library that handles Resource Description
199 Framework (RDF) query language syntaxes, query construction and execution
200 of queries returning results as bindings, boolean, RDF graphs/triples or
201 syntaxes. The supported query languages are SPARQL Query 1.0,
202 SPARQL Query 1.1, SPARQL Update 1.1 (no executing) and the Experimental
203 SPARQL extensions (LAQRS). Rasqal can write binding query results in the
204 SPARQL XML, SPARQL JSON, CSV, TSV, HTML, ASCII tables, RDF/XML and
205 Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
206 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
207
208 (define-public redland
209 (package
210 (name "redland")
211 (version "1.0.17")
212 (source (origin
213 (method url-fetch)
214 (uri (string-append "http://download.librdf.org/source/" name
215 "-" version ".tar.gz"))
216 (sha256
217 (base32
218 "109n0kp39p966dpiasad2bb7q66rwbcb9avjvimw28chnpvlf66y"))))
219 (build-system gnu-build-system)
220 (native-inputs
221 `(("perl" ,perl) ; needed for installation
222 ("pkg-config" ,pkg-config)))
223 (propagated-inputs
224 `(("rasqal" ,rasqal))) ; in Requires.private field of .pc
225 (inputs
226 `(("bdb" ,bdb)))
227 (home-page "http://librdf.org/")
228 (synopsis "RDF library")
229 (description "The Redland RDF Library (librdf) provides the RDF API
230 and triple stores.")
231 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
232
233 (define-public serd
234 (package
235 (name "serd")
236 (version "0.30.0")
237 (source (origin
238 (method url-fetch)
239 (uri (string-append "https://download.drobilla.net/serd-"
240 version ".tar.bz2"))
241 (sha256
242 (base32
243 "1yyfyvc6kwagi5w43ljp1bbjdvdpmgpds74lmjxycm91bkx0xyvf"))))
244 (build-system waf-build-system)
245 (arguments
246 `(#:tests? #f ; no check target
247 #:phases
248 (modify-phases %standard-phases
249 (add-before
250 'configure 'set-ldflags
251 (lambda* (#:key outputs #:allow-other-keys)
252 (setenv "LDFLAGS"
253 (string-append "-Wl,-rpath="
254 (assoc-ref outputs "out") "/lib"))
255 #t)))))
256 (home-page "https://drobilla.net/software/serd/")
257 (synopsis "Library for RDF syntax supporting Turtle and NTriples")
258 (description
259 "Serd is a lightweight C library for RDF syntax which supports reading
260 and writing Turtle and NTriples. Serd is not intended to be a swiss-army
261 knife of RDF syntax, but rather is suited to resource limited or performance
262 critical applications (e.g. converting many gigabytes of NTriples to Turtle),
263 or situations where a simple reader/writer with minimal dependencies is
264 ideal (e.g. in LV2 implementations or embedded applications).")
265 (license isc)))
266
267 (define-public sord
268 (package
269 (name "sord")
270 (version "0.16.2")
271 (source (origin
272 (method url-fetch)
273 (uri (string-append "https://download.drobilla.net/sord-"
274 version ".tar.bz2"))
275 (sha256
276 (base32
277 "13fshxwpipjrvsah1m2jw1kf022z2q5vpw24bzcznglgvms13x89"))))
278 (build-system waf-build-system)
279 (arguments
280 `(#:tests? #f ; no check target
281 #:phases
282 (modify-phases %standard-phases
283 (add-before
284 'configure 'set-ldflags
285 (lambda* (#:key outputs #:allow-other-keys)
286 (setenv "LDFLAGS"
287 (string-append "-Wl,-rpath="
288 (assoc-ref outputs "out") "/lib"))
289 #t)))))
290 (inputs
291 `(("serd" ,serd)))
292 (native-inputs
293 `(("pkg-config" ,pkg-config)))
294 (home-page "https://drobilla.net/software/sord/")
295 (synopsis "C library for storing RDF data in memory")
296 (description
297 "Sord is a lightweight C library for storing RDF data in memory.")
298 (license isc)))
299
300 (define-public python-rdflib
301 (package
302 (name "python-rdflib")
303 (version "4.2.2")
304 (source
305 (origin
306 (method url-fetch)
307 (uri (pypi-uri "rdflib" version))
308 (sha256
309 (base32
310 "0398c714znnhaa2x7v51b269hk20iz073knq2mvmqp2ma92z27fs"))))
311 (build-system python-build-system)
312 (arguments
313 '(;; FIXME: Three test failures. Should be fixed next release.
314 #:tests? #f))
315 ;; #:phases
316 ;; (modify-phases %standard-phases
317 ;; (replace 'check
318 ;; (lambda _
319 ;; ;; Run tests from the build directory so python3 only
320 ;; ;; sees the installed 2to3 version.
321 ;; (invoke "nosetests" "--where=./build/src"))))))
322 (native-inputs
323 `(("python-nose" ,python-nose)))
324 (propagated-inputs
325 `(("python-html5lib" ,python-html5lib)
326 ("python-isodate" ,python-isodate)
327 ("python-pyparsing" ,python-pyparsing)))
328 (home-page "https://github.com/RDFLib/rdflib")
329 (synopsis "Python RDF library")
330 (description
331 "RDFLib is a Python library for working with RDF, a simple yet
332 powerful language for representing information.")
333 (license (non-copyleft "file://LICENSE"
334 "See LICENSE in the distribution."))))
335
336 (define-public python2-rdflib
337 (package-with-python2 python-rdflib))