gnu: ungoogled-chromium: Update to 78.0.3904.97-0.acaf163.
[jackhill/guix/guix.git] / gnu / packages / elm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages elm)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages haskell)
22 #:use-module (gnu packages haskell-check)
23 #:use-module (gnu packages haskell-crypto)
24 #:use-module (gnu packages haskell-xyz)
25 #:use-module (gnu packages haskell-web)
26 #:use-module (guix build-system haskell)
27 #:use-module (guix git-download)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages))
30
31 ;; The full elm build calls out to itself via Template Haskell to
32 ;; compile the elm reactor web app. elm reactor isn't required to
33 ;; compile elm applications, so we take this part out of this
34 ;; bootstrap package.
35 (define-public elm-compiler
36 (package
37 (name "elm-compiler")
38 (version "0.19.0")
39 (source
40 (origin
41 (method git-fetch)
42 (file-name (git-file-name name version))
43 (uri (git-reference
44 (url "https://github.com/elm/compiler/")
45 (commit version)))
46 (sha256
47 (base32 "0s93z9vr0vp5w894ghc5s34nsq09sg1msf59zfiba87sid5vgjqy"))
48 (patches
49 (search-patches "elm-compiler-disable-reactor.patch"
50 "elm-compiler-relax-glsl-bound.patch"
51 "elm-compiler-fix-map-key.patch"))))
52 (build-system haskell-build-system)
53 (inputs
54 `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
55 ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
56 ("ghc-edit-distance" ,ghc-edit-distance)
57 ("ghc-file-embed" ,ghc-file-embed)
58 ("ghc-http" ,ghc-http)
59 ("ghc-http-client" ,ghc-http-client)
60 ("ghc-http-client-tls" ,ghc-http-client-tls)
61 ("ghc-http-types" ,ghc-http-types)
62 ("ghc-language-glsl" ,ghc-language-glsl)
63 ("ghc-logict" ,ghc-logict)
64 ("ghc-network" ,ghc-network)
65 ("ghc-raw-strings-qq" ,ghc-raw-strings-qq)
66 ("ghc-scientific" ,ghc-scientific)
67 ("ghc-sha" ,ghc-sha)
68 ("ghc-snap-core" ,ghc-snap-core)
69 ("ghc-snap-server" ,ghc-snap-server)
70 ("ghc-unordered-containers"
71 ,ghc-unordered-containers)
72 ("ghc-utf8-string" ,ghc-utf8-string)
73 ("ghc-vector" ,ghc-vector)
74 ("ghc-zip-archive" ,ghc-zip-archive)))
75 (home-page "https://elm-lang.org")
76 (synopsis "Programming language for Web applications")
77 (description
78 "This package provides Elm, a statically-typed functional programming
79 language for the browser. It includes commands for developers such as
80 @command{elm make} and @command{elm repl}.")
81 (license license:bsd-3)))