gnu: qbittorrent: Update to 4.1.9.1.
[jackhill/guix/guix.git] / gnu / packages / bittorrent.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
3 ;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
7 ;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
9 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
10 ;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
11 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages bittorrent)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix git-download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system python)
34 #:use-module (guix build-system glib-or-gtk)
35 #:use-module ((guix licenses) #:prefix l:)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages adns)
38 #:use-module (gnu packages boost)
39 #:use-module (gnu packages check)
40 #:use-module (gnu packages compression)
41 #:use-module (gnu packages crypto)
42 #:use-module (gnu packages curl)
43 #:use-module (gnu packages cyrus-sasl)
44 #:use-module (gnu packages file)
45 #:use-module (gnu packages freedesktop)
46 #:use-module (gnu packages glib)
47 #:use-module (gnu packages gnome)
48 #:use-module (gnu packages gnupg)
49 #:use-module (gnu packages gstreamer)
50 #:use-module (gnu packages gtk)
51 #:use-module (gnu packages libevent)
52 #:use-module (gnu packages linux)
53 #:use-module (gnu packages multiprecision)
54 #:use-module (gnu packages nettle)
55 #:use-module (gnu packages ncurses)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages python)
58 #:use-module (gnu packages python-crypto)
59 #:use-module (gnu packages python-xyz)
60 #:use-module (gnu packages qt)
61 #:use-module (gnu packages sqlite)
62 #:use-module (gnu packages ssh)
63 #:use-module (gnu packages tls)
64 #:use-module (gnu packages xml))
65
66 (define-public transmission
67 (package
68 (name "transmission")
69 (version "2.94")
70 (source (origin
71 (method url-fetch)
72 (uri (string-append
73 "https://github.com/transmission/transmission-releases/raw/"
74 "master/transmission-" version ".tar.xz"))
75 (sha256
76 (base32
77 "0zbbj7rlm6m7vb64x68a64cwmijhsrwx9l63hbwqs7zr9742qi1m"))))
78 (build-system glib-or-gtk-build-system)
79 (outputs '("out" ; library and command-line interface
80 "gui")) ; graphical user interface
81 (arguments
82 '(#:glib-or-gtk-wrap-excluded-outputs '("out")
83 #:phases
84 (modify-phases %standard-phases
85 (add-after 'install 'move-gui
86 (lambda* (#:key outputs #:allow-other-keys)
87 ;; Move the GUI to its own output, so that "out" doesn't
88 ;; depend on GTK+.
89 (let ((out (assoc-ref outputs "out"))
90 (gui (assoc-ref outputs "gui")))
91 (mkdir-p (string-append gui "/bin"))
92 (rename-file (string-append out "/bin/transmission-gtk")
93 (string-append gui
94 "/bin/transmission-gtk"))
95
96 ;; Move the '.desktop' file as well.
97 (mkdir (string-append gui "/share"))
98 (rename-file (string-append out "/share/applications")
99 (string-append gui "/share/applications")))
100 #t)))))
101 (inputs
102 `(("inotify-tools" ,inotify-tools)
103 ("libevent" ,libevent)
104 ("curl" ,curl)
105 ("cyrus-sasl" ,cyrus-sasl)
106 ("openssl" ,openssl)
107 ("file" ,file)
108 ("zlib" ,zlib)
109 ("gtk+" ,gtk+)))
110 (native-inputs
111 `(("intltool" ,intltool)
112 ("pkg-config" ,pkg-config)))
113 (home-page "https://transmissionbt.com/")
114 (synopsis "Fast and easy BitTorrent client")
115 (description
116 "Transmission is a BitTorrent client that comes with graphical,
117 textual, and Web user interfaces. Transmission also has a daemon for
118 unattended operations. It supports local peer discovery, full encryption,
119 DHT, µTP, PEX and Magnet Links.")
120
121 ;; COPYING reads:
122 ;;
123 ;; Transmission can be redistributed and/or modified under the terms of
124 ;; the GNU GPLv2 (http://www.gnu.org/licenses/license-list.html#GPLv2),
125 ;; the GNU GPLv3 (http://www.gnu.org/licenses/license-list.html#GNUGPLv3),
126 ;; or any future license endorsed by Mnemosyne LLC.
127 ;;
128 ;; A few files files carry an MIT/X11 license header.
129 (license l:gpl3+)))
130
131 (define-public libtorrent
132 (package
133 (name "libtorrent")
134 (version "0.13.8")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append
138 "http://rtorrent.net/downloads/libtorrent-"
139 version ".tar.gz"))
140 (sha256
141 (base32
142 "10z9i1rc41cmmi7nx8k7k1agsx6afv09g9cl7g9zr35fyhl5l4gd"))))
143 (build-system gnu-build-system)
144 (inputs `(("openssl" ,openssl)
145 ("zlib" ,zlib)))
146 (native-inputs `(("pkg-config" ,pkg-config)
147 ("cppunit" ,cppunit)))
148 (synopsis "BitTorrent library of rtorrent")
149 (description
150 "LibTorrent is a BitTorrent library used by and developed in parallel
151 with the BitTorrent client rtorrent. It is written in C++ with emphasis on
152 speed and efficiency.")
153 (home-page "https://github.com/rakshasa/libtorrent")
154 (license l:gpl2+)))
155
156 (define-public rtorrent
157 (package
158 (name "rtorrent")
159 (version "0.9.8")
160 (source (origin
161 (method url-fetch)
162 (uri (string-append
163 "http://rtorrent.net/downloads/rtorrent-"
164 version ".tar.gz"))
165 (sha256
166 (base32
167 "1bs2fnf4q7mlhkhzp3i1v052v9xn8qa7g845pk9ia8hlpw207pwy"))))
168 (build-system gnu-build-system)
169 (inputs `(("libtorrent" ,libtorrent)
170 ("ncurses" ,ncurses)
171 ("curl" ,curl)
172 ("cyrus-sasl" ,cyrus-sasl)
173 ("openssl" ,openssl)
174 ("zlib" ,zlib)))
175 (native-inputs `(("pkg-config" ,pkg-config)
176 ("cppunit" ,cppunit)))
177 (synopsis "BitTorrent client with ncurses interface")
178 (description
179 "rTorrent is a BitTorrent client with an ncurses interface. It supports
180 full encryption, DHT, PEX, and Magnet Links. It can also be controlled via
181 XML-RPC over SCGI.")
182 (home-page "https://github.com/rakshasa/rtorrent")
183 (license l:gpl2+)))
184
185 (define-public tremc
186 (let ((commit "4d50dab7376601daca13f7be6eabc0eaa057c1b0")
187 (revision "0"))
188 (package
189 (name "tremc")
190 (version (git-version "0.9.1" revision commit))
191 (source
192 (origin
193 (method git-fetch)
194 (uri (git-reference
195 (url "https://github.com/tremc/tremc.git")
196 (commit commit)))
197 (file-name (git-file-name name version))
198 (sha256
199 (base32
200 "0qpi65n8rv7l9mg8qyqx70z83inkl8v5r5nks65c99lhscdki0w7"))))
201 (build-system gnu-build-system)
202 (arguments
203 `(#:tests? #f ; no test suite
204 #:make-flags
205 (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
206 #:phases
207 (modify-phases %standard-phases
208 ;; The software is just a Python script that must be copied into place.
209 (delete 'configure)
210 (delete 'build))))
211 (inputs
212 `(("python" ,python)))
213 (synopsis "Console client for the Transmission BitTorrent daemon")
214 (description "Tremc is a console client, with a curses interface, for the
215 Transmission BitTorrent daemon.")
216 (home-page "https://github.com/tremc/tremc")
217 (license l:gpl3+))))
218
219 (define-public transmission-remote-cli
220 (package
221 (name "transmission-remote-cli")
222 (version "1.7.1")
223 (source (origin
224 (method git-fetch)
225 (uri (git-reference
226 (url "https://github.com/fagga/transmission-remote-cli.git")
227 (commit (string-append "v" version))))
228 (file-name (git-file-name name version))
229 (sha256
230 (base32
231 "09w9f8vrm61lapin8fmq4rgahr95y3c6wss10g0fgd0kl16f895v"))))
232 (build-system python-build-system)
233 (arguments
234 `(#:python ,python-2 ; only supports Python 2
235 #:tests? #f ; no test suite
236 #:phases (modify-phases %standard-phases
237 ;; The software is just a Python script that must be
238 ;; copied into place.
239 (delete 'build)
240 (replace 'install
241 (lambda* (#:key outputs #:allow-other-keys)
242 (let* ((out (assoc-ref outputs "out"))
243 (bin (string-append out "/bin"))
244 (man (string-append out "/share/man/man1"))
245 ;; FIXME install zsh completions
246 (completions (string-append out "/etc/bash_completion.d")))
247 (install-file "transmission-remote-cli" bin)
248 (install-file "transmission-remote-cli.1" man)
249 (install-file
250 (string-append
251 "completion/bash/"
252 "transmission-remote-cli-bash-completion.sh")
253 completions)))))))
254 (synopsis "Console client for the Transmission BitTorrent daemon")
255 (description "Transmission-remote-cli is a console client, with a curses
256 interface, for the Transmission BitTorrent daemon. This package is no longer
257 maintained upstream.")
258 (home-page "https://github.com/fagga/transmission-remote-cli")
259 (license l:gpl3+)
260 (properties `((superseded . ,tremc)))))
261
262 (define-public aria2
263 (package
264 (name "aria2")
265 (version "1.35.0")
266 (source (origin
267 (method url-fetch)
268 (uri (string-append "https://github.com/aria2/aria2/releases/"
269 "download/release-" version
270 "/aria2-" version ".tar.xz"))
271 (sha256
272 (base32
273 "1zbxc517d97lb96f15xcy4l7b66grxrp3h2ids2jiwkaip87yaqy"))))
274 (build-system gnu-build-system)
275 (arguments
276 `(#:configure-flags (list "--enable-libaria2"
277 (string-append "--with-bashcompletiondir="
278 %output "/etc/bash_completion.d/"))
279 #:phases
280 (modify-phases %standard-phases
281 (add-after 'unpack 'delete-socket-tests
282 (lambda _
283 (substitute* "test/LpdMessageDispatcherTest.cc"
284 (("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageDispatcherTest\\);" text)
285 (string-append "// " text)))
286 (substitute* "test/LpdMessageReceiverTest.cc"
287 (("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageReceiverTest\\);" text)
288 (string-append "// " text)))
289 #t)))))
290 (native-inputs
291 `(("cppunit" ,cppunit) ; for the tests
292 ("pkg-config" ,pkg-config)))
293 (inputs
294 `(("c-ares" ,c-ares)
295 ("gnutls" ,gnutls)
296 ("gmp" ,gmp)
297 ("libssh2" ,libssh2)
298 ("libxml2" ,libxml2)
299 ("nettle" ,nettle)
300 ("sqlite" ,sqlite)
301 ("zlib" ,zlib)))
302 (home-page "https://aria2.github.io/")
303 (synopsis "Utility for parallel downloading files")
304 (description
305 "Aria2 is a lightweight, multi-protocol & multi-source command-line
306 download utility. It supports HTTP/HTTPS, FTP, SFTP, BitTorrent and Metalink.
307 Aria2 can be manipulated via built-in JSON-RPC and XML-RPC interfaces.")
308 (license l:gpl2+)))
309
310 (define-public uget
311 (package
312 (name "uget")
313 (version "2.0.8")
314 (source (origin
315 (method url-fetch)
316 (uri (string-append "mirror://sourceforge/urlget/"
317 "uget%20%28stable%29/" version "/uget-"
318 version ".tar.gz"))
319 (sha256
320 (base32
321 "0919cf7lfk1djdl003cahqjvafdliv7v2l8r5wg95n4isqggdk75"))))
322 (build-system gnu-build-system)
323 (inputs
324 `(("curl" ,curl)
325 ("gtk+" ,gtk+)
326 ("glib" ,glib)
327 ("gnutls" ,gnutls)
328 ("gstreamer" ,gstreamer)
329 ("libgcrypt" ,libgcrypt)
330 ("libnotify" ,libnotify)
331 ("openssl" ,openssl)))
332 (native-inputs
333 `(("intltool" ,intltool)
334 ("pkg-config" ,pkg-config)))
335 (home-page "http://ugetdm.com/")
336 (synopsis "Universal download manager with GTK+ interface")
337 (description
338 "uGet is portable download manager with GTK+ interface supporting
339 HTTP, HTTPS, BitTorrent and Metalink, supporting multi-connection
340 downloads, download scheduling, download rate limiting.")
341 (license l:lgpl2.1+)))
342
343 (define-public mktorrent
344 (package
345 (name "mktorrent")
346 (version "1.1")
347 (source (origin
348 (method git-fetch)
349 (uri (git-reference
350 (url "https://github.com/Rudde/mktorrent.git")
351 (commit (string-append "v" version))))
352 (file-name (git-file-name name version))
353 (sha256
354 (base32
355 "17pdc5mandl739f8q26n5is8ga56s83aqcrwhlnnplbxwx2inidr"))))
356 (build-system gnu-build-system)
357 (arguments
358 `(#:phases (modify-phases %standard-phases
359 (delete 'configure)) ; no configure script
360 #:make-flags (list "CC=gcc"
361 (string-append "PREFIX=" (assoc-ref %outputs "out"))
362 "NO_HASH_CHECK=1"
363 "USE_LARGE_FILES=1"
364 "USE_LONG_OPTIONS=1"
365 "USE_PTHREADS=1")
366 #:tests? #f)) ; no tests
367 (home-page "https://github.com/Rudde/mktorrent")
368 (synopsis "Utility to create BitTorrent metainfo files")
369 (description
370 "mktorrent is a simple command-line utility to create BitTorrent
371 @dfn{metainfo} files, often known simply as @dfn{torrents}, from both single
372 files and whole directories. It can add multiple trackers and web seed URLs,
373 and set the @code{private} flag to disallow advertisement through the
374 distributed hash table (@dfn{DHT}) and Peer Exchange. Hashing is multi-threaded
375 and will take advantage of multiple processor cores where possible.")
376 (license (list l:public-domain ; sha1.*, used to build without OpenSSL
377 l:gpl2+)))) ; with permission to link with OpenSSL
378
379 (define-public libtorrent-rasterbar
380 (package
381 (name "libtorrent-rasterbar")
382 (version "1.1.13")
383 (source (origin
384 (method url-fetch)
385 (uri
386 (string-append
387 "https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
388 (string-join (string-split version #\.) "_")
389 "/libtorrent-rasterbar-" version ".tar.gz"))
390 (sha256
391 (base32
392 "1mza92ljjqvlz9582pmls3n45srqhxvw3q348xihcg4fhlchf11h"))))
393 (build-system gnu-build-system)
394 (arguments
395 `(#:configure-flags
396 (list (string-append "--with-boost-libdir="
397 (assoc-ref %build-inputs "boost")
398 "/lib")
399 "--enable-python-binding"
400 "--enable-tests")
401 #:make-flags (list
402 (string-append "LDFLAGS=-Wl,-rpath="
403 (assoc-ref %outputs "out") "/lib"))))
404 (inputs `(("boost" ,boost)
405 ("openssl" ,openssl)))
406 (native-inputs `(("python" ,python-2)
407 ("pkg-config" ,pkg-config)))
408 (home-page "https://www.libtorrent.org/")
409 (synopsis "Feature complete BitTorrent implementation")
410 (description
411 "libtorrent-rasterbar is a feature complete C++ BitTorrent implementation
412 focusing on efficiency and scalability. It runs on embedded devices as well as
413 desktops.")
414 (license l:bsd-2)))
415
416 (define-public qbittorrent
417 (package
418 (name "qbittorrent")
419 (version "4.1.9.1")
420 (source
421 (origin
422 (method git-fetch)
423 (uri (git-reference
424 (url "https://github.com/qbittorrent/qBittorrent.git")
425 (commit (string-append "release-" version))))
426 (file-name (git-file-name name version))
427 (sha256
428 (base32 "19zgqlby7i1kr20wa4zd99qzd062a879xxxbmlf40rnqiqy4bhyi"))))
429 (build-system gnu-build-system)
430 (arguments
431 `(#:configure-flags
432 (list (string-append "--with-boost-libdir="
433 (assoc-ref %build-inputs "boost")
434 "/lib")
435 "--enable-debug"
436 "QMAKE_LRELEASE=lrelease")))
437 (native-inputs
438 `(("pkg-config" ,pkg-config)
439 ("qttools" ,qttools)))
440 (inputs
441 `(("boost" ,boost)
442 ("libtorrent-rasterbar" ,libtorrent-rasterbar)
443 ("openssl" ,openssl)
444 ("python" ,python-wrapper)
445 ("qtbase" ,qtbase)
446 ("qtsvg" ,qtsvg)
447 ("zlib" ,zlib)))
448 (home-page "https://www.qbittorrent.org/")
449 (synopsis "Graphical BitTorrent client")
450 (description
451 "qBittorrent is a BitTorrent client programmed in C++/Qt that uses
452 libtorrent (sometimes called libtorrent-rasterbar) by Arvid Norberg.
453
454 It aims to be a good alternative to all other BitTorrent clients out there.
455 qBittorrent is fast, stable and provides unicode support as well as many
456 features.")
457 (license l:gpl2+)))
458
459 (define-public deluge
460 (package
461 (name "deluge")
462 (version "1.3.15")
463 (source
464 (origin
465 (method url-fetch)
466 (uri (string-append
467 "http://download.deluge-torrent.org/source/deluge-"
468 version ".tar.xz"))
469 (sha256
470 (base32
471 "0b7rri4x0wrcj7rjghrnw1kfrsd5i7i6aq85dsg5dg1w1qa0ar59"))))
472 (build-system python-build-system)
473 (inputs
474 `(("libtorrent" ,libtorrent-rasterbar)
475 ("python2-chardet" ,python2-chardet)
476 ("python2-pygtk" ,python2-pygtk)
477 ("python2-pyopenssl" ,python2-pyopenssl)
478 ("python2-pyxdg" ,python2-pyxdg)
479 ("python2-service-identity" ,python2-service-identity)
480 ("python2-twisted" ,python2-twisted)))
481 (native-inputs
482 `(("intltool" ,intltool)))
483 (arguments
484 `(#:python ,python-2))
485 (home-page "https://www.deluge-torrent.org/")
486 (synopsis "Fully-featured cross-platform ​BitTorrent client")
487 (description
488 "Deluge contains the common features to BitTorrent clients such as
489 Protocol Encryption, DHT, Local Peer Discovery (LSD), Peer Exchange
490 (PEX), UPnP, NAT-PMP, Proxy support, Web seeds, global and per-torrent
491 speed limits. Deluge heavily utilises the ​libtorrent library. It is
492 designed to run as both a normal standalone desktop application and as a
493 ​client-server.")
494 (license l:gpl3+)))