gnu: Add and use gettext-minimal.
[jackhill/guix/guix.git] / gnu / packages / glib.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
5 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages glib)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix utils)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system python)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages base)
32 #:use-module (gnu packages bison)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages flex)
35 #:use-module (gnu packages gettext)
36 #:use-module (gnu packages gnome)
37 #:use-module (gnu packages gtk)
38 #:use-module (gnu packages libffi)
39 #:use-module (gnu packages pcre)
40 #:use-module (gnu packages perl)
41 #:use-module (gnu packages pkg-config)
42 #:use-module (gnu packages python)
43 #:use-module (gnu packages xml)
44 #:use-module (gnu packages bash)
45 #:use-module (gnu packages file)
46 #:use-module (gnu packages xorg)
47 #:use-module (gnu packages m4)
48
49 ;; Export variables up-front to allow circular dependency with the 'xorg'
50 ;; module.
51 #:export (dbus
52 glib
53 gobject-introspection
54 dbus-glib
55 intltool
56 itstool
57 libsigc++
58 glibmm
59 telepathy-glib))
60
61 (define dbus
62 (package
63 (name "dbus")
64 (version "1.10.10")
65 (source (origin
66 (method url-fetch)
67 (uri (string-append
68 "https://dbus.freedesktop.org/releases/dbus/dbus-"
69 version ".tar.gz"))
70 (sha256
71 (base32
72 "0hwsfczhx2djmc9116vj5v230i7gpjihwh3vbljs1ldlk831v3wx"))
73 (patches (search-patches "dbus-helper-search-path.patch"))))
74 (build-system gnu-build-system)
75 (arguments
76 '(#:configure-flags
77 (list
78 ;; Install the system bus socket under /var.
79 "--localstatedir=/var"
80
81 ;; Install the session bus socket under /tmp.
82 "--with-session-socket-dir=/tmp"
83
84 ;; Use /etc/dbus-1 for system-wide config.
85 ;; Look for configuration file under
86 ;; /etc/dbus-1. This is notably required by
87 ;; 'dbus-daemon-launch-helper', which looks for
88 ;; the 'system.conf' file in that place,
89 ;; regardless of what '--config-file' was
90 ;; passed to 'dbus-daemon' on the command line;
91 ;; see <https://bugs.freedesktop.org/show_bug.cgi?id=92458>.
92 "--sysconfdir=/etc")
93 #:phases
94 (modify-phases %standard-phases
95 (replace 'install
96 (lambda _
97 ;; Don't try to create /var and /etc.
98 (system* "make"
99 "localstatedir=/tmp/dummy"
100 "sysconfdir=/tmp/dummy"
101 "install"))))))
102 (native-inputs
103 `(("pkg-config" ,pkg-config)))
104 (inputs
105 `(("expat" ,expat)
106
107 ;; Add a dependency on libx11 so that 'dbus-launch' has support for
108 ;; '--autolaunch'.
109 ("libx11" ,libx11)))
110
111 (home-page "http://dbus.freedesktop.org/")
112 (synopsis "Message bus for inter-process communication (IPC)")
113 (description
114 "D-Bus is a message bus system, a simple way for applications to
115 talk to one another. In addition to interprocess communication, D-Bus
116 helps coordinate process lifecycle; it makes it simple and reliable to
117 code a \"single instance\" application or daemon, and to launch
118 applications and daemons on demand when their services are needed.
119
120 D-Bus supplies both a system daemon (for events such as \"new hardware
121 device added\" or \"printer queue changed\") and a
122 per-user-login-session daemon (for general IPC needs among user
123 applications). Also, the message bus is built on top of a general
124 one-to-one message passing framework, which can be used by any two apps
125 to communicate directly (without going through the message bus
126 daemon). Currently the communicating applications are on one computer,
127 or through unencrypted TCP/IP suitable for use behind a firewall with
128 shared NFS home directories.")
129 (license license:gpl2+))) ; or Academic Free License 2.1
130
131 (define glib
132 (package
133 (name "glib")
134 (version "2.48.2")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "mirror://gnome/sources/"
138 name "/" (string-take version 4) "/"
139 name "-" version ".tar.xz"))
140 (sha256
141 (base32
142 "1x6kwrk1zyd3csv0ca3pmwc4bnkc33agn95cds15h6nbi4apappj"))
143 (patches (search-patches "glib-tests-timer.patch"))))
144 (build-system gnu-build-system)
145 (outputs '("out" ; everything
146 "bin" ; glib-mkenums, gtester, etc.; depends on Python
147 "doc")) ; 20 MiB of GTK-Doc reference
148 (propagated-inputs
149 `(("pcre" ,pcre))) ; in the Requires.private field of glib-2.0.pc
150 (inputs
151 `(("coreutils" ,coreutils)
152 ("libffi" ,libffi)
153 ("zlib" ,zlib)
154 ("tzdata" ,tzdata))) ; for tests/gdatetime.c
155 (native-inputs
156 `(("gettext" ,gettext-minimal)
157 ("dbus" ,dbus) ; for GDBus tests
158 ("pkg-config" ,pkg-config)
159 ("python" ,python-wrapper)
160 ("perl" ,perl) ; needed by GIO tests
161 ("bash" ,bash)))
162 (arguments
163 '(#:phases
164 (modify-phases %standard-phases
165 (add-before 'build 'pre-build
166 (lambda* (#:key inputs outputs #:allow-other-keys)
167 ;; For tests/gdatetime.c.
168 (setenv "TZDIR"
169 (string-append (assoc-ref inputs "tzdata")
170 "/share/zoneinfo"))
171
172 ;; Some tests want write access there.
173 (setenv "HOME" (getcwd))
174 (setenv "XDG_CACHE_HOME" (getcwd))
175
176 (substitute* '("glib/gspawn.c"
177 "glib/tests/utils.c"
178 "tests/spawn-test.c")
179 (("/bin/sh")
180 (string-append (assoc-ref inputs "bash") "/bin/sh")))))
181 (add-before 'check 'disable-failing-tests
182 (lambda _
183 (let ((disable
184 (lambda (test-file test-paths)
185 (define pattern+procs
186 (map (lambda (test-path)
187 (cons
188 ;; XXX: only works for single line statements.
189 (format #f "g_test_add_func.*\"~a\".*" test-path)
190 (const "")))
191 test-paths))
192 (substitute test-file pattern+procs)))
193 (failing-tests
194 '(("glib/tests/thread.c"
195 (;; prlimit(2) returns ENOSYS on Linux 2.6.32-5-xen-amd64
196 ;; as found on hydra.gnu.org, and strace(1) doesn't
197 ;; recognize it.
198 "/thread/thread4"))
199
200 ("glib/tests/timer.c"
201 (;; fails if compiler optimizations are enabled, which they
202 ;; are by default.
203 "/timer/stop"))
204
205 ("gio/tests/gapplication.c"
206 (;; XXX: proven to be unreliable. See:
207 ;; <https://bugs.debian.org/756273>
208 ;; <http://bugs.gnu.org/18445>
209 "/gapplication/quit"
210
211 ;; XXX: fails randomly for unknown reason. See:
212 ;; <https://lists.gnu.org/archive/html/guix-devel/2016-04/msg00215.html>
213 "/gapplication/local-actions"))
214
215 ("gio/tests/contenttype.c"
216 (;; XXX: requires shared-mime-info.
217 "/contenttype/guess"
218 "/contenttype/subtype"
219 "/contenttype/list"
220 "/contenttype/icon"
221 "/contenttype/symbolic-icon"
222 "/contenttype/tree"))
223
224 ("gio/tests/appinfo.c"
225 (;; XXX: requires update-desktop-database.
226 "/appinfo/associations"))
227
228 ("gio/tests/desktop-app-info.c"
229 (;; XXX: requires update-desktop-database.
230 "/desktop-app-info/delete"
231 "/desktop-app-info/default"
232 "/desktop-app-info/fallback"
233 "/desktop-app-info/lastused"
234 "/desktop-app-info/search"))
235
236 ("gio/tests/gdbus-peer.c"
237 (;; Requires /etc/machine-id.
238 "/gdbus/codegen-peer-to-peer"))
239
240 ("gio/tests/gdbus-unix-addresses.c"
241 (;; Requires /etc/machine-id.
242 "/gdbus/x11-autolaunch")))))
243 (and-map (lambda (x) (apply disable x)) failing-tests)))))
244
245 ;; Note: `--docdir' and `--htmldir' are not honored, so work around it.
246 #:configure-flags (list (string-append "--with-html-dir="
247 (assoc-ref %outputs "doc")
248 "/share/gtk-doc/html"))
249
250 ;; In 'gio/tests', 'gdbus-test-codegen-generated.h' is #included in a
251 ;; file that gets compiled possibly before it has been fully generated.
252 #:parallel-tests? #f))
253
254 (native-search-paths
255 ;; This variable is not really "owned" by GLib, but several related
256 ;; packages refer to it: gobject-introspection's tools use it as a search
257 ;; path for .gir files, and it's also a search path for schemas produced
258 ;; by 'glib-compile-schemas'.
259 (list (search-path-specification
260 (variable "XDG_DATA_DIRS")
261 (files '("share")))
262 ;; To load extra gio modules from glib-networking, etc.
263 (search-path-specification
264 (variable "GIO_EXTRA_MODULES")
265 (files '("lib/gio/modules")))))
266 (search-paths native-search-paths)
267
268 (synopsis "Thread-safe general utility library; basis of GTK+ and GNOME")
269 (description
270 "GLib provides data structure handling for C, portability wrappers,
271 and interfaces for such runtime functionality as an event loop, threads,
272 dynamic loading, and an object system.")
273 (home-page "http://developer.gnome.org/glib/")
274 (license license:lgpl2.0+))) ; some files are under lgpl2.1+
275
276 (define gobject-introspection
277 (package
278 (name "gobject-introspection")
279 (version "1.48.0")
280 (source (origin
281 (method url-fetch)
282 (uri (string-append "mirror://gnome/sources/"
283 "gobject-introspection/" (version-major+minor version)
284 "/gobject-introspection-" version ".tar.xz"))
285 (sha256
286 (base32 "0xsqwxhfqzr79av89mg766kxpb2i41bd0vwspk01xjdzrnn5l9zs"))
287 (modules '((guix build utils)))
288 (snippet
289 '(substitute* "tools/g-ir-tool-template.in"
290 (("#!/usr/bin/env @PYTHON@") "#!@PYTHON@")))
291 (patches (search-patches
292 "gobject-introspection-cc.patch"
293 "gobject-introspection-girepository.patch"
294 "gobject-introspection-absolute-shlib-path.patch"))))
295 (build-system gnu-build-system)
296 (inputs
297 `(("bison" ,bison)
298 ("flex" ,flex)
299 ("glib" ,glib)
300 ("python-2" ,python-2)))
301 (native-inputs
302 `(("glib" ,glib "bin")
303 ("pkg-config" ,pkg-config)))
304 (propagated-inputs
305 `(;; In practice, GIR users will need libffi when using
306 ;; gobject-introspection.
307 ("libffi" ,libffi)))
308 (native-search-paths
309 (list (search-path-specification
310 (variable "GI_TYPELIB_PATH")
311 (files '("lib/girepository-1.0")))))
312 (search-paths native-search-paths)
313 (arguments
314 `(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
315 ;; some tests to fail.
316 #:tests? #f))
317 (home-page "https://wiki.gnome.org/GObjectIntrospection")
318 (synopsis "Generate interface introspection data for GObject libraries")
319 (description
320 "GObject introspection is a middleware layer between C libraries (using
321 GObject) and language bindings. The C library can be scanned at compile time
322 and generate a metadata file, in addition to the actual native C library. Then
323 at runtime, language bindings can read this metadata and automatically provide
324 bindings to call into the C library.")
325 ; Some bits are distributed under the LGPL2+, others under the GPL2+
326 (license license:gpl2+)))
327
328 (define intltool
329 (package
330 (name "intltool")
331 (version "0.51.0")
332 (source (origin
333 (method url-fetch)
334 (uri (string-append "https://launchpad.net/intltool/trunk/"
335 version "/+download/intltool-"
336 version ".tar.gz"))
337 (sha256
338 (base32
339 "1karx4sb7bnm2j67q0q74hspkfn6lqprpy5r99vkn5bb36a4viv7"))))
340 (build-system gnu-build-system)
341 (inputs
342 `(("file" ,file)))
343 (propagated-inputs
344 `(;; Propagate gettext because users expect it to be there, and so does
345 ;; the `intltool-update' script.
346 ("gettext" ,gettext-minimal)
347
348 ("perl-xml-parser" ,perl-xml-parser)
349 ("perl" ,perl)))
350 (arguments
351 `(#:phases (alist-cons-after
352 'unpack 'patch-file-references
353 (lambda* (#:key inputs #:allow-other-keys)
354 (let ((file (assoc-ref inputs "file")))
355 (substitute* "intltool-update.in"
356 (("`file") (string-append "`" file "/bin/file")))))
357 %standard-phases)))
358 (home-page "https://launchpad.net/intltool/+download")
359 (synopsis "Tools to centralise translations of different file formats")
360 (description
361 "Intltool is a set of tools to centralise translations of many different
362 file formats using GNU gettext-compatible PO files.
363
364 The intltool collection can be used to do these things:
365
366 Extract translatable strings from various source files (.xml.in,
367 glade, .desktop.in, .server.in, .oaf.in).
368
369 Collect the extracted strings together with messages from traditional
370 source files (.c, .h) in po/$(PACKAGE).pot.
371
372 Merge back the translations from .po files into .xml, .desktop and
373 oaf files. This merge step will happen at build resp. installation time.")
374 (license license:gpl2+)))
375
376 (define itstool
377 (package
378 (name "itstool")
379 (version "2.0.2")
380 (source (origin
381 (method url-fetch)
382 (uri (string-append "http://files.itstool.org/itstool/itstool-"
383 version ".tar.bz2"))
384 (sha256
385 (base32
386 "0fh34wi52i0qikgvlmrcpf1vx6gc1xqdad4539l4d9hikfsrz45z"))))
387 (build-system gnu-build-system)
388 (inputs
389 `(("libxml2" ,libxml2)
390 ("python2-libxml2" ,python2-libxml2)
391 ("python-2" ,python-2)))
392 (arguments
393 '(#:phases
394 (modify-phases %standard-phases
395 (add-after
396 'install 'wrap-program
397 (lambda* (#:key outputs #:allow-other-keys)
398 (let ((prog (string-append (assoc-ref outputs "out")
399 "/bin/itstool")))
400 (wrap-program prog
401 `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))))))))
402 (home-page "http://www.itstool.org")
403 (synopsis "Tool to translate XML documents with PO files")
404 (description
405 "ITS Tool allows you to translate your XML documents with PO files, using
406 rules from the W3C Internationalization Tag Set (ITS) to determine what to
407 translate and how to separate it into PO file messages.
408
409 PO files are the standard translation format for GNU and other Unix-like
410 systems. They present translatable information as discrete messages, allowing
411 each message to be translated independently. In contrast to whole-page
412 translation, translating with a message-based format like PO means you can
413 easily track changes to the source document down to the paragraph. When new
414 strings are added or existing strings are modified, you only need to update the
415 corresponding messages.
416
417 ITS Tool is designed to make XML documents translatable through PO files by
418 applying standard ITS rules, as well as extension rules specific to ITS Tool.
419 ITS also provides an industry standard way for authors to override translation
420 information in their documents, such as whether a particular element should be
421 translated.")
422 (license license:gpl3+)))
423
424 (define dbus-glib
425 (package
426 (name "dbus-glib")
427 (version "0.106")
428 (source (origin
429 (method url-fetch)
430 (uri
431 (string-append "https://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-"
432 version ".tar.gz"))
433 (sha256
434 (base32
435 "0in0i6v68ixcy0ip28i84hdczf10ykq9x682qgcvls6gdmq552dk"))))
436 (build-system gnu-build-system)
437 (propagated-inputs ; according to dbus-glib-1.pc
438 `(("dbus" ,dbus)
439 ("glib" ,glib)))
440 (inputs
441 `(("expat" ,expat)))
442 (native-inputs
443 `(("glib" ,glib "bin")
444 ("pkg-config" ,pkg-config)))
445 (home-page "http://dbus.freedesktop.org/doc/dbus-glib/")
446 (synopsis "D-Bus GLib bindings")
447 (description
448 "GLib bindings for D-Bus. The package is obsolete and superseded
449 by GDBus included in Glib.")
450 (license license:gpl2))) ; or Academic Free License 2.1
451
452 (define libsigc++
453 (package
454 (name "libsigc++")
455 (version "2.8.0")
456 (source (origin
457 (method url-fetch)
458 (uri (string-append "mirror://gnome/sources/libsigc++/"
459 (version-major+minor version) "/"
460 name "-" version ".tar.xz"))
461 (sha256
462 (base32
463 "0lcnzzdq6718znfshs1hflpwqq6awbzwdyp4kv5lfaf54z880jbp"))))
464 (build-system gnu-build-system)
465 (native-inputs `(("pkg-config" ,pkg-config)
466 ("m4" ,m4)))
467 (home-page "http://libsigc.sourceforge.net/")
468 (synopsis "Type-safe callback system for standard C++")
469 (description
470 "Libsigc++ implements a type-safe callback system for standard C++. It
471 allows you to define signals and to connect those signals to any callback
472 function, either global or a member function, regardless of whether it is
473 static or virtual.
474
475 It also contains adaptor classes for connection of dissimilar callbacks and
476 has an ease of use unmatched by other C++ callback libraries.")
477 (license license:lgpl2.1+)))
478
479 (define glibmm
480 (package
481 (name "glibmm")
482 (version "2.48.1")
483 (source (origin
484 (method url-fetch)
485 (uri (string-append "mirror://gnome/sources/glibmm/"
486 (version-major+minor version)
487 "/glibmm-" version ".tar.xz"))
488 (sha256
489 (base32
490 "1pvw2mrm03p51p03179rb6fk9p42iykkwj1jcdv7jr265xymy8nw"))))
491 (build-system gnu-build-system)
492 (arguments
493 `(#:phases (alist-cons-before
494 'build 'pre-build
495 (lambda _
496 ;; This test uses /etc/fstab as an example file to read
497 ;; from; choose a better example.
498 (substitute* "tests/giomm_simple/main.cc"
499 (("/etc/fstab")
500 (string-append (getcwd)
501 "/tests/giomm_simple/main.cc")))
502
503 ;; This test does a DNS lookup, and then expects to be able
504 ;; to open a TLS session; just skip it.
505 (substitute* "tests/giomm_tls_client/main.cc"
506 (("Gio::init.*$")
507 "return 77;\n")))
508 %standard-phases)))
509 (native-inputs `(("pkg-config" ,pkg-config)
510 ("glib" ,glib "bin")))
511 (propagated-inputs
512 `(("libsigc++" ,libsigc++)
513 ("glib" ,glib)))
514 (home-page "http://gtkmm.org/")
515 (synopsis "C++ interface to the GLib library")
516 (description
517 "Glibmm provides a C++ programming interface to the part of GLib that are
518 useful for C++.")
519 (license license:lgpl2.1+)))
520
521 (define-public python2-pygobject-2
522 (package
523 (name "python2-pygobject")
524 ;; This was the last version to declare the 2.0 platform number, i.e. its
525 ;; pkg-config files were named pygobject-2.0.pc
526 (version "2.28.6")
527 (source
528 (origin
529 (method url-fetch)
530 (uri (string-append "mirror://gnome/sources/pygobject/"
531 (version-major+minor version)
532 "/pygobject-" version ".tar.xz"))
533 (sha256
534 (base32
535 "1f5dfxjnil2glfwxnqr14d2cjfbkghsbsn8n04js2c2icr7iv2pv"))
536 (patches (search-patches
537 "python2-pygobject-2-gi-info-type-error-domain.patch"))))
538 (build-system gnu-build-system)
539 (native-inputs
540 `(("which" ,which)
541 ("glib-bin" ,glib "bin") ;for tests: glib-compile-schemas
542 ("pkg-config" ,pkg-config)
543 ("dbus" ,dbus))) ;for tests
544 (inputs
545 `(("python" ,python-2)
546 ("glib" ,glib)
547 ("python2-pycairo" ,python2-pycairo)
548 ("gobject-introspection" ,gobject-introspection)))
549 (propagated-inputs
550 `(("libffi" ,libffi))) ;mentioned in pygobject-2.0.pc
551 (arguments
552 `(#:tests? #f ;segfaults during tests
553 #:configure-flags '("LIBS=-lcairo-gobject")))
554 (home-page "https://pypi.python.org/pypi/PyGObject")
555 (synopsis "Python bindings for GObject")
556 (description
557 "Python bindings for GLib, GObject, and GIO.")
558 (license license:lgpl2.1+)))
559
560 (define-public python-pygobject
561 (package
562 (name "python-pygobject")
563 (version "3.20.0")
564 (source
565 (origin
566 (method url-fetch)
567 (uri (string-append "mirror://gnome/sources/pygobject/"
568 (version-major+minor version)
569 "/pygobject-" version ".tar.xz"))
570 (sha256
571 (base32
572 "0ikzh3l7g1gjh8jj8vg6mdvrb25svp63gxcam4m0i404yh0lgari"))))
573 (build-system gnu-build-system)
574 (native-inputs
575 `(("which" ,which)
576 ("glib-bin" ,glib "bin") ;for tests: glib-compile-schemas
577 ("pkg-config" ,pkg-config)))
578 (inputs
579 `(("python" ,python)
580 ("python-pycairo" ,python-pycairo)
581 ("gobject-introspection" ,gobject-introspection)))
582 (propagated-inputs
583 ;; pygobject-3.0.pc refers to all these.
584 `(("glib" ,glib)
585 ("libffi" ,libffi)))
586 (arguments
587 ;; TODO: failing tests: test_native_calls_async
588 ;; test_native_calls_async_errors test_native_calls_sync
589 ;; test_native_calls_sync_errors test_python_calls_async
590 ;; test_python_calls_async_error test_python_calls_async_error_result
591 ;; test_python_calls_sync test_python_calls_sync_errors
592 ;; test_python_calls_sync_noargs test_callback_user_data_middle_none
593 ;; test_callback_user_data_middle_single
594 ;; test_callback_user_data_middle_tuple
595 '(#:tests? #f))
596 ;; For finding typelib files, since gobject-introscpetion isn't propagated.
597 (native-search-paths (package-native-search-paths gobject-introspection))
598 (home-page "https://live.gnome.org/PyGObject")
599 (synopsis "Python bindings for GObject")
600 (description
601 "Python bindings for GLib, GObject, and GIO.")
602 (license license:lgpl2.1+)
603 (properties `((python2-variant . ,(delay python2-pygobject))))))
604
605 (define-public python2-pygobject
606 (package (inherit (strip-python2-variant python-pygobject))
607 (name "python2-pygobject")
608 (inputs
609 `(("python" ,python-2)
610 ("python-pycairo" ,python2-pycairo)
611 ("gobject-introspection" ,gobject-introspection)))))
612
613 (define telepathy-glib
614 (package
615 (name "telepathy-glib")
616 (version "0.24.1")
617 (source
618 (origin
619 (method url-fetch)
620 (uri
621 (string-append
622 "https://telepathy.freedesktop.org/releases/telepathy-glib/"
623 "telepathy-glib-" version ".tar.gz"))
624 (sha256
625 (base32
626 "1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))
627 (patches
628 (list
629 ;; Don't use the same test name for multiple tests.
630 ;; <https://bugs.freedesktop.org/show_bug.cgi?id=92245>
631 (origin
632 (method url-fetch)
633 (uri "https://bugs.freedesktop.org/attachment.cgi?id=118608")
634 (file-name (string-append "telepathy-glib-duplicate-tests.patch"))
635 (sha256
636 (base32
637 "0z261fwrszxb28ccg3hsg9rizig4s84zvwmx6y31a4pyv7bvs5w3")))))))
638 (build-system gnu-build-system)
639 (arguments
640 '(#:configure-flags '("--enable-vala-bindings")))
641 (native-inputs
642 `(("glib" ,glib "bin") ; uses glib-mkenums
643 ("gobject-introspection" ,gobject-introspection)
644 ("pkg-config" ,pkg-config)
645 ("python" ,python-2)
646 ("vala" ,vala)
647 ("xsltproc" ,libxslt)))
648 (propagated-inputs
649 ;; There are all in the Requires.private field of telepathy-glib.pc.
650 `(("dbus" ,dbus)
651 ("dbus-glib" ,dbus-glib)
652 ("glib" ,glib)))
653 (home-page "http://telepathy.freedesktop.org/wiki/")
654 (synopsis "GLib Real-time communications framework over D-Bus")
655 (description "Telepathy is a flexible, modular communications framework
656 that enables real-time communication over D-Bus via pluggable protocol
657 backends. Telepathy is a communications service that can be accessed by
658 many applications simultaneously.
659
660 This package provides the library for GLib applications.")
661 (license license:lgpl2.1+)))