gnu: Add zita-resampler.
[jackhill/guix/guix.git] / gnu / packages / iso-codes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages iso-codes)
20 #:use-module ((guix licenses) #:select (gpl2+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages gettext)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages python))
27
28 (define-public iso-codes
29 (package
30 (name "iso-codes")
31 (version "3.49")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append
35 "http://pkg-isocodes.alioth.debian.org/downloads/iso-codes-"
36 version ".tar.xz"))
37 (sha256
38 (base32
39 "1ryk5i467p7xxrbrqynb35ci046yj9k9b4d3hfxzass962lz9q04"))))
40 (build-system gnu-build-system)
41 (inputs
42 `(("gettext" ,gnu-gettext)
43 ("perl" ,perl)
44 ("python-2" ,python-2)))
45 (home-page "http://pkg-isocodes.alioth.debian.org/")
46 (synopsis "Various ISO standards")
47 (description
48 "This package provides lists of various ISO standards (e.g. country,
49 language, language scripts, and currency names) in one place, rather
50 than repeated in many programs throughout the system.
51
52 Currently there are lists of languages and countries embedded in
53 several different programs, which leads to dozens of lists of
54 200 languages, translated into more than 30 languages... not
55 very efficient.
56
57 With this package, we create a single \"gettext domain\" for every
58 supported ISO standard which contains the translations of
59 that domain. It is easy for a programmer to re-use those
60 translations instead of maintaining their own translation
61 infrastructure. Moreover, the programmer does not need to follow
62 changes in the ISO standard and will not work with outdated
63 information.")
64 ; Some bits use the lgpl2
65 (license gpl2+)))