gnu: Add liblcf.
[jackhill/guix/guix.git] / gnu / packages / easyrpg.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages easyrpg)
20 #:use-module (guix packages)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages icu4c)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages xml))
27
28 (define-public liblcf
29 (package
30 (name "liblcf")
31 (version "0.5.4")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append
35 "https://easyrpg.org/downloads/player/" version
36 "/liblcf-" version ".tar.gz"))
37 (sha256
38 (base32
39 "1k99bcw5c23801jk3mbz5sj5h18x46w1qxrkknhwhfgqzpvxhwrs"))))
40 (build-system gnu-build-system)
41 (native-inputs
42 `(("pkg-config" ,pkg-config)))
43 (propagated-inputs
44 ;; Required by 'liblcf.pc'.
45 `(("expat" ,expat)
46 ("icu" ,icu4c)))
47 (home-page "https://easyrpg.org/")
48 (synopsis "Library to handle RPG Maker 2000 and 2003 game data")
49 (description
50 "@code{liblcf} is a library to handle RPG Maker 2000 and 2003 game data.
51 It can read and write LCF and XML files.")
52 ;; It includes a copy of Boost Preprocessor Cat and Stringize (boost-1.0):
53 ;; src/boost/preprocessor/config.hpp
54 ;; src/boost/preprocessor/cat.hpp
55 ;; src/boost/preprocessor/stringize.hpp
56 ;; and a copy of inih (bsd-3):
57 ;; src/ini.h
58 ;; src/ini.cpp
59 ;; src/inireader.h
60 ;; src/inireader.cpp
61 ;; TODO: Unbundle them.
62 (license license:expat)))