Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages kde)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix download)
30 #:use-module (guix git-download)
31 #:use-module ((guix licenses) #:prefix license:)
32 #:use-module (guix packages)
33 #:use-module (guix utils)
34 #:use-module (gnu packages)
35 #:use-module (gnu packages algebra)
36 #:use-module (gnu packages apr)
37 #:use-module (gnu packages boost)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages documentation)
41 #:use-module (gnu packages gettext)
42 #:use-module (gnu packages ghostscript)
43 #:use-module (gnu packages gl)
44 #:use-module (gnu packages gnome)
45 #:use-module (gnu packages graphics)
46 #:use-module (gnu packages image)
47 #:use-module (gnu packages kde-frameworks)
48 #:use-module (gnu packages kde-plasma)
49 #:use-module (gnu packages linux)
50 #:use-module (gnu packages llvm)
51 #:use-module (gnu packages maths)
52 #:use-module (gnu packages pdf)
53 #:use-module (gnu packages perl)
54 #:use-module (gnu packages photo)
55 #:use-module (gnu packages pkg-config)
56 #:use-module (gnu packages python)
57 #:use-module (gnu packages tls)
58 #:use-module (gnu packages qt)
59 #:use-module (gnu packages version-control)
60 #:use-module (gnu packages video)
61 #:use-module (gnu packages xdisorg)
62 #:use-module (gnu packages xorg))
63
64 (define-public kdenlive
65 (let ((version "18.08.1"))
66 (package
67 (name "kdenlive")
68 (version version)
69 (source
70 (origin
71 (method git-fetch)
72 (uri (git-reference
73 (url "git://anongit.kde.org/kdenlive.git")
74 (commit (string-append "v" version))))
75 (file-name (string-append name "-" version "-checkout"))
76 (sha256
77 (base32
78 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
79 (build-system cmake-build-system)
80 (native-inputs
81 `(("extra-cmake-modules" ,extra-cmake-modules)
82 ("qttools" ,qttools)))
83 (propagated-inputs
84 `(("mlt" ,mlt)))
85 (inputs
86 `(("shared-mime-info" ,shared-mime-info)
87 ("frei0r-plugins" ,frei0r-plugins)
88 ("qtbase" ,qtbase)
89 ("qtscript" ,qtscript)
90 ("qtsvg" ,qtsvg)
91 ("kparts" ,kparts)
92 ("knotifications" ,knotifications)
93 ("karchive" ,karchive)
94 ("kdbusaddons" ,kdbusaddons)
95 ("kcrash" ,kcrash)
96 ("kguiaddons" ,kguiaddons)
97 ("knewstuff" ,knewstuff)
98 ("knotifyconfig" ,knotifyconfig)
99 ("kfilemetadata" ,kfilemetadata)
100 ("kdoctools" ,kdoctools)
101 ("kdeclarative" ,kdeclarative)
102 ("qtdeclarative" ,qtdeclarative)
103 ("qtquickcontrols" ,qtquickcontrols)
104 ("kiconthemes" ,kiconthemes)
105 ("qtgraphicaleffects" ,qtgraphicaleffects)
106 ("kplotting" ,kplotting)))
107 (arguments
108 `(#:phases
109 (modify-phases %standard-phases
110 (add-after 'install 'wrap-executable
111 (lambda* (#:key inputs outputs #:allow-other-keys)
112 (let* ((out (assoc-ref outputs "out"))
113 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
114 (qtbase (assoc-ref inputs "qtbase"))
115 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
116 (frei0r (assoc-ref inputs "frei0r-plugins"))
117 (qml "/lib/qt5/qml"))
118 (wrap-program (string-append out "/bin/kdenlive")
119 `("QT_PLUGIN_PATH" ":" prefix
120 ,(map (lambda (label)
121 (string-append (assoc-ref inputs label)
122 "/lib/qt5/plugins/"))
123 '("qtbase" "qtsvg")))
124 `("FREI0R_PATH" ":" =
125 (,(string-append frei0r "/lib/frei0r-1/")))
126 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
127 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
128 `("QML2_IMPORT_PATH" ":" prefix
129 (,(string-append qtquickcontrols qml)
130 ,(string-append qtdeclarative qml)))))
131 #t)))))
132 (home-page "https://kdenlive.org")
133 (synopsis "Non-linear video editor")
134 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
135
136 Non-linear video editing is much more powerful than beginner's (linear)
137 editors, hence it requires a bit more organization before starting. However,
138 it is not reserved to specialists and can be used for small personal
139 projects.")
140 (license license:gpl2+))))
141
142 (define-public kdevelop
143 (package
144 (name "kdevelop")
145 (version "5.1.2")
146 (source
147 (origin
148 (method url-fetch)
149 (uri (string-append "mirror://kde/stable/kdevelop"
150 "/" version "/src/kdevelop-"
151 version ".tar.xz"))
152 (sha256
153 (base32
154 "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
155 (build-system cmake-build-system)
156 (native-inputs
157 `(("extra-cmake-modules" ,extra-cmake-modules)
158 ("pkg-config" ,pkg-config)
159 ("qttools" ,qttools)))
160 (inputs
161 `(("kdevplatform" ,kdevplatform)
162 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
163 ("qtbase" ,qtbase)
164 ("qtdeclarative" ,qtdeclarative)
165 ("qtquickcontrols" ,qtquickcontrols)
166 ("qtwebkit" ,qtwebkit)
167 ("karchive" ,karchive)
168 ("kcmutils" ,kcmutils)
169 ("kconfig" ,kconfig)
170 ("kdeclarative" ,kdeclarative)
171 ("kdoctools" ,kdoctools)
172 ("kguiaddons" ,kguiaddons)
173 ("ki18n" ,ki18n)
174 ("kio" ,kio)
175 ("kiconthemes" ,kiconthemes)
176 ("kitemmodels" ,kitemmodels)
177 ("kitemviews" ,kitemviews)
178 ("kjobwidgets" ,kjobwidgets)
179 ("knotifyconfig" ,knotifyconfig)
180 ("knotifications" ,knotifications)
181 ("kparts" ,kparts)
182 ("kcrash" ,kcrash)
183 ("knewstuff" ,knewstuff)
184 ("krunner" ,krunner)
185 ("kxmlgui" ,kxmlgui)
186 ("libksysguard" ,libksysguard)
187 ("threadweaver" ,threadweaver)
188 ("ktexteditor" ,ktexteditor)
189 ("kwindowsystem" ,kwindowsystem)
190 ("plasma" ,plasma-framework)
191 ("grantlee" ,grantlee)
192 ("libepoxy" ,libepoxy)
193 ("clang" ,clang)
194 ("shared-mime-info" ,shared-mime-info)))
195 (arguments
196 `(#:phases
197 (modify-phases %standard-phases
198 (delete 'check) ;; there are some issues with the test suite
199 (add-after 'install 'wrap-executable
200 (lambda* (#:key inputs outputs #:allow-other-keys)
201 (let* ((out (assoc-ref outputs "out"))
202 (kdevplatform (assoc-ref inputs "kdevplatform"))
203 (kio (assoc-ref inputs "kio"))
204 (kcmutils (assoc-ref inputs "kcmutils"))
205 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
206 (qtbase (assoc-ref inputs "qtbase"))
207 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
208 (qml "/qml"))
209 (wrap-program (string-append out "/bin/kdevelop")
210 `("XDG_DATA_DIRS" ":" prefix
211 ,(map (lambda (s) (string-append s "/share"))
212 (list out kdevplatform kcmutils)))
213 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
214 (,(string-append qtbase "/plugins/platforms")))
215 `("QT_PLUGIN_PATH" ":" prefix
216 ,(map (lambda (s) (string-append s "/lib/plugins"))
217 (list out kdevplatform kio)))
218 `("QML2_IMPORT_PATH" ":" prefix
219 (,(string-append qtquickcontrols qml)
220 ,(string-append qtdeclarative qml))))))))))
221 (home-page "https://kdevelop.org")
222 (synopsis "IDE for C, C++, Python, Javascript and PHP")
223 (description "The KDevelop IDE provides semantic syntax highlighting, as
224 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
225 JavaScript, Python and PHP. It also integrates with a debugger, different
226 build systems (CMake, QMake, custom Makefiles) and version control
227 software (Git, Subversion, Mercurial, CVS and Bazaar).")
228 (license license:lgpl2.1+)))
229
230 (define-public kdevelop-pg-qt
231 (package
232 (name "kdevelop-pg-qt")
233 (version "2.0.0")
234 (source
235 (origin
236 (method url-fetch)
237 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
238 version ".tar.gz"))
239 (file-name (string-append name "-" version ".tar.gz"))
240 (sha256
241 (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
242 (native-inputs
243 `(("extra-cmake-modules" ,extra-cmake-modules)))
244 (inputs
245 `(("qtbase" ,qtbase)))
246 (build-system cmake-build-system)
247 (home-page "https://kde.org")
248 (synopsis "Parser generator library for KDevplatform")
249 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
250 for some KDevelop language plugins (Ruby, PHP, CSS...).")
251 (license license:lgpl2.0+)))
252
253 (define-public kdevplatform
254 (package
255 (name "kdevplatform")
256 (version "5.1.2")
257 (source (origin
258 (method url-fetch)
259 (uri (string-append "mirror://kde/stable/kdevelop"
260 "/" version "/src/kdevplatform-"
261 version ".tar.xz"))
262 (sha256
263 (base32
264 "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
265 (build-system cmake-build-system)
266 (native-inputs
267 `(("extra-cmake-modules" ,extra-cmake-modules)
268 ("pkg-config" ,pkg-config)))
269 (inputs
270 `(("apr" ,apr)
271 ("apr-util" ,apr-util)
272 ("boost" ,boost)
273 ("karchive" ,karchive)
274 ("kconfigwidgets" ,kconfigwidgets)
275 ("kcmutils" ,kcmutils)
276 ("kiconthemes" ,kiconthemes)
277 ("kdeclarative" ,kdeclarative)
278 ("kdoctools" ,kdoctools)
279 ("kguiaddons" ,kguiaddons)
280 ("kinit" ,kinit)
281 ("kitemmodels" ,kitemmodels)
282 ("knewstuff" ,knewstuff)
283 ("knotifications" ,knotifications)
284 ("knotifyconfig" ,knotifyconfig)
285 ("kwindowsystem" ,kwindowsystem)
286 ("kio" ,kio)
287 ("ki18n" ,ki18n)
288 ("kparts" ,kparts)
289 ("kservice" ,kservice)
290 ("grantlee" ,grantlee)
291 ("libkomparediff2" ,libkomparediff2)
292 ("sonnet" ,sonnet)
293 ("threadweaver" ,threadweaver)
294 ("ktexteditor" ,ktexteditor)
295 ("qtbase" ,qtbase)
296 ("qtdeclarative" ,qtdeclarative)
297 ("qtscript" ,qtscript)
298 ("qtwebkit" ,qtwebkit)
299 ("qtx11extras" ,qtx11extras)
300 ("plasma" ,plasma-framework)
301 ("subversion" ,subversion)
302 ("zlib" ,zlib)))
303 (arguments
304 `(#:phases
305 (modify-phases %standard-phases
306 (delete 'check)
307 (add-after 'install 'check
308 (lambda* (#:key outputs #:allow-other-keys)
309 (let ((out (assoc-ref outputs "out")))
310 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
311 (setenv "QT_PLUGIN_PATH"
312 (string-append out "/lib/plugins:"
313 (getenv "QT_PLUGIN_PATH")))
314 (setenv "XDG_DATA_DIRS"
315 (string-append out "/share:"
316 (getenv "XDG_DATA_DIRS")))
317 (invoke "ctest" "-R" ; almost all tests require a display
318 "filteringstrategy|kdevvarlengtharray|kdevhash")))))))
319 (home-page "https://github.com/KDE/kdevplatform")
320 (synopsis "Framework to build integrated development environments (IDEs)")
321 (description "KDevPlatform is the basis of KDevelop and contains some
322 plugins, as well as code to create plugins, or complete applications.")
323 (license license:gpl3+)))
324
325 (define-public krita
326 (package
327 (name "krita")
328 (version "4.2.7.1")
329 (source (origin
330 (method url-fetch)
331 (uri (string-append
332 "mirror://kde/stable/krita/" version
333 "/krita-" version ".tar.gz"))
334 (sha256
335 (base32
336 "0gcwq1w09gmx53i2fir73l222p41299wagvhbvsxwrz0v3crzliy"))))
337 (build-system cmake-build-system)
338 (arguments
339 `(#:tests? #f
340 #:configure-flags
341 (list "-DBUILD_TESTING=OFF"
342 (string-append "-DCMAKE_CXX_FLAGS=-I"
343 (assoc-ref %build-inputs "ilmbase")
344 "/include/OpenEXR"))
345 #:phases
346 (modify-phases %standard-phases
347 ;; Ensure that icons are found at runtime.
348 ;; This works around <https://bugs.gnu.org/22138>.
349 (add-after 'install 'wrap-executable
350 (lambda* (#:key inputs outputs #:allow-other-keys)
351 (let ((out (assoc-ref outputs "out"))
352 (qt '("qtbase" "qtsvg")))
353 (wrap-program (string-append out "/bin/krita")
354 `("QT_PLUGIN_PATH" ":" prefix
355 ,(map (lambda (label)
356 (string-append (assoc-ref inputs label)
357 "/lib/qt5/plugins/"))
358 qt)))
359 #t))))))
360 (native-inputs
361 `(("curl" ,curl)
362 ("eigen" ,eigen)
363 ("extra-cmake-modules" ,extra-cmake-modules)
364 ("gettext-minimal" ,gettext-minimal)
365 ("kitemmodels" ,kitemmodels)
366 ("pkg-config" ,pkg-config)
367 ("qwt" ,qwt)
368 ("vc" ,vc)))
369 (inputs
370 `(("boost" ,boost)
371 ("exiv2" ,exiv2)
372 ("fftw" ,fftw)
373 ("gsl" ,gsl)
374 ("ilmbase" ,ilmbase)
375 ("karchive" ,karchive)
376 ("kcompletion" ,kcompletion)
377 ("kconfig" ,kconfig)
378 ("kcoreaddons" ,kcoreaddons)
379 ("kcrash" ,kcrash)
380 ("kguiaddons" ,kguiaddons)
381 ("ki18n" ,ki18n)
382 ("kiconthemes" ,kiconthemes)
383 ("kio" ,kio)
384 ("kitemviews" ,kitemviews)
385 ("kwidgetsaddons" ,kwidgetsaddons)
386 ("kwindowsystem" ,kwindowsystem)
387 ("kxmlgui" ,kxmlgui)
388 ("lcms" ,lcms)
389 ("libjpeg-turbo" ,libjpeg-turbo)
390 ("libpng" ,libpng)
391 ("libraw" ,libraw-0.18)
392 ("libtiff" ,libtiff)
393 ("libx11" ,libx11)
394 ("libxcb" ,libxcb)
395 ("libxi" ,libxi)
396 ("openexr" ,openexr)
397 ("perl" ,perl)
398 ("poppler-qt5" ,poppler-qt5)
399 ("qtbase" ,qtbase)
400 ("qtdeclarative" ,qtdeclarative)
401 ("qtmultimedia" ,qtmultimedia)
402 ("qtsvg" ,qtsvg)
403 ("qtx11extras" ,qtx11extras)
404 ("quazip" ,quazip)
405 ("zlib" ,zlib)))
406 (home-page "https://krita.org")
407 (synopsis "Digital painting application")
408 (description
409 "Krita is a professional painting tool designed for concept artists,
410 illustrators, matte and texture artists, and the VFX industry. Notable
411 features include brush stabilizers, brush engines and wrap-around mode.")
412 (license license:gpl2+)))
413
414 (define-public libkomparediff2
415 (package
416 (name "libkomparediff2")
417 (version "19.08.2")
418 (source
419 (origin
420 (method url-fetch)
421 (uri (string-append "mirror://kde/stable/applications/" version
422 "/src/libkomparediff2-" version ".tar.xz"))
423 (sha256
424 (base32 "1mvihd0xpkl8kryf5dvsfgpbgs9af8c9bzq8mmr74gfsvfb8ywy5"))))
425 (native-inputs
426 `(("extra-cmake-modules" ,extra-cmake-modules)
427 ("pkg-config" ,pkg-config)))
428 (inputs
429 `(("kcodecs" ,kcodecs)
430 ("kconfig" ,kconfig)
431 ("kcoreaddons" ,kcoreaddons)
432 ("ki18n" ,ki18n)
433 ("kio" ,kio)
434 ("kxmlgui" ,kxmlgui)
435 ("qtbase" ,qtbase)))
436 (build-system cmake-build-system)
437 (home-page "https://kde.org")
438 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
439 (description "Libkomparediff2 is a library to work with diffs and patches,
440 used in KDE development tools Kompare and KDevelop.")
441
442 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
443 ;; source archive
444 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
445
446 (define-public qca
447 (package
448 (name "qca")
449 (version "2.2.1")
450 (source
451 (origin
452 (method url-fetch)
453 (uri (string-append "mirror://kde/stable/qca/" version
454 "/qca-" version ".tar.xz"))
455 (sha256
456 (base32
457 "00kv1vsrc8fp556hm8s6yw3240vx3l4067q6vfxrb3gdwgcd45np"))))
458 (build-system cmake-build-system)
459 (native-inputs
460 `(("pkg-config" ,pkg-config)))
461 (inputs
462 `(("openssl" ,openssl)
463 ("qtbase" ,qtbase)))
464 (home-page "https://userbase.kde.org/QCA")
465 (synopsis "Libraries for the Qt Cryptographic Architecture")
466 (description "The Qt Cryptographic Architecture (QCA) provides a
467 straightforward and cross-platform API for a range of cryptographic features,
468 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
469 cards.")
470 (license license:lgpl2.1)))
471
472 (define-public kpmcore
473 (package
474 (name "kpmcore")
475 (version "4.0.1")
476 (source (origin
477 (method url-fetch)
478 (uri (string-append
479 "mirror://kde/stable/kpmcore"
480 "/" version "/src/"
481 name "-" version ".tar.xz"))
482 (sha256
483 (base32
484 "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))
485 (patches (search-patches "kpmcore-fix-tests.patch"
486 "kpmcore-remove-broken-test.patch"))))
487 (build-system cmake-build-system)
488 (native-inputs
489 `(("extra-cmake-modules" ,extra-cmake-modules)
490 ("pkg-config" ,pkg-config)))
491 (inputs
492 `(("kauth" ,kauth)
493 ("kcoreaddons" ,kcoreaddons)
494 ("ki18n" ,ki18n)
495 ("kwidgetsaddons" ,kwidgetsaddons)
496 ("qtbase" ,qtbase)
497 ("qca" ,qca)
498 ("util-linux" ,util-linux)))
499 (home-page "https://community.kde.org/Frameworks")
500 (synopsis "Library for managing partitions")
501 (description "Library for managing partitions.")
502 (license license:gpl3+)))
503
504 (define-public snorenotify
505 (package
506 (name "snorenotify")
507 (version "0.7.0")
508 (source
509 (origin
510 (method url-fetch)
511 (uri (string-append "mirror://kde/stable/snorenotify/"
512 version "/src/snorenotify-" version ".tar.xz"))
513 (sha256
514 (base32
515 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
516 (build-system cmake-build-system)
517 (arguments
518 `(#:tests? #f)) ; both tests fail, require display
519 (inputs
520 `(("extra-cmake-modules" ,extra-cmake-modules)
521 ("qtbase" ,qtbase)
522 ("qttools" ,qttools)))
523 (home-page "https://techbase.kde.org/Projects/Snorenotify")
524 (synopsis "Qt notification framework")
525 (description "Snorenotify is a multi platform Qt notification framework.
526 Using a plugin system it is possible to create notifications with many
527 different notification systems.")
528 (license license:lgpl3)))
529
530 (define-public kdeconnect
531 (package
532 (name "kdeconnect")
533 (version "1.3.5")
534 (source
535 (origin
536 (method url-fetch)
537 (uri (string-append "mirror://kde/stable/kdeconnect/"
538 version "/kdeconnect-kde-"
539 version ".tar.xz"))
540 (sha256
541 (base32
542 "02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
543 (build-system cmake-build-system)
544 (arguments
545 `(#:configure-flags '("-DBUILD_TESTING=ON")
546 #:tests? #f ; tests fail hard in our build environment
547 #:modules ((guix build cmake-build-system)
548 (guix build qt-utils)
549 (guix build utils))
550 #:imported-modules (,@%cmake-build-system-modules
551 (guix build qt-utils))
552 #:phases
553 (modify-phases %standard-phases
554 (add-before 'check 'check-setup
555 (lambda _
556 (setenv "QT_QPA_PLATFORM" "offscreen")
557 #t))
558 (add-after 'install 'wrap-executable
559 (lambda* (#:key outputs #:allow-other-keys)
560 (let ((out (assoc-ref outputs "out")))
561 (setenv "QT_PLUGIN_PATH"
562 (string-append out "/lib/qt5/plugins"
563 ":" (getenv "QT_PLUGIN_PATH")))
564 (wrap-qt-program out "../lib/libexec/kdeconnectd")
565 (wrap-qt-program out "kdeconnect-cli")
566 (wrap-qt-program out "kdeconnect-handler")
567 (wrap-qt-program out "kdeconnect-indicator"))
568 #t)))))
569 (native-inputs
570 `(("extra-cmake-modules" ,extra-cmake-modules)
571 ("kdoctools" ,kdoctools)
572 ("libxtst" ,libxtst)
573 ("pkg-config" ,pkg-config)
574 ("python" ,python-wrapper)))
575 (inputs
576 `(("kcmutils" ,kcmutils)
577 ("kconfigwidgets" ,kconfigwidgets)
578 ("kdbusaddons" ,kdbusaddons)
579 ("ki18n" ,ki18n)
580 ("kiconthemes" ,kiconthemes)
581 ("kio" ,kio)
582 ("knotifications" ,knotifications)
583 ("kwayland" ,kwayland)
584 ("libfakekey" ,libfakekey)
585 ("qca" ,qca)
586 ("qtbase" ,qtbase)
587 ("qtdeclarative" ,qtdeclarative)
588 ("qtx11extras" ,qtx11extras)))
589 (home-page "https://community.kde.org/KDEConnect")
590 (synopsis "Enable your devices to communicate with each other")
591 (description "KDE Connect is a project that enables all your devices to
592 communicate with each other. Here's a few things KDE Connect can do:
593 @enumerate
594 @item Receive your phone notifications on your desktop computer and reply to messages
595 @item Control music playing on your desktop from your phone
596 @item Use your phone as a remote control for your desktop
597 @item Run predefined commands on your PC from connected devices
598 @item Check your phones battery level from the desktop
599 @item Ring your phone to help finding it
600 @item Share files and links between devices
601 @item Browse your phone from the desktop
602 @item Control the desktop's volume from the phone
603 @end enumerate")
604 (properties `((upstream-name . "kdeconnect-kde")))
605 (license (list license:gpl2 license:gpl3)))) ; dual licensed
606
607 (define-public kqtquickcharts
608 (package
609 (name "kqtquickcharts")
610 (version "19.08.2")
611 (source
612 (origin
613 (method url-fetch)
614 (uri (string-append "mirror://kde/stable/applications/"
615 version "/src/kqtquickcharts-" version ".tar.xz"))
616 (sha256
617 (base32
618 "1yy9fyd8y4g25ljdsbil19qdf4j3mzmzl489sx7rqpm3lfdzjh9k"))))
619 (build-system cmake-build-system)
620 (native-inputs
621 `(("extra-cmake-modules" ,extra-cmake-modules)))
622 (inputs
623 `(("qtbase" ,qtbase)
624 ("qtdeclarative" ,qtdeclarative)))
625 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
626 (synopsis "Interactive charts for Qt Quick")
627 (description
628 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
629 charts.")
630 (license license:lgpl2.1+)))
631
632 (define-public kcachegrind
633 (package
634 (name "kcachegrind")
635 (version "19.04.1")
636 (source (origin
637 (method url-fetch)
638 (uri (string-append "mirror://kde/stable/applications/" version
639 "/src/kcachegrind-" version ".tar.xz"))
640 (sha256
641 (base32
642 "1hhsk64yp6q2xh8j269j4wp9y24ggmii861r6gf02mj1mbn2p1jb"))))
643 (build-system cmake-build-system)
644 (native-inputs
645 `(("extra-cmake-modules" ,extra-cmake-modules)
646 ("perl" ,perl)
647 ("python" ,python)
648 ("qttools" ,qttools)
649 ("kdoctools" ,kdoctools)))
650 (inputs
651 `(("qtbase" ,qtbase)
652 ("karchive" ,karchive)
653 ("ki18n" ,ki18n)
654 ("kio" ,kio)
655 ("kdbusaddons" ,kdbusaddons)))
656 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
657 ;; Python and PHP, respectively. These are optional and we ignore them
658 ;; for now.
659 (home-page "https://kcachegrind.github.io/html/Home.html")
660 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
661 (description
662 "The data files generated by the Callgrind of Valgrind, an application
663 profiler, can be loaded into KCachegrind for browsing the performance results.
664 There is also a command-line tool to get ASCII reports from data files without
665 the need to use KCachegrind.
666
667 The format of Callgrind output is documented. With conversion scripts,
668 KCachegrind is able to visualize output of other profilers like OProfile, a
669 system-wide profiler for Linux using statistical sampling with hardware
670 performance counters. There also exist converters for profiling output of
671 Python, PHP, and Perl.")
672 (license license:gpl2)))