gnu: Add bidiv.
[jackhill/guix/guix.git] / gnu / packages / patches / bidiv-update-fribidi.patch
1 https://sources.debian.org/data/main/b/bidiv/1.5-6/debian/patches/fribidi_019
2
3 Description: Fix building with fribidi 1.9
4 Author: أحمد المحمودي <aelmahmoudy@users.sourceforge.net>
5 Bug-Debian: http://bugs.debian.org/568130
6
7 --- a/bidiv.c
8 +++ b/bidiv.c
9 @@ -141,8 +141,9 @@ bidiv(FILE *fp)
10 */
11 if(c1<0x80||c1>0xbf){
12 ungetc(c1, fp);
13 - unicode_in[len]=
14 - fribidi_iso8859_8_to_unicode_c(c);
15 + fribidi_charset_to_unicode(
16 + FRIBIDI_CHAR_SET_ISO8859_8,
17 + &c, 1, &unicode_in[len]);
18 } else
19 unicode_in[len]=((c & 037) << 6) + (c1 & 077);
20 newline=0;
21 @@ -153,8 +154,9 @@ bidiv(FILE *fp)
22 In the future we will have a language
23 option, which will control this (as well
24 as the output encoding). */
25 - unicode_in[len]=
26 - fribidi_iso8859_8_to_unicode_c(c);
27 + fribidi_charset_to_unicode(
28 + FRIBIDI_CHAR_SET_ISO8859_8,
29 + &c, 1, &unicode_in[len]);
30 #else
31 in[len]=c;
32 #endif
33 @@ -206,11 +208,11 @@ bidiv(FILE *fp)
34 rtl_line=0;
35
36 if(out_utf8)
37 - fribidi_unicode_to_utf8(unicode_out, len,
38 - out);
39 + fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8,
40 + unicode_out, len, out);
41 else
42 - fribidi_unicode_to_iso8859_8(unicode_out, len,
43 - out);
44 + fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_ISO8859_8,
45 + unicode_out, len, out);
46 /* if rtl_line (i.e., base_dir is RL), and we didn't fill the
47 entire width, we need to pad with spaces. Maybe in the
48 future this should be an option.
49 --
50