gnu: python-oslosphinx: Update to 4.18.0.
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
5 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
8 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages openstack)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages gnupg)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages python-check)
31 #:use-module (gnu packages python-crypto)
32 #:use-module (gnu packages python-web)
33 #:use-module (gnu packages python-xyz)
34 #:use-module (gnu packages sphinx)
35 #:use-module (gnu packages ssh)
36 #:use-module (gnu packages time)
37 #:use-module (gnu packages tls)
38 #:use-module (gnu packages version-control)
39 #:use-module (gnu packages xml)
40 #:use-module (guix build-system python)
41 #:use-module (guix download)
42 #:use-module ((guix licenses)
43 #:select (asl2.0))
44 #:use-module (guix packages)
45 #:use-module (srfi srfi-1))
46
47 (define-public python-bandit
48 (package
49 (name "python-bandit")
50 (version "1.6.2")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (pypi-uri "bandit" version))
55 (sha256
56 (base32
57 "0rb034c99pyhb4a60z7f2kz40cjydhm8m9v2blaal1rmhlam7rs1"))))
58 (build-system python-build-system)
59 (arguments
60 ;; The tests are disabled to avoid a circular dependency with
61 ;; python-stestr.
62 `(#:tests? #f))
63 (propagated-inputs
64 `(("python-gitpython" ,python-gitpython)
65 ("python-pyyaml" ,python-pyyaml)
66 ("python-six" ,python-six)
67 ("python-stevedore" ,python-stevedore)))
68 (native-inputs
69 `(("python-pbr" ,python-pbr)))
70 (home-page "https://github.com/PyCQA/bandit")
71 (synopsis "Security oriented static analyser for python code")
72 (description "Bandit is a tool designed to find common security issues in
73 Python code. To do this Bandit processes each file, builds an AST from it,
74 and runs appropriate plugins against the AST nodes. Once Bandit has finished
75 scanning all the files it generates a report.")
76 (license asl2.0)))
77
78 (define-public python-cliff
79 (package
80 (name "python-cliff")
81 (version "3.5.0")
82 (source
83 (origin
84 (method url-fetch)
85 (uri (pypi-uri "cliff" version))
86 (sha256
87 (base32
88 "0n8pzr0mnn9lq2mykds69ij2xrn0fsirh4ndmkx0mzydbx5niysv"))))
89 (build-system python-build-system)
90 (arguments
91 `(#:tests? #f))
92 (native-inputs
93 `(("python-pbr" ,python-pbr)))
94 (propagated-inputs
95 `(("python-cmd2" ,python-cmd2)
96 ("python-prettytable" ,python-prettytable)
97 ("python-pyparsing" ,python-pyparsing)
98 ("python-pyyaml" ,python-pyyaml)
99 ("python-bandit" ,python-bandit)
100 ("python-stevedore" ,python-stevedore)))
101 (home-page "https://opendev.org/openstack/cliff")
102 (synopsis "Framework for building command line programs")
103 (description "The @code{cliff} framework allows creating multi-level
104 commands such as those of @command{subversion} and @command{git}, where the
105 main program handles some basic argument parsing and then invokes a
106 sub-command to do the work. It uses plugins to define sub-commands, output
107 formatters, and other extensions.")
108 (license asl2.0)))
109
110 (define-public python-debtcollector
111 (package
112 (name "python-debtcollector")
113 (version "1.19.0")
114 (source
115 (origin
116 (method url-fetch)
117 (uri (pypi-uri "debtcollector" version))
118 (sha256
119 (base32
120 "06c7vyn184y9f0lsrwaz13aq63hdz5fjrd191b8nifx6acsni42f"))))
121 (build-system python-build-system)
122 (propagated-inputs
123 `(("python-pbr" ,python-pbr)
124 ("python-six" ,python-six)
125 ("python-wrapt" ,python-wrapt)))
126 (native-inputs
127 `(;; Tests.
128 ("python-subunit" ,python-subunit)
129 ("python-testrepository" ,python-testrepository)
130 ("python-testtools" ,python-testtools)))
131 (home-page "https://www.openstack.org/")
132 (synopsis
133 "Find deprecated patterns and strategies in Python code")
134 (description
135 "This package provides a collection of Python deprecation patterns and
136 strategies that help you collect your technical debt in a non-destructive
137 manner.")
138 (properties `((python2-variant . ,(delay python2-debtcollector))))
139 (license asl2.0)))
140
141 (define-public python2-debtcollector
142 (let ((base (package-with-python2 (strip-python2-variant
143 python-debtcollector))))
144 (package
145 (inherit base)
146 (propagated-inputs
147 `(("python2-funcsigs" ,python2-funcsigs)
148 ,@(package-propagated-inputs base))))))
149
150 (define-public python-hacking
151 (package
152 (name "python-hacking")
153 (version "4.0.0")
154 (source
155 (origin
156 (method url-fetch)
157 (uri (pypi-uri "hacking" version))
158 (sha256
159 (base32
160 "062rvbkvbavqqz55f7q00ikwipkn5j0rdls1rrajdbfwgckjcrsm"))))
161 (build-system python-build-system)
162 (propagated-inputs
163 `(("python-flake8" ,python-flake8)))
164 (native-inputs
165 `( ;; Tests
166 ("python-coverage" ,python-coverage)
167 ("python-ddt" ,python-ddt)
168 ("python-dnspython" ,python-dnspython)
169 ("python-fixtures" ,python-fixtures)
170 ("python-eventlet" ,python-eventlet)
171 ("python-mock" ,python-mock)
172 ("python-monotonic" ,python-monotonic)
173 ("python-subunit" ,python-subunit)
174 ("python-stestr" ,python-stestr)
175 ("python-testscenarios" ,python-testscenarios)
176 ("python-testtools" ,python-testtools)))
177 (home-page "https://github.com/openstack-dev/hacking")
178 (synopsis "OpenStack hacking guideline enforcement")
179 (description
180 "Python-hacking is a set of flake8 plugins that test and enforce the
181 @uref{http://docs.openstack.org/developer/hacking/, OpenStack style
182 guidelines}.")
183 (license asl2.0)))
184
185 (define-public python-mox3
186 (package
187 (name "python-mox3")
188 (version "0.24.0")
189 (source
190 (origin
191 (method url-fetch)
192 (uri (pypi-uri "mox3" version))
193 (patches (search-patches "python-mox3-python3.6-compat.patch"))
194 (sha256
195 (base32
196 "0w58adwv7q9wzvmq9mlrk2asfk73myq9fpwy7mjkzsz3baa95zf5"))))
197 (build-system python-build-system)
198 (propagated-inputs
199 `(("python-fixtures" ,python-fixtures)
200 ("python-pbr" ,python-pbr)))
201 (native-inputs
202 `(("python-openstackdocstheme" ,python-openstackdocstheme)
203 ("python-sphinx" ,python-sphinx)
204 ("python-subunit" ,python-subunit)
205 ("python-testrepository" ,python-testrepository)
206 ("python-testtools" ,python-testtools)))
207 (home-page "https://www.openstack.org/")
208 (synopsis "Mock object framework for Python")
209 (description
210 "Mox3 is an unofficial port of the @uref{https://code.google.com/p/pymox/,
211 Google mox framework} to Python 3. It was meant to be as compatible
212 with mox as possible, but small enhancements have been made.")
213 (license asl2.0)))
214
215 (define-public python2-mox3
216 (package-with-python2 python-mox3))
217
218 (define-public python-openstackdocstheme
219 (package
220 (name "python-openstackdocstheme")
221 (version "1.18.1")
222 (source (origin
223 (method url-fetch)
224 (uri (pypi-uri "openstackdocstheme" version))
225 (sha256
226 (base32
227 "1ki5204rjdqjvr8xr9w2qc1z6b6d2i5jas0i70xzkf9njlzjzv2r"))))
228 (build-system python-build-system)
229 (arguments
230 ;; FIXME: Tests require an old version of python-hacking, which in
231 ;; turn depends on mox3 which depends on this package.
232 `(#:tests? #f))
233 (propagated-inputs
234 `(("python-dulwich" ,python-dulwich)
235 ("python-pbr" ,python-pbr)))
236 (native-inputs
237 `(("python-sphinx" ,python-sphinx)))
238 (home-page "https://docs.openstack.org/openstackdocstheme/latest/")
239 (synopsis "OpenStack Docs Theme")
240 (description
241 "This package provides themes and extensions for Sphinx for publishing
242 to docs.openstack.org and developer.openstack.org.")
243 (license asl2.0)))
244
245 (define-public python2-openstackdocstheme
246 (package-with-python2 python-openstackdocstheme))
247
248 (define-public python-os-client-config
249 (package
250 (name "python-os-client-config")
251 (version "1.12.0")
252 (source
253 (origin
254 (method url-fetch)
255 (uri (pypi-uri "os-client-config" version))
256 (sha256
257 (base32
258 "1vjn7667pswnmpqv6ngwyqm2xn46w90hi5b4pv2grwfz751cn1lf"))))
259 (build-system python-build-system)
260 (arguments
261 `(#:tests? #f)) ;; Circular dependency with python-oslotest
262 (propagated-inputs
263 `(("python-appdirs" ,python-appdirs)
264 ("python-pyyaml" ,python-pyyaml)))
265 (native-inputs
266 `(("python-pbr" ,python-pbr)
267 ("python-fixtures" ,python-fixtures)
268 ("python-mimeparse" ,python-mimeparse)
269 ("python-testrepository" ,python-testrepository)
270 ("python-testscenarios" ,python-testscenarios)
271 ("python-testtools" ,python-testtools)))
272 (home-page "https://www.openstack.org/")
273 (synopsis
274 "OpenStack Client Configuration Library")
275 (description
276 "The OpenStack Client Configuration Library is a library for collecting
277 client configuration for using an OpenStack cloud in a consistent and
278 comprehensive manner.")
279 (license asl2.0)))
280
281 (define-public python2-os-client-config
282 (package-with-python2 python-os-client-config))
283
284 (define-public python-os-testr
285 (package
286 (name "python-os-testr")
287 (version "0.8.0")
288 (source
289 (origin
290 (method url-fetch)
291 (uri (pypi-uri "os-testr" version))
292 (sha256
293 (base32
294 "0mknd9hlmxmihr755gjkxyjp180380jajq5i3zm34q7y7bi62lss"))))
295 (build-system python-build-system)
296 (arguments
297 ;; os-testr uses itself to run the tests. It seems like pbr writes the
298 ;; exectuable in the virtualenv when using tox. Not sure how to do this
299 ;; when building the package. Skip the tests for now.
300 `(#:tests? #f))
301 (propagated-inputs
302 `(("python-subunit" ,python-subunit)))
303 (native-inputs
304 `(("python-pbr" ,python-pbr)
305 ("python-testtools" ,python-testtools)
306 ("python-babel" ,python-babel)))
307 (home-page "https://www.openstack.org/")
308 (synopsis "Testr wrapper to provide functionality for OpenStack projects")
309 (description
310 "Os-testr provides developers with a testr wrapper and an output filter
311 for subunit.")
312 (license asl2.0)))
313
314 (define-public python2-os-testr
315 (package-with-python2 python-os-testr))
316
317 (define-public python-stevedore
318 (package
319 (name "python-stevedore")
320 (version "3.2.2")
321 (source
322 (origin
323 (method url-fetch)
324 (uri (pypi-uri "stevedore" version))
325 (sha256
326 (base32
327 "1w11lm293afzb73iq0ba9wnmr2rjwymnhr92km4a4xrs7a5qcigq"))))
328 (build-system python-build-system)
329 (arguments
330 ;; The tests are disabled to avoid a circular dependency with
331 ;; python-stestr.
332 `(#:tests? #f))
333 (native-inputs
334 `(("python-pbr" ,python-pbr)))
335 (home-page "https://github.com/dreamhost/stevedore")
336 (synopsis "Manage dynamic plugins for Python applications")
337 (description
338 "Python makes loading code dynamically easy, allowing you to configure
339 and extend your application by discovering and loading extensions (\"plugins\")
340 at runtime. Many applications implement their own library for doing this,
341 using __import__ or importlib. Stevedore avoids creating yet another extension
342 mechanism by building on top of setuptools entry points. The code for managing
343 entry points tends to be repetitive, though, so stevedore provides manager
344 classes for implementing common patterns for using dynamically loaded
345 extensions.")
346 (license asl2.0)))
347
348 (define-public python2-stevedore
349 (package-with-python2 python-stevedore))
350
351 (define-public python-tempest-lib
352 (package
353 (name "python-tempest-lib")
354 (version "1.0.0")
355 (source
356 (origin
357 (method url-fetch)
358 (uri (pypi-uri "tempest-lib" version))
359 (sha256
360 (base32
361 "1cpp2vwmawpd29hjsklsps181lq2ah91cl412qvpnz228nf9sqn5"))))
362 (build-system python-build-system)
363 (arguments
364 `(#:tests? #f ; FIXME: Requires oslo.log >= 1.14.0.
365 #:phases
366 (modify-phases %standard-phases
367 (add-before
368 'check 'pre-check
369 (lambda _
370 (substitute* "tempest_lib/tests/cli/test_execute.py"
371 (("/bin/ls") (which "ls"))))))))
372 (propagated-inputs
373 `(("python-fixtures" ,python-fixtures)
374 ("python-httplib2" ,python-httplib2)
375 ("python-iso8601" ,python-iso8601)
376 ("python-jsonschema" ,python-jsonschema)
377 ("python-oslo.log" ,python-oslo.log)
378 ("python-paramiko" ,python-paramiko)
379 ("python-pbr" ,python-pbr)
380 ("python-six" ,python-six)))
381 (native-inputs
382 `(("python-babel" ,python-babel)
383 ("python-mock" ,python-mock)
384 ("python-os-testr" ,python-os-testr)
385 ("python-oslotest" ,python-oslotest)))
386 (home-page "https://www.openstack.org/")
387 (synopsis "OpenStack functional testing library")
388 (description
389 "Tempest-lib is a functional testing library for OpenStack. It provides
390 common features used in Tempest.")
391 (license asl2.0)))
392
393 ;; Packages from the Oslo library
394 (define-public python-oslo.config
395 (package
396 (name "python-oslo.config")
397 (version "5.2.0")
398 (source
399 (origin
400 (method url-fetch)
401 (uri (pypi-uri "oslo.config" version))
402 (sha256
403 (base32
404 "0ymf7jxbq29fifyvkwhfiys1qvljqfxdw8ajwzwaf3yiqidgpxqd"))))
405 (build-system python-build-system)
406 (propagated-inputs
407 `(("python-debtcollector" ,python-debtcollector)
408 ("python-netaddr" ,python-netaddr)
409 ("python-oslo.i18n" ,python-oslo.i18n)
410 ("python-pbr" ,python-pbr)
411 ("python-rfc3986" ,python-rfc3986)
412 ("python-six" ,python-six)
413 ("python-stevedore" ,python-stevedore)
414 ("python-pyyaml" ,python-pyyaml)))
415 (native-inputs
416 `(("python-bandit" ,python-bandit)
417 ("python-coverage" ,python-coverage)
418 ("python-mock" ,python-mock)
419 ("python-openstackdocstheme" ,python-openstackdocstheme)
420 ("python-oslotest" ,python-oslotest)
421 ("python-reno" ,python-reno)
422 ("python-sphinx" ,python-sphinx)
423 ("python-testrepository" ,python-testrepository)
424 ("python-testscenarios" ,python-testscenarios)
425 ("python-testtools" ,python-testtools)))
426 (home-page "https://launchpad.net/oslo")
427 (synopsis "Oslo Configuration API")
428 (description
429 "The Oslo configuration API supports parsing command line arguments and
430 .ini style configuration files.")
431 (license asl2.0)))
432
433 (define-public python-oslo.context
434 (package
435 (name "python-oslo.context")
436 (version "3.1.1")
437 (source
438 (origin
439 (method url-fetch)
440 (uri (pypi-uri "oslo.context" version))
441 (sha256
442 (base32
443 "1l2z186rkd9acrb2ygf53yrdc1lgf7cy1akbhm21kgkzind4p2r6"))))
444 (build-system python-build-system)
445 (arguments
446 `(#:phases (modify-phases %standard-phases
447 (add-after 'unpack 'relax-requirements
448 (lambda _
449 (substitute* "test-requirements.txt"
450 (("hacking>=3.0.1,<3.1.0")
451 "hacking>=3.0.1"))
452 #t)))))
453 (propagated-inputs
454 `(("python-debtcollector" ,python-debtcollector)))
455 (native-inputs
456 `(("python-bandit" ,python-bandit)
457 ("python-coverage" ,python-coverage)
458 ("python-fixtures" ,python-fixtures)
459 ("python-hacking" ,python-hacking)
460 ("python-oslotest" ,python-oslotest)
461 ("python-pbr" ,python-pbr)
462 ("python-stestr" ,python-stestr)))
463 (home-page "https://launchpad.net/oslo")
464 (synopsis "Oslo context library")
465 (description
466 "The Oslo context library has helpers to maintain useful information
467 about a request context. The request context is usually populated in the WSGI
468 pipeline and used by various modules such as logging.")
469 (license asl2.0)))
470
471 (define-public python2-oslo.context
472 (package-with-python2 python-oslo.context))
473
474 (define-public python-oslo.i18n
475 (package
476 (name "python-oslo.i18n")
477 (version "3.20.0")
478 (source
479 (origin
480 (method url-fetch)
481 (uri (pypi-uri "oslo.i18n" version))
482 (sha256
483 (base32
484 "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
485 (build-system python-build-system)
486 (propagated-inputs
487 `(("python-babel" ,python-babel)
488 ("python-six" ,python-six)))
489 (native-inputs
490 `(("python-pbr" ,python-pbr)
491 ;; Tests
492 ("python-mock" ,python-mock)
493 ("python-mox3" ,python-mox3)
494 ("python-oslotest" ,python-oslotest)
495 ("python-testscenarios" ,python-testscenarios)))
496 (home-page "https://launchpad.net/oslo")
497 (synopsis "Oslo internationalization (i18n) library")
498 (description
499 "The oslo.i18n library contain utilities for working with
500 internationalization (i18n) features, especially translation for text strings
501 in an application or library.")
502 (license asl2.0)))
503
504 (define-public python2-oslo.i18n
505 (package-with-python2 python-oslo.i18n))
506
507 (define-public python-oslo.log
508 (package
509 (name "python-oslo.log")
510 (version "3.36.0")
511 (source
512 (origin
513 (method url-fetch)
514 (uri (pypi-uri "oslo.log" version))
515 (sha256
516 (base32
517 "0h7hplf1h8k24v75m3mq1jlrl74x5ynyr4hwgffsg5campxnza4x"))))
518 (build-system python-build-system)
519 (propagated-inputs
520 `(("python-dateutil" ,python-dateutil)
521 ("python-debtcollector" ,python-debtcollector)
522 ("python-monotonic" ,python-monotonic)
523 ("python-oslo.config" ,python-oslo.config)
524 ("python-oslo.context" ,python-oslo.context)
525 ("python-oslo.i18n" ,python-oslo.i18n)
526 ("python-oslo.utils" ,python-oslo.utils)
527 ("python-oslo.serialization" ,python-oslo.serialization)
528 ("python-pbr" ,python-pbr)
529 ("python-pyinotify" ,python-pyinotify)
530 ("python-six" ,python-six)))
531 (native-inputs
532 `(("python-mock" ,python-mock)
533 ("python-oslotest" ,python-oslotest)
534 ("python-subunit" ,python-subunit)
535 ("python-testrepository" ,python-testrepository)
536 ("python-testtools" ,python-testtools)))
537 (home-page "https://launchpad.net/oslo")
538 (synopsis "Python logging library of the Oslo project")
539 (description
540 "The oslo.log (logging) configuration library provides standardized
541 configuration for all OpenStack projects. It also provides custom formatters,
542 handlers and support for context specific logging (like resource id’s etc).")
543 (license asl2.0)))
544
545 (define-public python-oslo.serialization
546 (package
547 (name "python-oslo.serialization")
548 (version "2.24.0")
549 (source
550 (origin
551 (method url-fetch)
552 (uri (pypi-uri "oslo.serialization" version))
553 (sha256
554 (base32
555 "08bxkp98c617y58x630xq44iiffm7f0f3cwh6zbnlkgq0zgh7jk1"))))
556 (build-system python-build-system)
557 (propagated-inputs
558 `(("python-msgpack" ,python-msgpack)
559 ("python-netaddr" ,python-netaddr)
560 ("python-oslo.utils" ,python-oslo.utils)
561 ("python-six" ,python-six)
562 ("python-pytz" ,python-pytz)))
563 (native-inputs
564 `(("python-pbr" ,python-pbr)
565 ;; Tests.
566 ("python-mock" ,python-mock)
567 ("python-oslo.i18n" ,python-oslo.i18n)
568 ("python-oslotest" ,python-oslotest)))
569 (home-page "https://launchpad.net/oslo")
570 (synopsis "Oslo serialization library")
571 (description
572 "The oslo.serialization library provides support for representing objects
573 in transmittable and storable formats, such as JSON and MessagePack.")
574 (license asl2.0)))
575
576 (define-public python-reno
577 (package
578 (name "python-reno")
579 (version "2.7.0")
580 (source
581 (origin
582 (method url-fetch)
583 (uri (pypi-uri "reno" version))
584 (sha256
585 (base32 "0gwzi5dvacqx43smxl3rd1z33npn7gfhm50bvgmq90fib2q431wc"))))
586 (build-system python-build-system)
587 (arguments
588 `(#:phases
589 (modify-phases %standard-phases
590 (add-before 'check 'init-git
591 (lambda _
592 ;; reno expects a git repo
593 (invoke "git" "init"))))))
594 (propagated-inputs
595 `(("python-dulwich" ,python-dulwich)
596 ("python-pbr" ,python-pbr)
597 ("python-pyyaml" ,python-pyyaml)
598 ("python-six" ,python-six)))
599 (native-inputs
600 `(("python-testtools" ,python-testtools)
601 ("python-testscenarios" ,python-testscenarios)
602 ("python-testrepository" ,python-testrepository)
603 ("python-mock" ,python-mock)
604 ("python-docutils" ,python-docutils)
605 ("python-sphinx" ,python-sphinx)
606 ("gnupg" ,gnupg)
607 ("git" ,git-minimal)))
608 (home-page "https://docs.openstack.org/reno/latest/")
609 (synopsis "Release notes manager")
610 (description "Reno is a tool for storing release notes in a git repository
611 and building documentation from them.")
612 (license asl2.0)))
613
614 (define-public python2-reno
615 (package-with-python2 python-reno))
616
617 (define-public python-oslosphinx
618 (package
619 (name "python-oslosphinx")
620 (version "4.18.0")
621 (source
622 (origin
623 (method url-fetch)
624 (uri (pypi-uri "oslosphinx" version))
625 (sha256
626 (base32
627 "1xm41857vzrzjmnyi6bqirg4i5qa61v7wxcsdc4q1nzgr3ndgz5k"))))
628 (build-system python-build-system)
629 (arguments
630 `(#:phases
631 (modify-phases %standard-phases
632 (add-after 'unpack 'relax-requirements
633 (lambda _
634 (substitute* "test-requirements.txt"
635 (("hacking!=0.13.0,<0.14,>=0.12.0")
636 "hacking!=0.13.0,>=0.12.0"))
637 #t)))))
638 (propagated-inputs
639 `(("python-requests" ,python-requests)))
640 (native-inputs
641 `(("python-hacking" ,python-hacking)
642 ("python-openstackdocstheme" ,python-openstackdocstheme)
643 ("python-pbr" ,python-pbr)
644 ("python-reno" ,python-reno)
645 ("python-sphinx" ,python-sphinx)))
646 (home-page "https://www.openstack.org/")
647 (synopsis "OpenStack sphinx extensions and theme")
648 (description "This package provides themes and extensions for Sphinx
649 documentation from the OpenStack project.")
650 (license asl2.0)))
651
652 (define-public python-oslotest
653 (package
654 (name "python-oslotest")
655 (version "4.4.1")
656 (source
657 (origin
658 (method url-fetch)
659 (uri (pypi-uri "oslotest" version))
660 (sha256
661 (base32
662 "0r50sz55m8ljv2vk1k7sp88iz1iqq4p9w6kb8hn8g8c50r9zdi5i"))))
663 (build-system python-build-system)
664 (arguments
665 ;; The tests are disabled to avoid a circular dependency with oslo.config.
666 `(#:tests? #f))
667 (propagated-inputs
668 `(("python-fixtures" ,python-fixtures)
669 ("python-six" ,python-six)
670 ("python-subunit" ,python-subunit)
671 ("python-testtools" ,python-testtools)))
672 (home-page "https://launchpad.net/oslo")
673 (synopsis "Oslo test framework")
674 (description "The Oslo Test framework provides common fixtures, support
675 for debugging, and better support for mocking results.")
676 (license asl2.0)))
677
678 (define-public python2-oslotest
679 (package-with-python2 python-oslotest))
680
681 (define-public python-oslo.utils
682 (package
683 (name "python-oslo.utils")
684 (version "3.36.2")
685 (source
686 (origin
687 (method url-fetch)
688 (uri (pypi-uri "oslo.utils" version))
689 (sha256
690 (base32
691 "1ipjcgg9z697wmibhcbg5lqpk5gafakdx4qkff3w255zr0mvw04r"))))
692 (build-system python-build-system)
693 (propagated-inputs
694 `(("python-debtcollector" ,python-debtcollector)
695 ("python-oslo.i18n" ,python-oslo.i18n)
696 ("python-iso8601" ,python-iso8601)
697 ("python-monotonic" ,python-monotonic)
698 ("python-netaddr" ,python-netaddr)
699 ("python-netifaces" ,python-netifaces)
700 ("python-pyparsing" ,python-pyparsing)
701 ("python-pytz" ,python-pytz)
702 ("python-six" ,python-six)))
703 (native-inputs
704 `(("python-pbr" ,python-pbr)
705 ;; Tests.
706 ("python-bandit" ,python-bandit)
707 ("python-ddt" ,python-ddt)
708 ("python-fixtures" ,python-fixtures)
709 ("python-oslo.config" ,python-oslo.config)
710 ("python-oslotest" ,python-oslotest)
711 ("python-mock" ,python-mock)
712 ("python-testrepository" ,python-testrepository)
713 ("python-testscenarios" ,python-testscenarios)
714 ("python-testtools" ,python-testtools)))
715 (home-page "https://launchpad.net/oslo")
716 (synopsis "Oslo utility library")
717 (description
718 "The @code{oslo.utils} library provides support for common utility type
719 functions, such as encoding, exception handling, string manipulation, and time
720 handling.")
721 (license asl2.0)))
722
723 (define-public python-keystoneclient
724 (package
725 (name "python-keystoneclient")
726 (version "1.8.1")
727 (source
728 (origin
729 (method url-fetch)
730 (uri (pypi-uri "python-keystoneclient" version))
731 (sha256
732 (base32
733 "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
734 (build-system python-build-system)
735 (arguments
736 '(#:tests? #f)) ; FIXME: Many tests are failing.
737 (native-inputs
738 `(("python-sphinx" ,python-sphinx)
739 ;; and some packages for the tests
740 ("openssl" ,openssl)
741 ("python-coverage" ,python-coverage)
742 ("python-discover" ,python-discover)
743 ("python-fixtures" ,python-fixtures)
744 ("python-hacking" ,python-hacking)
745 ("python-keyring" ,python-keyring)
746 ("python-lxml" ,python-lxml)
747 ("python-mock" ,python-mock)
748 ("python-mox3" ,python-mox3)
749 ("python-oauthlib" ,python-oauthlib)
750 ("python-oslosphinx" ,python-oslosphinx)
751 ("python-oslotest" ,python-oslotest)
752 ("python-pycrypto" ,python-pycrypto)
753 ("python-requests-mock" ,python-requests-mock)
754 ("python-temptest-lib" ,python-tempest-lib)
755 ("python-testrepository" ,python-testrepository)
756 ("python-testresources" ,python-testresources)
757 ("python-testtools" ,python-testtools)
758 ("python-webob" ,python-webob)))
759 (propagated-inputs
760 `(("python-babel" ,python-babel)
761 ("python-debtcollector" ,python-debtcollector)
762 ("python-iso8601" ,python-iso8601)
763 ("python-netaddr" ,python-netaddr)
764 ("python-oslo.config" ,python-oslo.config)
765 ("python-oslo.i18n" ,python-oslo.i18n)
766 ("python-oslo.serialization" ,python-oslo.serialization)
767 ("python-oslo.utils" ,python-oslo.utils)
768 ("python-pbr" ,python-pbr)
769 ("python-prettytable" ,python-prettytable)
770 ("python-requests" ,python-requests)
771 ("python-six" ,python-six)
772 ("python-stevedore" ,python-stevedore)))
773 (home-page "https://www.openstack.org/")
774 (synopsis "Client Library for OpenStack Identity")
775 (description
776 "Python-keystoneclient is the identity service used by OpenStack for
777 authentication (authN) and high-level authorization (authZ). It currently
778 supports token-based authN with user/service authZ, and is scalable to support
779 OAuth, SAML, and OpenID in future versions. Out of the box, Keystone uses
780 SQLite for its identity store database, with the option to connect to external
781 LDAP.")
782 (license asl2.0)))
783
784 (define-public python-swiftclient
785 (package
786 (name "python-swiftclient")
787 (version "2.6.0")
788 (source
789 (origin
790 (method url-fetch)
791 (uri (pypi-uri "python-swiftclient" version))
792 (sha256
793 (base32
794 "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
795 (build-system python-build-system)
796 (native-inputs
797 `(("python-pbr" ,python-pbr)
798 ("python-sphinx" ,python-sphinx)
799 ;; The folloing packages are needed for the tests.
800 ("python-coverage" ,python-coverage)
801 ("python-discover" ,python-discover)
802 ("python-hacking" ,python-hacking)
803 ("python-mock" ,python-mock)
804 ("python-oslosphinx" ,python-oslosphinx)
805 ("python-keystoneclient" ,python-keystoneclient)
806 ("python-testrepository" ,python-testrepository)
807 ("python-testtools" ,python-testtools)))
808 (propagated-inputs
809 `(("python-requests" ,python-requests)
810 ("python-six" ,python-six)))
811 (home-page "https://www.openstack.org/")
812 (synopsis "OpenStack Object Storage API Client Library")
813 (description
814 "OpenStack Object Storage (code-named Swift) creates redundant, scalable
815 object storage using clusters of standardized servers to store petabytes of
816 accessible data. It is not a file system or real-time data storage system, but
817 rather a long-term storage system for a more permanent type of static data that
818 can be retrieved, leveraged, and then updated if necessary. Primary examples of
819 data that best fit this type of storage model are virtual machine images, photo
820 storage, email storage and backup archiving. Having no central \"brain\" or
821 master point of control provides greater scalability, redundancy and
822 permanence.")
823 (license asl2.0)))
824
825 (define-public python-git-review
826 (package
827 (name "python-git-review")
828 (version "1.28.0")
829 (source
830 (origin
831 (method url-fetch)
832 (uri (pypi-uri "git-review" version))
833 (sha256
834 (base32 "0nn17mfqvsa3ryjz53qjslmf60clc0vx2115kkj66h28p6vsnflf"))))
835 (build-system python-build-system)
836 (arguments
837 '(#:tests? #f ; tests require a running Gerrit server
838 #:phases
839 (modify-phases %standard-phases
840 (add-after 'install 'wrap-program
841 (lambda* (#:key inputs outputs #:allow-other-keys)
842 (let* ((out (assoc-ref outputs "out"))
843 (git (assoc-ref inputs "git"))
844 (openssh (assoc-ref inputs "openssh")))
845 (wrap-program (string-append out "/bin/git-review")
846 `("PATH" ":" prefix
847 ,(map (lambda (dir)
848 (string-append dir "/bin"))
849 (list git openssh)))))
850 #t)))))
851 (native-inputs
852 `(("python-pbr" ,python-pbr)))
853 (propagated-inputs
854 `(("python-requests" ,python-requests)))
855 (inputs
856 `(("git" ,git)
857 ("openssh" ,openssh)))
858 (home-page "https://docs.openstack.org/infra/git-review/")
859 (synopsis "Command-line tool for Gerrit")
860 (description
861 "Git-review is a command-line tool that helps submitting Git branches to
862 Gerrit for review, or fetching existing ones.")
863 (license asl2.0)))
864
865 (define-public python2-git-review
866 (package-with-python2 python-git-review))