gnu: libunwind: Add fix for CVE-2015-3239.
[jackhill/guix/guix.git] / gnu / packages / libunwind.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libunwind)
21 #:use-module (guix packages)
22 #:use-module (gnu packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix licenses))
26
27 (define-public libunwind
28 (package
29 (name "libunwind")
30 (version "1.1")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://savannah/libunwind/libunwind-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "16nhx2pahh9d62mvszc88q226q5lwjankij276fxwrm8wb50zzlx"))
38 (patches (list (search-patch "libunwind-CVE-2015-3239.patch")))))
39 (build-system gnu-build-system)
40 (arguments
41 ;; FIXME: As of glibc 2.17, we get 3 out of 34 test failures.
42 ;; Report them upstream.
43 '(#:tests? #f))
44 (home-page "http://www.nongnu.org/libunwind")
45 (synopsis "Determining the call chain of a program")
46 (description
47 "The primary goal of this project is to define a portable and efficient C
48 programming interface (API) to determine the call-chain of a program. The API
49 additionally provides the means to manipulate the preserved (callee-saved)
50 state of each call-frame and to resume execution at any point in the
51 call-chain (non-local goto). The API supports both local (same-process) and
52 remote (across-process) operation. As such, the API is useful in a number of
53 applications.")
54 (license x11)))