gnu: http-server: Fix build on i686-linux.
[jackhill/guix/guix.git] / gnu / packages / patches / superlu-dist-scotchmetis.patch
1 The METIS interface from Scotch may segfault if passed NULL to indicate a
2 default parameter, so use the older calling style.
3
4 --- a/SRC/get_perm_c.c 2014-05-16 23:38:30.070835316 -0500
5 +++ b/SRC/get_perm_c.c 2014-05-16 23:39:04.582836211 -0500
6 @@ -70,11 +70,13 @@
7 #else
8
9 /* Earlier version 3.x.x */
10 - /* METIS_NodeND(&nm, b_colptr, b_rowind, &numflag, metis_options,
11 - perm, iperm);*/
12 + METIS_NodeND(&nm, b_colptr, b_rowind, &numflag, metis_options,
13 + perm, iperm);
14
15 /* Latest version 4.x.x */
16 +#if 0
17 METIS_NodeND(&nm, b_colptr, b_rowind, NULL, NULL, perm, iperm);
18 +#endif
19
20 /*check_perm_dist("metis perm", n, perm);*/
21 #endif