gnu: http-server: Fix build on i686-linux.
[jackhill/guix/guix.git] / gnu / packages / patches / rust-openssl-sys-no-vendor.patch
1 https://sources.debian.org/data/main/r/rust-openssl-sys/0.9.53-1/debian/patches/disable-vendor.patch
2 "MIT" licensed according to debian/copyright file
3 slightly modified to only change the vendored openssl-src dependency
4
5 --- a/Cargo.toml
6 +++ b/Cargo.toml
7 @@ -31,14 +31,11 @@
8 [build-dependencies.cc]
9 version = "1.0"
10
11 -[build-dependencies.openssl-src]
12 -version = "111.0.1"
13 -optional = true
14 -
15 [build-dependencies.pkg-config]
16 version = "0.3.9"
17
18 [features]
19 vendored = ["openssl-src"]
20 +openssl-src = []
21 [target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
22 version = "0.2"
23