Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages libidn)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages libunistring)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
30
31 (define-public libidn
32 (package
33 (name "libidn")
34 (version "1.33")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/libidn/libidn-" version
38 ".tar.gz"))
39 (sha256
40 (base32
41 "068fjg2arlppjqqpzd714n1lf6gxkpac9v5yyvp1qwmv6nvam9s4"))))
42 (build-system gnu-build-system)
43 ;; FIXME: No Java and C# libraries are currently built.
44 (synopsis "Internationalized string processing library")
45 (description
46 "libidn is a library implementing of the Stringprep, Punycode and IDNA
47 specifications. These are used to encode and decode internationalized domain
48 names according to the IDNA2003 specifications. It includes native C, C# and
49 Java libraries.")
50 ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
51 ;; the command line tool is gpl3+.
52 (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
53 (home-page "https://www.gnu.org/software/libidn/")))
54
55 (define-public libidn2
56 (package
57 (name "libidn2")
58 (version "2.0.4")
59 (source (origin
60 (method url-fetch)
61 (uri (string-append "mirror://gnu/libidn/" name "-" version
62 ".tar.lz"))
63 (sha256
64 (base32
65 "00f2fyw5kwr9is3cdn5h9arzxp0lnvg0z9bb9zyfs0dq81gaqim4"))))
66 (native-inputs
67 `(("lzip" ,lzip)))
68 (inputs
69 `(("libunistring" ,libunistring)))
70 (build-system gnu-build-system)
71 (synopsis "Internationalized domain name library for IDNA2008")
72 (description "Libidn2 is an internationalized domain library implementing
73 the IDNA2008 specifications. Libidn2 is believed to be a complete IDNA2008
74 implementation, but has yet to be as extensively used as the original Libidn
75 library.")
76 (home-page "https://www.gnu.org/software/libidn/#libidn2")
77 (properties '((ftp-directory . "/gnu/libidn")))
78 ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
79 ;; GPL2+ or LGPL3+.
80 (license (list gpl2+ gpl3+ lgpl3+))))