gnu: offlineimap: Update to 7.0.12.
[jackhill/guix/guix.git] / gnu / packages / patches / hdf-eos5-fix-szip.patch
1 Ill-placed #endif causes missing symbol errors when compiling without
2 szip. Reported to upstream maintainer.
3 ---
4 src/EHapi.c | 3 +--
5 1 file changed, 1 insertion(+), 2 deletions(-)
6
7 diff --git a/src/EHapi.c b/src/EHapi.c
8 index 46a9b5c..208f447 100755
9 --- a/src/EHapi.c
10 +++ b/src/EHapi.c
11 @@ -11379,6 +11379,7 @@ int HE5_szip_can_encode(void )
12 return(-1);
13 }
14
15 +#endif /* H5_HAVE_FILTER_SZIP */
16
17
18 /*----------------------------------------------------------------------------|
19 @@ -11509,8 +11510,6 @@ HE5_EHHEisHE5(char *filename)
20 }
21 }
22
23 -#endif /* H5_HAVE_FILTER_SZIP */
24 -
25
26 #ifndef __cplusplus
27
28 --
29 2.10.0
30