Merge branch 'version-1.1.0'
[jackhill/guix/guix.git] / gnu / packages / patches / bastet-change-source-of-unordered_set.patch
1 From: Tobias Geerinckx-Rice <me@tobias.gr>
2 Date: Wed, 3 Oct 2018 23:30:42 +0200
3 Subject: [PATCH] bastet: Change source of unordered_set.
4
5 This allows building bastet 0.43.2 with boost >=1.66.
6 It was backported verbatim from the upstream master branch.
7
8 From 0e03f8d4d6bc6949cf1c447e632ce0d1b98c4be1 Mon Sep 17 00:00:00 2001
9 From: Federico Poloni <fpoloni@di.unipi.it>
10 Date: Wed, 4 Oct 2017 19:35:01 +0200
11 Subject: [PATCH] Changed source of unordered_set (should hopefully fix #6
12 without reopening #1)
13
14 ---
15 BastetBlockChooser.hpp | 5 ++---
16 1 file changed, 2 insertions(+), 3 deletions(-)
17
18 diff --git a/BastetBlockChooser.hpp b/BastetBlockChooser.hpp
19 index 992e556..7ee3b7c 100644
20 --- a/BastetBlockChooser.hpp
21 +++ b/BastetBlockChooser.hpp
22 @@ -23,8 +23,7 @@
23
24 #include "Well.hpp"
25
26 -#include <boost/tr1/tr1/unordered_set>
27 -#include <set>
28 +#include <boost/unordered_set.hpp>
29 #include <boost/functional/hash.hpp>
30
31 namespace Bastet{
32 @@ -75,7 +74,7 @@ namespace Bastet{
33 public:
34 Searcher(BlockType b, const Well *well, Vertex v, WellVisitor *visitor);
35 private:
36 - std::tr1::unordered_set<Vertex> _visited;
37 + boost::unordered_set<Vertex> _visited;
38 //std::set<Vertex> _visited; ^^ the above is more efficient, we need to do many inserts
39 BlockType _block;
40 const Well *_well;