gnu: Fix misplaced commas (unquote).
[jackhill/guix/guix.git] / gnu / packages / fonts.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Joshua Grant <tadni@riseup.net>
5 ;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
6 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
7 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
8 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
9 ;;; Copyright © 2016 Nils Gillmann <niasterisk@grrlz.net>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages fonts)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system trivial)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages zip)
35 #:use-module (gnu packages perl)
36 #:use-module (gnu packages xorg)
37 #:use-module (gnu packages pkg-config))
38
39 (define-public font-inconsolata
40 (package
41 (name "font-inconsolata")
42 (version "0.80")
43 (source (origin
44 (method url-fetch)
45 (uri "http://www.levien.com/type/myfonts/Inconsolata.otf")
46 (sha256
47 (base32
48 "06js6znbcf7swn8y3b8ki416bz96ay7d3yvddqnvi88lqhbfcq8m"))))
49 (build-system trivial-build-system)
50 (arguments
51 `(#:modules ((guix build utils))
52 #:builder (begin
53 (use-modules (guix build utils))
54 (let ((font-dir (string-append %output
55 "/share/fonts/opentype"))
56 (source (assoc-ref %build-inputs "source")))
57 (mkdir-p font-dir)
58 (copy-file source
59 (string-append font-dir "/" "inconsolata.otf"))))))
60 (native-inputs `(("source" ,source)))
61 (home-page "http://levien.com/type/myfonts/inconsolata.html")
62 (synopsis "Monospace font")
63 (description "A monospace font, designed for code listings and the like,
64 in print. With attention to detail for high resolution rendering.")
65 (license license:silofl1.1)))
66
67 (define-public font-ubuntu
68 (package
69 (name "font-ubuntu")
70 (version "0.80")
71 (source (origin
72 (method url-fetch)
73 (uri (string-append "http://font.ubuntu.com/download/ubuntu-font-family-"
74 version ".zip"))
75 (sha256
76 (base32
77 "0k4f548riq23gmw4zhn30qqkcpaj4g2ab5rbc3lflfxwkc4p0w8h"))))
78 (build-system trivial-build-system)
79 (arguments
80 `(#:modules ((guix build utils))
81 #:builder (begin
82 (use-modules (guix build utils)
83 (srfi srfi-26))
84
85 (let ((PATH (string-append (assoc-ref %build-inputs
86 "unzip")
87 "/bin"))
88 (font-dir (string-append %output
89 "/share/fonts/truetype"))
90 (doc-dir (string-append %output "/share/doc/"
91 ,name "-" ,version)))
92 (setenv "PATH" PATH)
93 (system* "unzip" (assoc-ref %build-inputs "source"))
94
95 (mkdir-p font-dir)
96 (mkdir-p doc-dir)
97 (chdir (string-append "ubuntu-font-family-" ,version))
98 (for-each (lambda (ttf)
99 (copy-file ttf
100 (string-append font-dir "/" ttf)))
101 (find-files "." "\\.ttf$"))
102 (for-each (lambda (doc)
103 (copy-file doc
104 (string-append doc-dir "/" doc)))
105 (find-files "." "\\.txt$"))))))
106 (native-inputs `(("source" ,source)
107 ("unzip" ,unzip)))
108 (home-page "http://font.ubuntu.com/")
109 (synopsis "The Ubuntu Font Family")
110 (description "The Ubuntu Font Family is a unique, custom designed font
111 that has a very distinctive look and feel. This package provides the
112 TrueType (TTF) files.")
113 (license
114 (license:non-copyleft
115 "http://font.ubuntu.com/ufl/ubuntu-font-licence-1.0.txt"
116 "Ubuntu Font License v1.0"))))
117
118 (define-public font-dejavu
119 (package
120 (name "font-dejavu")
121 (version "2.34")
122 (source (origin
123 (method url-fetch)
124 (uri (string-append "mirror://sourceforge/dejavu/"
125 version "/dejavu-fonts-ttf-"
126 version ".tar.bz2"))
127 (sha256
128 (base32
129 "0pgb0a3ngamidacmrvasg51ck3gp8gn93w6sf1s8snwzx4x2r9yh"))))
130 (build-system trivial-build-system)
131 (arguments
132 `(#:modules ((guix build utils))
133 #:builder (begin
134 (use-modules (guix build utils))
135
136 (let ((tar (string-append (assoc-ref %build-inputs
137 "tar")
138 "/bin/tar"))
139 (PATH (string-append (assoc-ref %build-inputs
140 "bzip2")
141 "/bin"))
142 (font-dir (string-append
143 %output "/share/fonts/truetype"))
144 (conf-dir (string-append
145 %output "/share/fontconfig/conf.avail"))
146 (doc-dir (string-append
147 %output "/share/doc/" ,name "-" ,version)))
148 (setenv "PATH" PATH)
149 (system* tar "xvf" (assoc-ref %build-inputs "source"))
150
151 (mkdir-p font-dir)
152 (mkdir-p conf-dir)
153 (mkdir-p doc-dir)
154 (chdir (string-append "dejavu-fonts-ttf-" ,version))
155 (for-each (lambda (ttf)
156 (copy-file ttf
157 (string-append font-dir "/"
158 (basename ttf))))
159 (find-files "ttf" "\\.ttf$"))
160 (for-each (lambda (conf)
161 (copy-file conf
162 (string-append conf-dir "/"
163 (basename conf))))
164 (find-files "fontconfig" "\\.conf$"))
165 (for-each (lambda (doc)
166 (copy-file doc
167 (string-append doc-dir "/"
168 (basename doc))))
169 (find-files "." "\\.txt$|^[A-Z][A-Z]*$"))))))
170 (native-inputs `(("source" ,source)
171 ("tar" ,tar)
172 ("bzip2" ,bzip2)))
173 (home-page "http://dejavu-fonts.org/")
174 (synopsis "Vera font family derivate with additional characters")
175 (description "DejaVu provides an expanded version of the Vera font family
176 aiming for quality and broader Unicode coverage while retaining the original
177 Vera style. DejaVu currently works towards conformance with the Multilingual
178 European Standards (MES-1 and MES-2) for Unicode coverage. The DejaVu fonts
179 provide serif, sans and monospaced variants.")
180 (license
181 (license:x11-style
182 "http://dejavu-fonts.org/"))))
183
184 (define-public font-bitstream-vera
185 (package
186 (name "font-bitstream-vera")
187 (version "1.10")
188 (source (origin
189 (method url-fetch)
190 (uri (string-append "mirror://gnome/sources/ttf-bitstream-vera/"
191 version "/ttf-bitstream-vera-"
192 version ".tar.bz2"))
193 (sha256
194 (base32
195 "1p3qs51x5327gnk71yq8cvmxc6wgx79sqxfvxcv80cdvgggjfnyv"))))
196 (build-system trivial-build-system)
197 (arguments
198 `(#:modules ((guix build utils))
199 #:builder (begin
200 (use-modules (guix build utils)
201 (srfi srfi-26))
202
203 (let ((tar (string-append (assoc-ref %build-inputs
204 "tar")
205 "/bin/tar"))
206 (PATH (string-append (assoc-ref %build-inputs
207 "bzip2")
208 "/bin"))
209 (font-dir (string-append %output
210 "/share/fonts/truetype"))
211 (doc-dir (string-append %output "/share/doc/"
212 ,name "-" ,version)))
213 (setenv "PATH" PATH)
214 (system* tar "xvf" (assoc-ref %build-inputs "source"))
215
216 (mkdir-p font-dir)
217 (mkdir-p doc-dir)
218 (chdir (string-append "ttf-bitstream-vera-" ,version))
219 (for-each (lambda (ttf)
220 (copy-file ttf
221 (string-append font-dir "/" ttf)))
222 (find-files "." "\\.ttf$"))
223 (for-each (lambda (doc)
224 (copy-file doc
225 (string-append doc-dir "/" doc)))
226 (find-files "." "\\.TXT$"))))))
227 (native-inputs `(("source" ,source)
228 ("tar" ,tar)
229 ("bzip2" ,bzip2)))
230 (home-page "http://www.gnome.org/fonts/")
231 (synopsis "Bitstream Vera sans-serif typeface")
232 (description "Vera is a sans-serif typeface from Bitstream, Inc. This
233 package provides the TrueType (TTF) files.")
234 (license
235 (license:x11-style
236 "http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
237
238 (define-public font-gnu-freefont-ttf
239 (package
240 (name "font-gnu-freefont-ttf")
241 (version "20100919")
242 (source (origin
243 (method url-fetch)
244 (uri (string-append "mirror://gnu/freefont/freefont-ttf-"
245 version ".tar.gz"))
246 (sha256
247 (base32
248 "1q3h5jp1mbdkinkwxy0lfd0a1q7azlbagraydlzaa2ng82836wg4"))))
249 (build-system trivial-build-system)
250 (arguments
251 `(#:modules ((guix build utils))
252 #:builder (begin
253 (use-modules (guix build utils)
254 (srfi srfi-26))
255
256 (let ((tar (string-append (assoc-ref %build-inputs
257 "tar")
258 "/bin/tar"))
259 (PATH (string-append (assoc-ref %build-inputs
260 "gzip")
261 "/bin"))
262 (font-dir (string-append %output
263 "/share/fonts/truetype"))
264 (doc-dir (string-append %output "/share/doc/"
265 ,name "-" ,version)))
266 (setenv "PATH" PATH)
267 (system* tar "xvf" (assoc-ref %build-inputs "source"))
268
269 (mkdir-p font-dir)
270 (mkdir-p doc-dir)
271 (chdir (string-append "freefont-" ,version))
272 (for-each (lambda (file)
273 (let ((dir (if (string-suffix? "ttf" file)
274 font-dir
275 doc-dir)))
276 (copy-file file
277 (string-append dir "/" file))))
278 (find-files "." ""))))))
279 (native-inputs `(("source" ,source)
280 ("tar" ,tar)
281 ("gzip" ,gzip)))
282 (home-page "http://www.gnu.org/software/freefont/")
283 (synopsis "Unicode-encoded outline fonts")
284 (description
285 "The GNU Freefont project aims to provide a set of free outline
286 (PostScript Type0, TrueType, OpenType...) fonts covering the ISO
287 10646/Unicode UCS (Universal Character Set).")
288 (license license:gpl3+)))
289
290 (define-public font-liberation
291 (package
292 (name "font-liberation")
293 (version "2.00.1")
294 (source (origin
295 (method url-fetch)
296 (uri (string-append "https://fedorahosted.org/releases/l/i/"
297 "liberation-fonts/liberation-fonts-ttf-"
298 version ".tar.gz"))
299 (sha256
300 (base32
301 "010m4zfqan4w04b6bs9pm3gapn9hsb18bmwwgp2p6y6idj52g43q"))))
302 (build-system trivial-build-system)
303 (arguments
304 `(#:modules ((guix build utils))
305 #:builder
306 (begin
307 (use-modules (guix build utils))
308
309 (let ((tar (string-append (assoc-ref %build-inputs "tar")
310 "/bin/tar"))
311 (PATH (string-append (assoc-ref %build-inputs "gzip")
312 "/bin"))
313 (font-dir (string-append %output "/share/fonts/truetype"))
314 (doc-dir (string-append %output "/share/doc/" ,name)))
315 (setenv "PATH" PATH)
316 (system* tar "xvf" (assoc-ref %build-inputs "source"))
317 (mkdir-p font-dir)
318 (mkdir-p doc-dir)
319 (chdir (string-append "liberation-fonts-ttf-" ,version))
320 (for-each (lambda (ttf)
321 (copy-file ttf
322 (string-append font-dir "/"
323 (basename ttf))))
324 (find-files "." "\\.ttf$"))
325 (for-each (lambda (doc)
326 (copy-file doc
327 (string-append doc-dir "/"
328 (basename doc))))
329 '("AUTHORS" "ChangeLog" "LICENSE" "README" "TODO"))))))
330 (native-inputs
331 `(("source" ,source)
332 ("tar" ,tar)
333 ("gzip" ,gzip)))
334 (home-page "https://fedorahosted.org/liberation-fonts/")
335 (synopsis
336 "Fonts compatible with Arial, Times New Roman, and Courier New")
337 (description
338 "The Liberation font family aims at metric compatibility with
339 Arial, Times New Roman, and Courier New.
340
341 There are three sets:
342
343 - Sans (a substitute for Arial, Albany, Helvetica, Nimbus Sans L, and
344 Bitstream Vera Sans);
345
346 - Serif (a substitute for Times New Roman, Thorndale, Nimbus Roman, and
347 Bitstream Vera Serif);
348
349 - Mono (a substitute for Courier New, Cumberland, Courier, Nimbus Mono L,
350 and Bitstream Vera Sans Mono).
351
352 The Liberation Fonts are sponsored by Red Hat.")
353 (license license:silofl1.1)))
354
355 (define-public font-terminus
356 (package
357 (name "font-terminus")
358 (version "4.40")
359 (source
360 (origin
361 (method url-fetch)
362 (uri (string-append
363 "mirror://sourceforge/project/terminus-font/terminus-font-"
364 version
365 "/terminus-font-"
366 version
367 ".tar.gz"))
368 (sha256
369 (base32
370 "0487cyx5h1f0crbny5sg73a22gmym5vk1i7646gy7hgiscj2rxb4"))))
371 (build-system gnu-build-system)
372 (native-inputs
373 `(("pkg-config" ,pkg-config)
374 ("perl" ,perl)
375 ("bdftopcf" ,bdftopcf)
376 ("font-util" ,font-util)
377 ("mkfontdir" ,mkfontdir)))
378 (arguments
379 `(#:configure-flags (list
380 ;; install fonts into subdirectory of package output
381 ;; instead of font-util-?.?.?/share/fonts/X11
382 (string-append "--with-fontrootdir="
383 %output "/share/fonts/X11"))
384 #:tests? #f)) ;; No test target in tarball
385 (home-page "http://terminus-font.sourceforge.net/")
386 (synopsis "Simple bitmap programming font")
387 (description "Terminus Font is a clean, fixed width bitmap font, designed
388 for long (8 and more hours per day) work with computers.")
389 (license license:silofl1.1)))
390
391 (define-public font-adobe-source-han-sans
392 (package
393 (name "font-adobe-source-han-sans")
394 (version "1.004")
395 (source (origin
396 (method url-fetch)
397 (uri (string-append
398 "https://github.com/adobe-fonts/source-han-sans/archive/"
399 version "R.tar.gz"))
400 (file-name (string-append "source-han-sans-" version "R.tar.gz"))
401 (sha256
402 (base32
403 "1ssx0fw90sy6mj8fv8fv4dgzszpqwbmwpjnlx16g4pvaqzdmybbz"))))
404 (outputs '("out" ; OpenType/CFF Collection (OTC), 121 MiB.
405 "cn" "jp" "kr" "tw")) ; Region-specific Subset OpenType/CFF.
406 (build-system trivial-build-system)
407 (arguments
408 `(#:modules ((guix build utils))
409 #:builder
410 (begin
411 (use-modules (guix build utils))
412 (let ((tar (string-append (assoc-ref %build-inputs
413 "tar")
414 "/bin/tar"))
415 (PATH (string-append (assoc-ref %build-inputs
416 "gzip")
417 "/bin"))
418 (install-opentype-fonts
419 (lambda (fonts-dir out)
420 (copy-recursively fonts-dir
421 (string-append (assoc-ref %outputs out)
422 "/share/fonts/opentype")))))
423 (setenv "PATH" PATH)
424 (system* tar "xvf" (assoc-ref %build-inputs "source"))
425 (chdir (string-append "source-han-sans-" ,version "R"))
426 (install-opentype-fonts "OTC" "out")
427 (install-opentype-fonts "SubsetOTF/CN" "cn")
428 (install-opentype-fonts "SubsetOTF/JP" "jp")
429 (install-opentype-fonts "SubsetOTF/KR" "kr")
430 (install-opentype-fonts "SubsetOTF/TW" "tw")
431 (for-each delete-file (find-files %output "\\.zip$"))))))
432 (native-inputs
433 `(("gzip" ,gzip)
434 ("tar" ,tar)))
435 (home-page "https://github.com/adobe-fonts/source-han-sans")
436 (synopsis "Pan-CJK fonts")
437 (description
438 "Source Han Sans is a sans serif Pan-CJK font family that is offered in
439 seven weights: ExtraLight, Light, Normal, Regular, Medium, Bold, and Heavy.
440 And in several OpenType/CFF-based deployment configurations to accommodate
441 various system requirements or limitations. As the name suggests, Pan-CJK
442 fonts are intended to support the characters necessary to render or display
443 text in Simplified Chinese, Traditional Chinese, Japanese, and Korean.")
444 (license license:silofl1.1)))
445
446 (define-public font-wqy-zenhei
447 (package
448 (name "font-wqy-zenhei")
449 (version "0.9.45")
450 (source (origin
451 (method url-fetch)
452 (uri (string-append
453 "mirror://sourceforge/wqy/wqy-zenhei-"
454 version ".tar.gz"))
455 (file-name (string-append "wqy-zenhei-" version ".tar.gz"))
456 (sha256
457 (base32
458 "1mkmxq8g2hjcglb3zajfqj20r4r88l78ymsp2xyl5yav8w3f7dz4"))))
459 (build-system trivial-build-system)
460 (arguments
461 `(#:modules ((guix build utils))
462 #:builder
463 (begin
464 (use-modules (guix build utils))
465 (let ((PATH (string-append (assoc-ref %build-inputs "tar") "/bin:"
466 (assoc-ref %build-inputs "gzip") "/bin"))
467 (font-dir (string-append (assoc-ref %outputs "out")
468 "/share/fonts/wenquanyi/")))
469 (setenv "PATH" PATH)
470 (mkdir-p font-dir)
471 (system* "tar" "xvf" (assoc-ref %build-inputs "source"))
472 (chdir "wqy-zenhei")
473 (copy-file "wqy-zenhei.ttc"
474 (string-append font-dir "wqy-zenhei.ttc"))))))
475 (native-inputs
476 `(("gzip" ,gzip)
477 ("tar" ,tar)))
478 (home-page "http://wenq.org/wqy2/")
479 (synopsis "CJK font")
480 (description
481 "WenQuanYi Zen Hei is a Hei-Ti style (sans-serif type) Chinese outline
482 font. It is designed for general purpose text formatting and on-screen
483 display of Chinese characters and symbols from many other languages.
484 WenQuanYi Zen Hei provides a rather complete coverage to Chinese Hanzi glyphs,
485 including both simplified and traditional forms. The total glyph number in
486 this font is over 35,000, including over 21,000 Chinese Hanzi. This font has
487 full coverage to GBK(CP936) charset, CJK Unified Ideographs, as well as the
488 code-points needed for zh_cn, zh_sg, zh_tw, zh_hk, zh_mo, ja (Japanese) and
489 ko (Korean) locales for fontconfig.")
490 ;; GPLv2 with font embedding exception
491 (license license:gpl2)))
492
493 (define-public font-tex-gyre
494 (package
495 (name "font-tex-gyre")
496 (version "2.005")
497 (source
498 (origin
499 (method url-fetch)
500 (uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
501 "tex-gyre/whole/tg-" version "otf.zip"))
502 (sha256
503 (base32
504 "0kph9l3g7jb2bpmxdbdg5zl56wacmnvdvsdn7is1gc750sqvsn31"))))
505 (build-system trivial-build-system)
506 (arguments
507 `(#:modules ((guix build utils))
508 #:builder
509 (begin
510 (use-modules (guix build utils))
511
512 (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
513 "/bin/unzip"))
514 (font-dir (string-append %output "/share/fonts/opentype")))
515 (mkdir-p font-dir)
516 (system* unzip
517 (assoc-ref %build-inputs "source")
518 "-d" font-dir)))))
519 (native-inputs
520 `(("unzip" ,unzip)))
521 (home-page "http://www.gust.org.pl/projects/e-foundry/tex-gyre/")
522 (synopsis "Remake of Ghostscript fonts")
523 (description "The TeX Gyre collection of fonts is the result of an
524 extensive remake and extension of the freely available base PostScript fonts
525 distributed with Ghostscript version 4.00. The collection contains the
526 following fonts in the OpenType format: Adventor, Bonum, Chorus, Cursor,
527 Heros, Pagella, Schola, Termes.")
528 (license license:gfl1.0)))
529
530 (define-public font-anonymous-pro
531 (package
532 (name "font-anonymous-pro")
533 (version "1.002")
534 (source (origin
535 (method url-fetch)
536 (uri (string-append
537 "http://www.marksimonson.com/assets/content/fonts/"
538 "AnonymousPro-" version ".zip"))
539 (sha256
540 (base32
541 "1asj6lykvxh46czbal7ymy2k861zlcdqpz8x3s5bbpqwlm3mhrl6"))))
542 (build-system trivial-build-system)
543 (arguments
544 `(#:modules ((guix build utils))
545 #:builder
546 (begin
547 (use-modules (guix build utils))
548 (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
549 "/bin/unzip"))
550 (font-dir (string-append %output "/share/fonts/truetype"))
551 (doc-dir (string-append %output "/share/doc/" ,name)))
552 (system* unzip (assoc-ref %build-inputs "source"))
553 (mkdir-p font-dir)
554 (mkdir-p doc-dir)
555 (chdir (string-append "AnonymousPro-" ,version ".001"))
556 (for-each (lambda (ttf)
557 (copy-file ttf
558 (string-append font-dir "/" ttf)))
559 (find-files "." "\\.ttf$"))
560 (for-each (lambda (doc)
561 (copy-file doc
562 (string-append doc-dir "/" doc)))
563 (find-files "." "\\.txt$"))))))
564 (native-inputs
565 `(("unzip" ,unzip)))
566 (home-page "http://www.marksimonson.com/fonts/view/anonymous-pro")
567 (synopsis "Fixed-width fonts designed with coding in mind")
568 (description "Anonymous Pro is a family of four fixed-width fonts designed
569 with coding in mind. Anonymous Pro features an international, Unicode-based
570 character set, with support for most Western and Central European Latin-based
571 languages, plus Greek and Cyrillic.")
572 (license license:silofl1.1)))
573
574 (define-public font-gnu-unifont
575 (package
576 (name "font-gnu-unifont")
577 (version "8.0.01")
578 (source (origin
579 (method url-fetch)
580 (uri (string-append
581 "mirror://gnu/unifont/unifont-8.0.01/unifont-"
582 version ".tar.gz"))
583 (sha256
584 (base32
585 "176bzc2y3i49xavrmbyyz5lkqp0qq3bkj7rjrl197kib873by82b"))))
586 (build-system gnu-build-system)
587 (outputs '("out" ; TrueType version
588 "pcf" ; PCF (bitmap) version
589 "psf" ; PSF (console) version
590 "bin" ; Utilities to manipulate '.hex' format
591 ))
592 (arguments
593 '(#:parallel-build? #f ; parallel build fails
594 #:tests? #f ; no check target
595 #:phases
596 (modify-phases %standard-phases
597 (replace 'configure
598 (lambda _
599 (setenv "CC" "gcc")))
600 (replace
601 'install
602 (lambda* (#:key outputs #:allow-other-keys)
603 (let* ((ttf (string-append (assoc-ref outputs "out")
604 "/share/fonts/truetype"))
605 (pcf (string-append (assoc-ref outputs "pcf")
606 "/share/fonts/misc"))
607 (psf (string-append (assoc-ref outputs "psf")
608 "/share/consolefonts"))
609 (bin (assoc-ref outputs "bin")))
610 (system* "make"
611 (string-append "PREFIX=" bin)
612 (string-append "TTFDEST=" ttf)
613 (string-append "PCFDEST=" pcf)
614 (string-append "CONSOLEDEST=" psf)
615 "install")
616 ;; Move Texinfo file to the right place.
617 (mkdir (string-append bin "/share/info"))
618 (rename-file (string-append bin "/share/unifont/unifont.info.gz")
619 (string-append bin "/share/info/unifont.info.gz"))
620 #t))))))
621 (inputs
622 `(("perl" ,perl))) ; for utilities
623 (synopsis
624 "Large bitmap font covering Unicode's Basic Multilingual Plane")
625 (description
626 "GNU Unifont is a bitmap font covering essentially all of
627 Unicode's Basic Multilingual Plane. The package also includes
628 utilities to ease adding new glyphs to the font.")
629 (home-page "http://unifoundry.com/unifont.html")
630 (license license:gpl2+)))