gnu: qemu: Remove dependency on Samba.
[jackhill/guix/guix.git] / gnu / packages / ocrad.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ocrad)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((gnu packages compression)
25 #:select (lzip)))
26
27 (define-public ocrad
28 (package
29 (name "ocrad")
30 (version "0.23")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/ocrad/ocrad-"
34 version ".tar.lz"))
35 (sha256
36 (base32
37 "0vx0v4sz8ivgcp04zggdq9cv9sb5zxnn7j1nm15cds0zq1wr9g7m"))))
38 (build-system gnu-build-system)
39 (native-inputs `(("lzip" ,lzip)))
40 (home-page "http://www.gnu.org/software/ocrad/")
41 (synopsis "Optical character recognition based on feature extraction")
42 (description
43 "GNU Ocrad is an optical character recognition program based on a
44 feature extraction method. It can read images in PBM, PGM or PPM formats and
45 it produces text in 8-bit or UTF-8 formats.")
46 (license gpl3+)))