gnu: qemu: Remove dependency on Samba.
[jackhill/guix/guix.git] / gnu / packages / groff.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages groff)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages ghostscript)
27 #:use-module (gnu packages netpbm)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages texinfo))
30
31 (define-public groff
32 (package
33 (name "groff")
34 (version "1.22.2")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/groff/groff-" version
38 ".tar.gz"))
39 (sha256 (base32
40 "0xi07nhj5vdgax37rj25mwxzdmsz1ifx50hjgc6hqbkpqkd6821q"))))
41 (build-system gnu-build-system)
42 (inputs `(("ghostscript" ,ghostscript)
43 ("netpbm" ,netpbm)))
44 (native-inputs `(("bison" ,bison)
45 ("perl" ,perl)
46 ("psutils" ,psutils)
47 ("texinfo" ,texinfo)))
48 (synopsis "Typesetting from plain text mixed with formatting commands")
49 (description
50 "Groff is a typesetting package that reads plain text and produces
51 formatted output based on formatting commands contained within the text. It
52 is usually the formatter of \"man\" documentation pages.")
53 (license gpl3+)
54 (home-page "http://www.gnu.org/software/groff/")))