gnu: texlive: Add inputs fontforge and ruby.
[jackhill/guix/guix.git] / gnu / packages / freeipmi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages freeipmi)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages readline)
25 #:use-module (gnu packages gnupg))
26
27 (define-public freeipmi
28 (package
29 (name "freeipmi")
30 (version "1.4.5")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "033zakrk3kvi4y41kslicr90b3yb2kj052cl6nbja7ybn70y9nkz"))))
38 (build-system gnu-build-system)
39 (inputs
40 `(("readline" ,readline) ("libgcrypt" ,libgcrypt)))
41 (home-page "http://www.gnu.org/software/freeipmi/")
42 (synopsis "Platform management, including sensor and power monitoring")
43 (description
44 "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
45 in accordance with the IPMI v1.5/2.0 specification. These programs provide a
46 set of interfaces for platform management. Common functionality includes
47 sensor monitoring, system event monitoring, power control and
48 serial-over-LAN.")
49 (license gpl3+)))