gnu: r-maldiquant: Move to (gnu packages cran).
[jackhill/guix/guix.git] / gnu / packages / gsasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages gsasl)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages libidn)
26 #:use-module (gnu packages gnupg)
27 #:use-module (gnu packages nettle)
28 #:use-module (gnu packages kerberos)
29 #:use-module (gnu packages tls)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix build-system gnu))
34
35 (define-public libntlm
36 (package
37 (name "libntlm")
38 (version "1.6")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append "https://www.nongnu.org/libntlm/releases/"
42 "libntlm-" version ".tar.gz"))
43 (sha256
44 (base32
45 "08b83nss16jsn213j326yhn1vnrz10k15fwq6jm5b1vdn23nndzj"))))
46 (build-system gnu-build-system)
47 (synopsis "Library that implements NTLM authentication")
48 (description
49 "Libntlm is a library that implements NTLM authentication.")
50 (license license:lgpl2.1+)
51 (home-page "https://www.nongnu.org/libntlm/")))
52
53 (define-public gss
54 (package
55 (name "gss")
56 (version "1.0.3")
57 (source (origin
58 (method url-fetch)
59 (uri (string-append "mirror://gnu/gss/gss-" version
60 ".tar.gz"))
61 (sha256 (base32
62 "1syyvh3k659xf1hdv9pilnnhbbhs6vfapayp4xgdcc8mfgf9v4gz"))))
63 (build-system gnu-build-system)
64 (inputs `(("nettle" ,nettle)
65 ("shishi" ,shishi)
66 ("zlib" ,zlib)))
67 (synopsis "Generic Security Service library")
68 (description
69 "The GNU Generic Security Service provides a free implementation of the
70 GSS-API specification. It provides a generic application programming
71 interface for programs to access security services. Security services present
72 a generic, GSS interface, with which the calling application interacts via
73 this library, freeing the application developer from needing to know about
74 the underlying security implementation.")
75 (license license:gpl3+)
76 (home-page "https://www.gnu.org/software/gss/")))
77
78 (define-public gsasl
79 (package
80 (name "gsasl")
81 (version "1.8.1")
82 (source (origin
83 (method url-fetch)
84 (uri (string-append "mirror://gnu/gsasl/gsasl-" version
85 ".tar.gz"))
86 (sha256
87 (base32
88 "1lnqfbaajkj1r2fx1db1qgcxy69pfgbyq7xd2kpvyxhra4m1dnjd"))))
89 (build-system gnu-build-system)
90 (arguments
91 `(#:configure-flags '("--with-gssapi-impl=mit"
92 "--disable-static")))
93 (inputs
94 `(("libgcrypt" ,libgcrypt)
95 ("libidn" ,libidn)
96 ("libntlm" ,libntlm)
97 ("mit-krb5" ,mit-krb5)
98 ("zlib" ,zlib)))
99 (propagated-inputs
100 ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
101 ;; propagated input of GnuTLS.
102 `(("gnutls" ,gnutls)))
103 (synopsis "Simple Authentication and Security Layer library")
104 (description
105 "GNU SASL is an implementation of the Simple Authentication and
106 Security Layer framework. On network servers such as IMAP or SMTP servers,
107 SASL is used to handle client/server authentication. This package contains
108 both a library and a command-line tool to access the library.")
109 (license license:gpl3+)
110 (home-page "https://www.gnu.org/software/gsasl/")))