gnu: r-maldiquant: Move to (gnu packages cran).
[jackhill/guix/guix.git] / gnu / packages / chicken.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
3 ;;; Copyright © 2020 Evan Hanson <evhan@foldling.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages chicken)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix download)
25 #:use-module (gnu packages commencement)
26 #:use-module ((guix licenses)
27 #:select (bsd-3)))
28
29 (define-public chicken
30 (package
31 (name "chicken")
32 (version "5.2.0")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "https://code.call-cc.org/releases/"
36 version "/chicken-" version ".tar.gz"))
37 (sha256
38 (base32
39 "1yl0hxm9cirgcp8jgxp6vv29lpswfvaw3zfkh6rsj0vkrv44k4c1"))))
40 (build-system gnu-build-system)
41 (arguments
42 `(#:modules ((guix build gnu-build-system)
43 (guix build utils)
44 (srfi srfi-1))
45
46 ;; No `configure' script; run "make check" after "make install" as
47 ;; prescribed by README.
48 #:phases
49 (modify-phases %standard-phases
50 (delete 'configure)
51 (delete 'check)
52 (add-after 'install 'check
53 (assoc-ref %standard-phases 'check)))
54
55 #:make-flags (let ((out (assoc-ref %outputs "out")))
56 (list "PLATFORM=linux"
57 (string-append "PREFIX=" out)
58 (string-append "VARDIR=" out "/var/lib")))
59
60 ;; Parallel builds are not supported, as noted in README.
61 #:parallel-build? #f))
62 (propagated-inputs `(("gcc-toolchain", gcc-toolchain)))
63 (home-page "https://www.call-cc.org/")
64 (synopsis "R5RS Scheme implementation that compiles native code via C")
65 (description
66 "CHICKEN is a compiler for the Scheme programming language. CHICKEN
67 produces portable and efficient C, supports almost all of the R5RS Scheme
68 language standard, and includes many enhancements and extensions.")
69 (license bsd-3)))