gnu: r-maldiquant: Move to (gnu packages cran).
[jackhill/guix/guix.git] / gnu / packages / acl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
7 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages acl)
25 #:use-module (guix licenses)
26 #:use-module (gnu packages attr)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages perl)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (gnu packages)
33 #:use-module (guix build-system gnu))
34
35 (define-public acl
36 (package
37 (name "acl")
38 (version "2.2.53")
39 (source
40 (origin
41 (method url-fetch)
42 (uri (string-append "mirror://savannah/acl/acl-"
43 version ".tar.gz"))
44 (sha256
45 (base32
46 "1ir6my3w74s6nfbgbqgzj6w570sn0qjf3524zx8xh67lqrjrigh6"))))
47 (build-system gnu-build-system)
48 (arguments
49 `(#:modules ((ice-9 ftw)
50 ,@%gnu-build-system-modules)
51 #:configure-flags '("--disable-static")
52 #:phases
53 (modify-phases %standard-phases
54 ;; XXX After repacking the sources the timestamps are reset to the
55 ;; epoch, which leads to a failure in gzipping the CHANGES file.
56 (add-after 'unpack 'ensure-no-mtimes-pre-1980
57 (lambda _
58 (let ((early-1980 315619200)) ; 1980-01-02 UTC
59 (ftw "." (lambda (file stat flag)
60 (unless (<= early-1980 (stat:mtime stat))
61 (utime file early-1980 early-1980))
62 #t))
63 #t)))
64 (add-after 'build 'patch-exec-bin-sh
65 (lambda _
66 (substitute* "test/run"
67 (("/bin/sh") (which "sh")))
68 #t))
69 (add-before 'check 'patch-tests
70 (lambda _
71 ;; The coreutils do not have an ACL bit to remove from their
72 ;; output, so the sed expression that removes the bit is disabled.
73 (substitute* "test/sbits-restore.test"
74 (("\\| sed.*'") ""))
75 ;; These tests require the existence of a user named "bin", but
76 ;; this user does not exist within Guix's build environment.
77 (substitute* "Makefile.in"
78 ((".*test/misc\\.test.*") "")
79 ((".*test/cp\\.test.*") "")
80 ((".*test/setfacl-X\\.test.*") ""))
81 #t)))))
82 (inputs `(("attr" ,attr)))
83 (native-inputs
84 `(("gettext" ,gettext-minimal)
85 ("perl" ,perl)))
86 (home-page "https://savannah.nongnu.org/projects/acl")
87 (synopsis
88 "Library and tools for manipulating access control lists")
89 (description
90 "Library and tools for manipulating access control lists.")
91 (license (list gpl2+ lgpl2.1+))))