Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / stalonetray.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages stalonetray)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:select (gpl2+))
24 #:use-module (gnu packages xorg))
25
26 (define-public stalonetray
27 (package
28 (name "stalonetray")
29 (version "0.8.1")
30 (source
31 (origin
32 (method url-fetch)
33 (uri
34 (string-append "mirror://sourceforge/stalonetray/stalonetray-"
35 version "/stalonetray-" version ".tar.bz2"))
36 (sha256
37 (base32
38 "1wp8pnlv34w7xizj1vivnc3fkwqq4qgb9dbrsg15598iw85gi8ll"))))
39 (inputs `(("libx11" ,libx11)))
40 (build-system gnu-build-system)
41 (home-page "stalonetray")
42 (synopsis "Standalone freedesktop.org and KDE systray implementation")
43 (description
44 "Stalonetray is a stand-alone freedesktop.org and KDE system
45 tray (notification area) for X Window System/X11 (e.g. X.Org or XFree86). It
46 has full XEMBED support and minimal dependencies: an X11 lib only. Stalonetray
47 works with virtually any EWMH-compliant window manager.")
48 (license gpl2+)))