gnu: texinfo: Update to 5.2.
[jackhill/guix/guix.git] / gnu / packages / texinfo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages texinfo)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages ncurses))
27
28 (define-public texinfo
29 (package
30 (name "texinfo")
31 (version "5.2")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/texinfo/texinfo-"
35 version ".tar.xz"))
36 (sha256
37 (base32
38 "1njfwh2z34r2c4r0iqa7v24wmjzvsfyz4vplzry8ln3479lfywal"))))
39 (build-system gnu-build-system)
40 (inputs `(("ncurses" ,ncurses)
41 ("xz" ,xz)
42 ("perl" ,perl)))
43 (home-page "http://www.gnu.org/software/texinfo/")
44 (synopsis "The GNU documentation format")
45 (description
46 "Texinfo is the official documentation format of the GNU project.
47 It was invented by Richard Stallman and Bob Chassell many years
48 ago, loosely based on Brian Reid's Scribe and other formatting
49 languages of the time. It is used by many non-GNU projects as
50 well.
51
52 Texinfo uses a single source file to produce output in a number
53 of formats, both online and printed (dvi, html, info, pdf, xml,
54 etc.). This means that instead of writing different documents
55 for online information and another for a printed manual, you
56 need write only one document. And when the work is revised, you
57 need revise only that one document. The Texinfo system is
58 well-integrated with GNU Emacs.")
59 (license gpl3+)))