gnu: rage: Update to 0.2.1.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages enlightenment)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system python)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages bash)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages curl)
31 #:use-module (gnu packages fontutils)
32 #:use-module (gnu packages fribidi)
33 #:use-module (gnu packages game-development)
34 #:use-module (gnu packages gettext)
35 #:use-module (gnu packages ghostscript)
36 #:use-module (gnu packages gl)
37 #:use-module (gnu packages glib)
38 #:use-module (gnu packages gnome)
39 #:use-module (gnu packages gstreamer)
40 #:use-module (gnu packages gtk)
41 #:use-module (gnu packages image)
42 #:use-module (gnu packages linux)
43 #:use-module (gnu packages lua)
44 #:use-module (gnu packages pdf)
45 #:use-module (gnu packages photo)
46 #:use-module (gnu packages pkg-config)
47 #:use-module (gnu packages pulseaudio)
48 #:use-module (gnu packages python)
49 #:use-module (gnu packages tls)
50 #:use-module (gnu packages video)
51 #:use-module (gnu packages xorg))
52
53 (define-public efl
54 (package
55 (name "efl")
56 (version "1.18.0")
57 (source (origin
58 (method url-fetch)
59 (uri (string-append
60 "https://download.enlightenment.org/rel/libs/efl/efl-"
61 version ".tar.xz"))
62 (sha256
63 (base32
64 "17mzbjmz8d2vs8p63r1sk3mppl3l2fhxy2jv24dp75lgqbsvp806"))))
65 (build-system gnu-build-system)
66 (native-inputs
67 `(("pkg-config" ,pkg-config)))
68 (inputs
69 `(("alsa-lib" ,alsa-lib)
70 ("compositeproto" ,compositeproto)
71 ("curl" ,curl)
72 ("ghostscript" ,ghostscript)
73 ("giflib" ,giflib)
74 ("gstreamer" ,gstreamer)
75 ("gst-plugins-base" ,gst-plugins-base)
76 ("libexif" ,libexif)
77 ("libjpeg" ,libjpeg)
78 ("libraw" ,libraw)
79 ("librsvg" ,librsvg)
80 ("libspectre" ,libspectre)
81 ("libtiff" ,libtiff)
82 ("libx11" ,libx11)
83 ("libxcomposite" ,libxcomposite)
84 ("libxcursor" ,libxcursor)
85 ("libxdmcp" ,libxdmcp)
86 ("libxext" ,libxext)
87 ("libxi" ,libxi)
88 ("libxkbfile" ,libxkbfile)
89 ("libxinerama" ,libxinerama)
90 ("libxp" ,libxp)
91 ("libxrandr" ,libxrandr)
92 ("libxscrnsaver" ,libxscrnsaver)
93 ("libxtst" ,libxtst)
94 ("lz4" ,lz4)
95 ("mesa" ,mesa)
96 ("openjpeg" ,openjpeg-1)
97 ("poppler" ,poppler)
98 ("printproto" ,printproto)
99 ("scrnsaverproto" ,scrnsaverproto)
100 ("xextproto" ,xextproto)
101 ("xinput" ,xinput)
102 ("xpr" ,xpr)
103 ("xproto" ,xproto)))
104 (propagated-inputs
105 ;; All these inputs are in package config files in section
106 ;; Require.private.
107 `(("bullet" ,bullet) ; ephysics.pc
108 ("dbus" ,dbus) ; eldbus.pc, elementary.pc, elocation.pc, ethumb_client.pc
109 ("eudev" ,eudev) ; eeze.pc
110 ("fontconfig" ,fontconfig) ; evas.pc, evas-cxx.pc
111 ("freetype" ,freetype) ; evas.pc, evas-cxx.pc
112 ("fribidi" ,fribidi) ; evas.pc, evas-cxx.pc
113 ("glib" ,glib) ; ecore.pc, ecore-cxx.pc
114 ("harfbuzz" ,harfbuzz) ; evas.pc, evas-cxx.pc
115 ("luajit" ,luajit) ; elua.pc, evas.pc, evas-cxx.pc
116 ("libpng" ,libpng) ; evas.pc, evas-cxx.pc
117 ("libsndfile" ,libsndfile) ; ecore-audio.pc, ecore-audio-cxx.pc
118 ("openssl" ,openssl) ; ecore-con.pc, eet.pc, eet-cxx.pc, emile.pc
119 ("pulseaudio" ,pulseaudio) ; ecore-audio.pc, ecore-audio-cxx.pc
120 ("util-linux" ,util-linux) ; eeze.pc
121 ("zlib" ,zlib))) ; eet.pc, eet-cxx.pc, emile.pc
122 (arguments
123 `(#:configure-flags '("--disable-silent-rules"
124 "--enable-liblz4"
125 "--enable-harfbuzz")
126 #:phases
127 (modify-phases %standard-phases
128 ;; ecore_audio cannot find pulseaudio or libsndfile when compiled.
129 ;; Starting in version 1.18.0, these two libraries are dlopened so
130 ;; we hardcode their locations as a temporary workaround.
131 (add-after 'configure 'hardlink-dlopen-files
132 (lambda _
133 (substitute* "src/lib/ecore_audio/ecore_audio.c"
134 (("libpulse.so.0")
135 (string-append (assoc-ref %build-inputs "pulseaudio")
136 "/lib/libpulse.so.0")))
137 (substitute* "src/lib/ecore_audio/ecore_audio.c"
138 (("libsndfile.so.1")
139 (string-append (assoc-ref %build-inputs "libsndfile")
140 "/lib/libsndfile.so.1")))
141 #t)))))
142 (home-page "https://www.enlightenment.org")
143 (synopsis "Enlightenment Foundation Libraries")
144 (description
145 "Enlightenment Foundation Libraries is a set of libraries developed
146 for Enlightenment. Libraries covers data serialization, wide support for
147 graphics rendering, UI layout and themes, interaction with OS, access to
148 removable devices or support for multimedia.")
149 ;; Different parts are under different licenses.
150 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
151
152 (define-public elementary
153 (package
154 (name "elementary")
155 (version "1.17.1")
156 (source (origin
157 (method url-fetch)
158 (uri
159 (string-append "https://download.enlightenment.org/rel/libs/"
160 "elementary/elementary-" version ".tar.xz"))
161 (sha256
162 (base32
163 "149xjq4z71l44w1kd8zks9b2g0wjc9656w46hzd27b58afj1dqc5"))))
164 (build-system gnu-build-system)
165 (native-inputs
166 `(("pkg-config" ,pkg-config)))
167 (propagated-inputs
168 `(("efl" ,efl))) ; elementary.pc, elementary-cxx.pc
169 (home-page "https://www.enlightenment.org")
170 (synopsis "Widget library of Enlightenment world")
171 (description
172 "Elementary is a widget library/toolkit, part of the Enlightenment
173 Foundation Libraries. It is build upon Edje and Evas libraries and uses
174 full capabilities of EFL.")
175 (license license:lgpl2.1)))
176
177 (define-public evas-generic-loaders
178 (package
179 (name "evas-generic-loaders")
180 (version "1.17.0")
181 (source (origin
182 (method url-fetch)
183 (uri
184 (string-append
185 "https://download.enlightenment.org/rel/libs/"
186 "evas_generic_loaders/evas_generic_loaders-"
187 version ".tar.xz"))
188 (sha256
189 (base32
190 "0ynq1nx0bfgg19p4vki1fap36yyip53zaxpzncx2slr6jcx1kxf2"))))
191 (build-system gnu-build-system)
192 (native-inputs
193 `(("pkg-config" ,pkg-config)))
194 (inputs
195 `(("efl" ,efl)
196 ("gstreamer" ,gstreamer)
197 ("gst-plugins-base" ,gst-plugins-base)
198 ("librsvg" ,librsvg)
199 ("libspectre" ,libspectre)
200 ("poppler" ,poppler)))
201 (home-page "https://www.enlightenment.org")
202 (synopsis "Plugins for integration of various file types into Evas")
203 (description
204 "Evas-generic-loaders is a collection of interfaces to outside libraries
205 and applications allowing to natively open pictures, documents and media
206 files in Evas (EFL canvas library).")
207 (license license:gpl2+)))
208
209 (define-public emotion-generic-players
210 (package
211 (name "emotion-generic-players")
212 (version "1.17.0")
213 (source (origin
214 (method url-fetch)
215 (uri
216 (string-append "https://download.enlightenment.org/rel/libs/"
217 "emotion_generic_players/emotion_generic_players"
218 "-" version ".tar.xz"))
219 (sha256
220 (base32
221 "03kaql95mk0c5j50v3c5i5lmlr3gz7xlh8p8q87xz8zf9j5h1pp7"))))
222 (build-system gnu-build-system)
223 (native-inputs
224 `(("pkg-config" ,pkg-config)))
225 (inputs
226 `(("efl" ,efl)
227 ("vlc" ,vlc)))
228 (home-page "https://www.enlightenment.org")
229 (synopsis "Plugins for integrating media players in EFL based applications")
230 (description
231 "Emotion-generic-players is a collection of interfaces to outside libraries
232 and applications allowing to natively play video files through Emotion.
233 The only supported now is VLC.")
234 (license license:bsd-2)))
235
236 (define-public terminology
237 (package
238 (name "terminology")
239 (version "0.9.1")
240 (source (origin
241 (method url-fetch)
242 (uri
243 (string-append "https://download.enlightenment.org/rel/apps/"
244 "terminology/terminology-" version ".tar.xz"))
245 (sha256
246 (base32
247 "1kwv9vkhngdm5v38q93xpcykghnyawhjjcb5bgy0p89gpbk7mvpc"))))
248 (build-system gnu-build-system)
249 (native-inputs
250 `(("pkg-config" ,pkg-config)))
251 (inputs
252 `(("efl" ,efl)))
253 (home-page "https://www.enlightenment.org")
254 (synopsis "Powerful terminal emulator based on EFL")
255 (description
256 "Terminology is fast and feature rich terminal emulator. It is solely
257 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
258 URL and local path detection, themes, popup based content viewer for non-text
259 contents and more.")
260 (license license:bsd-2)))
261
262 (define-public rage
263 (package
264 (name "rage")
265 (version "0.2.1")
266 (source (origin
267 (method url-fetch)
268 (uri
269 (string-append
270 "https://download.enlightenment.org/rel/apps/rage/rage-"
271 version ".tar.xz"))
272 (sha256
273 (base32
274 "06kbgcnbhl9clhdl7k983m4d0n6ggsl4qvizzi1nrp8c7np87fix"))))
275 (build-system gnu-build-system)
276 (native-inputs
277 `(("pkg-config" ,pkg-config)))
278 (inputs
279 `(("efl" ,efl)))
280 (home-page "https://www.enlightenment.org/about-rage")
281 (synopsis "Video and audio player based on EFL")
282 (description
283 "Rage is a video and audio player written with Enlightenment Foundation
284 Libraries with some extra bells and whistles.")
285 (license license:bsd-2)))
286
287 (define-public enlightenment
288 (package
289 (name "enlightenment")
290 (version "0.21.2")
291 (source (origin
292 (method url-fetch)
293 (uri
294 (string-append "https://download.enlightenment.org/rel/apps/"
295 name "/" name "-" version ".tar.xz"))
296 (sha256
297 (base32
298 "0fi5dxrprnvhnn2y51gnfpsjj44snriqi20k20a73vhaqxfn8xx8"))))
299 (build-system gnu-build-system)
300 (arguments
301 `(#:configure-flags '("--enable-mount-eeze")))
302 (native-inputs
303 `(("gettext" ,gnu-gettext)
304 ("pkg-config" ,pkg-config)))
305 (inputs
306 `(("alsa-lib" ,alsa-lib)
307 ("dbus" ,dbus)
308 ("efl" ,efl)
309 ("freetype" ,freetype)
310 ("libxcb" ,libxcb)
311 ("libxext" ,libxext)
312 ("linux-pam" ,linux-pam)
313 ("xcb-util-keysyms" ,xcb-util-keysyms)))
314 (home-page "https://www.enlightenment.org")
315 (synopsis "Lightweight desktop environment")
316 (description
317 "Enlightenment is resource friendly desktop environment with integrated
318 file manager, wide range of configuration options, plugin system allowing to
319 unload unused functionality, with support for touchscreen and suitable for
320 embedded systems.")
321 (license license:bsd-2)))
322
323 (define-public python-efl
324 (package
325 (name "python-efl")
326 (version "1.18.0")
327 (source
328 (origin
329 (method url-fetch)
330 (uri (pypi-uri "python-efl" version))
331 (sha256
332 (base32
333 "0x49rb7mx7ysjp23m919r2rx8qnl4xackhl9s9x2697m7cs77n1r"))))
334 (build-system python-build-system)
335 (arguments
336 '(#:phases
337 (modify-phases %standard-phases
338 (replace 'build
339 (lambda _
340 (zero?
341 (system* "env" "ENABLE_CYTHON=1" "python" "setup.py" "build"))))
342 (add-before 'build 'set-flags
343 (lambda _
344 (setenv "CFLAGS"
345 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
346 "/include/dbus-1.0")))))))
347 (native-inputs
348 `(("pkg-config" ,pkg-config)
349 ("python-cython" ,python-cython)))
350 (inputs
351 `(("efl" ,efl)
352 ("python-dbus" ,python-dbus)))
353 (home-page "https://www.enlightenment.org/")
354 (synopsis "Python bindings for EFL")
355 (description
356 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
357 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
358 (license license:lgpl3)))
359
360 (define-public python2-efl
361 (package-with-python2 python-efl))