gnu: Remove ".git" from "https://github/…/….git".
[jackhill/guix/guix.git] / gnu / packages / stenography.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages stenography)
20 #:use-module (guix build-system python)
21 #:use-module (guix git-download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages check)
26 #:use-module (gnu packages libusb)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-xyz)
29 #:use-module (gnu packages wxwidgets))
30
31 (define-public plover
32 (package
33 (name "plover")
34 (version "3.1.1")
35 (source
36 (origin
37 (method git-fetch)
38 (uri (git-reference
39 (url "https://github.com/openstenoproject/plover")
40 (commit (string-append "v" version))))
41 (file-name (git-file-name name version))
42 (sha256
43 (base32 "114rlxvq471fyifwcdcgdad79ak7q3w2lk8z9nqhz1i9fg05721c"))))
44 (build-system python-build-system)
45 (arguments
46 `(#:python ,python-2))
47 (native-inputs
48 `(("python2-mock" ,python2-mock)
49 ("python2-pytest" ,python2-pytest)
50 ("python2-setuptools-scm" ,python2-setuptools-scm)))
51 (inputs
52 `(("python2-appdirs" ,python2-appdirs)
53 ("python2-dbus" ,python2-dbus)
54 ("python2-hidapi" ,python2-hidapi)
55 ("python2-pyserial" ,python2-pyserial)
56 ("python2-wxpython" ,python2-wxpython)
57 ("python2-xlib" ,python2-xlib)))
58 (home-page "https://www.openstenoproject.org/plover/")
59 (synopsis "Stenography engine")
60 (description
61 "Plover (rhymes with @emph{lover}) is a desktop application that
62 allows anyone to use stenography to write on their computer, up to
63 speeds of 200WPM and beyond.")
64 (license license:gpl2+)))
65