gnu: Remove ".git" from "https://github/…/….git".
[jackhill/guix/guix.git] / gnu / packages / lolcode.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Nikita <nikita@n0.is>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages lolcode)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages python)
23 #:use-module (gnu packages readline)
24 #:use-module (guix build-system cmake)
25 #:use-module (guix git-download)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages))
28
29 (define-public lci
30 (package
31 (name "lci")
32 (version "0.11.2")
33 (source
34 (origin
35 (method git-fetch)
36 (uri (git-reference
37 (url "https://github.com/justinmeza/lci")
38 (commit (string-append "v" version))))
39 (file-name (git-file-name name version))
40 (sha256
41 (base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
42 (build-system cmake-build-system)
43 (inputs
44 `(("readline" ,readline)))
45 (native-inputs
46 `(("python-2" ,python-2))) ; for the tests
47 (synopsis "LOLCODE interpreter written in C")
48 (description
49 "@code{lci} is a LOLCODE interpreter written in C and is designed to be
50 correct, portable, fast, and precisely documented.
51 @enumerate
52 @item correct: Every effort has been made to test lci's conformance to the
53 LOLCODE language specification. Unit tests come packaged with the lci source code.
54 @item portable: lci follows the widely ported ANSI C specification allowing it
55 to compile on a broad range of systems.
56 @item fast: Much effort has gone into producing simple and efficient code
57 whenever possible to the extent that the above points are not compromized.
58 @end enumerate")
59 (home-page "http://lolcode.org/")
60 (license license:gpl3+)))