gnu: ruby: Update to 2.3.1.
[jackhill/guix/guix.git] / gnu / packages / patches / maxima-defsystem-mkdir.patch
1 Change 'ensure-directories-exist' to look for 'mkdir' in $PATH, not in /bin.
2
3 --- maxima-5.36.1/lisp-utils/defsystem.lisp.orig 2014-11-22 16:21:30.000000000 -0500
4 +++ maxima-5.36.1/lisp-utils/defsystem.lisp 2015-05-25 21:53:31.223648483 -0400
5 @@ -4627,7 +4627,7 @@
6 (cmd (if (member :win32 *features*)
7 (format nil "mkdir \"~a\""
8 (coerce (subst #\\ #\/ (coerce (namestring dir) 'list)) 'string))
9 - (format nil "/bin/mkdir -p ~S" (namestring dir)))))
10 + (format nil "mkdir -p ~S" (namestring dir)))))
11 (unless (directory dir)
12 (lisp:system cmd))
13 ;; The second return value is supposed to be T if directories were