gnu: harminv: Update to 1.4.1.
[jackhill/guix/guix.git] / gnu / packages / patches / dtc-format-modifier.patch
1 This fixes build on 32 bits platforms. This patch is taken from upstream.
2
3 commit 497432fd2131967f349e69dc5d259072151cc4b4
4 Author: Thierry Reding <treding@nvidia.com>
5 Date: Wed Sep 27 15:04:09 2017 +0200
6
7 checks: Use proper format modifier for size_t
8
9 The size of size_t can vary between architectures, so using %ld isn't
10 going to work on 32-bit builds. Use the %zu modifier to make sure it is
11 always correct.
12
13 Signed-off-by: Thierry Reding <treding@nvidia.com>
14 Acked-by: Rob Herring <robh@kernel.org>
15 Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
16
17 diff --git a/checks.c b/checks.c
18 index 902f2e3..08a3a29 100644
19 --- a/checks.c
20 +++ b/checks.c
21 @@ -972,7 +972,7 @@ static void check_property_phandle_args(struct check *c,
22 int cell, cellsize = 0;
23
24 if (prop->val.len % sizeof(cell_t)) {
25 - FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s",
26 + FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s",
27 prop->name, prop->val.len, sizeof(cell_t), node->fullpath);
28 return;
29 }
30 @@ -1163,7 +1163,7 @@ static void check_interrupts_property(struct check *c,
31 return;
32
33 if (irq_prop->val.len % sizeof(cell_t))
34 - FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s",
35 + FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s",
36 irq_prop->name, irq_prop->val.len, sizeof(cell_t),
37 node->fullpath);
38