gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / wordnet.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages wordnet)
21 #:use-module (guix packages)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages gcc)
27 #:use-module (gnu packages tcl))
28
29 (define-public wordnet
30 (package
31 (name "wordnet")
32 (version "3.0")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "http://wordnetcode.princeton.edu/"
36 version "/WordNet-" version ".tar.bz2"))
37 (sha256
38 (base32
39 "08pgjvd2vvmqk3h641x63nxp7wqimb9r30889mkyfh2agc62sjbc"))
40 (patches (search-patches
41 "wordnet-CVE-2008-2149.patch"
42 "wordnet-CVE-2008-3908-pt1.patch"
43 "wordnet-CVE-2008-3908-pt2.patch"))))
44 (build-system gnu-build-system)
45 (arguments
46 `(#:configure-flags (list (string-append "--with-tcl="
47 (assoc-ref %build-inputs "tcl")
48 "/lib")
49 (string-append "--with-tk="
50 (assoc-ref %build-inputs "tk")
51 "/lib")
52
53 ;; Provide the `result' field in `Tcl_Interp'.
54 ;; See <https://bugs.gentoo.org/show_bug.cgi?id=452034>.
55 "CFLAGS=-DUSE_INTERP_RESULT -O2")
56 #:phases
57 (modify-phases %standard-phases
58 (add-after 'install 'post-install
59 (lambda* (#:key inputs outputs #:allow-other-keys)
60 (let ((out (assoc-ref outputs "out"))
61 (bin (assoc-ref outputs "tk"))
62 (tk (assoc-ref inputs "tk"))
63 (tkv ,(let ((v (package-version tk)))
64 (string-take v (string-index-right v #\.)))))
65 ;; Move `wishwn' and `wnb' to BIN.
66 (for-each (lambda (prog)
67 (let ((orig (string-append out "/bin/" prog))
68 (dst (string-append bin "/bin/" prog))
69 (dir (string-append tk "/lib/tk" tkv)))
70 (mkdir-p (dirname dst))
71 (copy-file orig dst)
72 (delete-file orig)
73 (wrap-program dst
74 `("TK_LIBRARY" "" = (,dir))
75 `("PATH" ":" prefix
76 (,(string-append out
77 "/bin"))))))
78 '("wishwn" "wnb"))
79 #t))))))
80 (outputs '("out"
81 "tk")) ; for the Tcl/Tk GUI
82
83 ;; Build with a patched GCC to work around <http://bugs.gnu.org/24703>.
84 ;; (Specifically the 'DEFAULTPATH' string literal is what we want to
85 ;; prevent from being chunked so that grafting can "see" it and patch it.)
86 (native-inputs `(("gcc@6" ,gcc-6)))
87
88 (inputs `(("tk" ,tk)
89 ("tcl" ,tcl)))
90 (home-page "http://wordnet.princeton.edu/")
91 (synopsis "Lexical database for the English language")
92 (description
93 "WordNet is a large lexical database of English. Nouns, verbs,
94 adjectives and adverbs are grouped into sets of cognitive synonyms (synsets),
95 each expressing a distinct concept. Synsets are interlinked by means of
96 conceptual-semantic and lexical relations. The resulting network of
97 meaningfully related words and concepts can be navigated with the browser.
98 WordNet is also freely and publicly available for download. WordNet's
99 structure makes it a useful tool for computational linguistics and natural
100 language processing.")
101 (license x11)))