gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / tmux.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages tmux)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages libevent)
29 #:use-module (gnu packages ncurses))
30
31
32 (define-public tmux
33 (package
34 (name "tmux")
35 (version "2.3")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "https://github.com/tmux/tmux/releases/download/"
40 version "/tmux-" version ".tar.gz"))
41 (sha256
42 (base32
43 "0aw5fcav8pa70ym391n4g6mh5vir34x35xhb09zdwhhg5w9kwcam"))))
44 (build-system gnu-build-system)
45 (inputs
46 `(("libevent" ,libevent)
47 ("ncurses" ,ncurses)))
48 (home-page "http://tmux.github.io/")
49 (synopsis "Terminal multiplexer")
50 (description
51 "tmux is a terminal multiplexer: it enables a number of terminals (or
52 windows), each running a separate program, to be created, accessed, and
53 controlled from a single screen. tmux may be detached from a screen and
54 continue running in the background, then later reattached.")
55 (license isc)))
56
57 (define-public tmux-themepack
58 (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
59 (revision "1"))
60 (package
61 (name "tmux-themepack")
62 (version
63 (string-append "0.0.0-" revision "." (string-take commit 7))) ;; No version tags
64 (source (origin
65 (method git-fetch)
66 (uri (git-reference
67 (url
68 (string-append "https://github.com/jimeh/" name ".git"))
69 (commit commit)))
70 (sha256
71 (base32
72 "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
73 (file-name (string-append name "-" version "-checkout"))))
74 (build-system gnu-build-system)
75 (arguments
76 `(#:tests? #f ; No test suite.
77 #:phases (modify-phases %standard-phases
78 (delete 'configure)
79 (delete 'build)
80 (replace 'install
81 (lambda* (#:key outputs #:allow-other-keys)
82 (let* ((out (string-append
83 (assoc-ref outputs "out")
84 "/share/" ,name "-" ,version)))
85 (copy-recursively "." out)))))))
86 (home-page "https://github.com/jimeh/tmux-themepack")
87 (synopsis "Collection of themes for Tmux")
88 (description "A collection of various themes for Tmux.")
89 (license
90 (non-copyleft "http://www.wtfpl.net/txt/copying/")))))