gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / sync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages sync)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix build-system cmake)
23 #:use-module (guix download)
24 #:use-module (guix packages)
25 #:use-module (gnu packages check)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages databases)
28 #:use-module (gnu packages linux)
29 #:use-module (gnu packages lua)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages qt)
33 #:use-module (gnu packages tls))
34
35 (define-public owncloud-client
36 (package
37 (name "owncloud-client")
38 (version "2.2.4")
39 (source
40 (origin
41 (method url-fetch)
42 (uri (string-append "https://download.owncloud.com/desktop/stable/"
43 "owncloudclient-" version ".tar.xz"))
44 (sha256
45 (base32 "1lz7v5sscj5489panz5ng372g9l66ng0srx6xaz8drnsgi7m64zk"))
46 (modules '((guix build utils)))
47 (snippet
48 '(begin
49 ;; only allows bundled libcrashreporter-qt
50 (delete-file-recursively "src/3rdparty/libcrashreporter-qt")
51 ;; we already package qtkeychain and sqlite
52 (delete-file-recursively "src/3rdparty/qtkeychain")
53 (delete-file-recursively "src/3rdparty/sqlite3")
54 ;; qjson is packaged, qprogessindicator, qlockedfile, qtokenizer and
55 ;; qtsingleapplication have not yet been packaged, but all are
56 ;; explicitly used from the 3rdparty folder during build.
57 ;; We can also remove the macgoodies folder
58 (delete-file-recursively "src/3rdparty/qtmacgoodies")))))
59 (build-system cmake-build-system)
60 (arguments
61 `(#:phases
62 (modify-phases %standard-phases
63 (add-after 'unpack 'change-rpath-dirs
64 (lambda _
65 (substitute* '("src/libsync/CMakeLists.txt"
66 "csync/src/CMakeLists.txt")
67 ;; We store the libs in out/lib and not /usr/lib/appname, so we
68 ;; need the executable to point to the libraries in /lib and not
69 ;; in /lib/appname.
70 (("\\/\\$\\{APPLICATION_EXECUTABLE\\}") ""))
71 (substitute* '("src/cmd/CMakeLists.txt"
72 "src/crashreporter/CMakeLists.txt"
73 "src/gui/CMakeLists.txt")
74 ;; This has the same issue as the substitution above.
75 (("\\/\\$\\{APPLICATION_EXECUTABLE\\}\\\"") "\""))
76 #t))
77 (add-after 'unpack 'delete-failing-tests
78 ;; These tests fail for no apparent reason
79 (lambda _
80 (substitute* "test/CMakeLists.txt"
81 (("owncloud_add_test\\(FileSystem \"\"\\)" test)
82 (string-append "#" test))
83 (("owncloud_add_test\\(Utility \"\"\\)" test)
84 (string-append "#" test)))
85 #t)))
86 #:configure-flags '("-DUNIT_TESTING=ON")))
87 (native-inputs
88 `(("cmocka" ,cmocka)
89 ("perl" ,perl)
90 ("pkg-config" ,pkg-config)
91 ("qtlinguist" ,qttools)))
92 (inputs
93 `(("inotify-tools" ,inotify-tools)
94 ("openssl" ,openssl)
95 ("qtbase" ,qtbase)
96 ("qtkeychain" ,qtkeychain)
97 ("qtwebkit" ,qtwebkit)
98 ("sqlite" ,sqlite)
99 ("zlib" ,zlib)))
100 (home-page "https://owncloud.org")
101 (synopsis "Folder synchronization with an ownCloud server")
102 (description "The ownCloudSync system lets you always have your latest
103 files wherever you are. Just specify one or more folders on the local machine
104 to and a server to synchronize to. You can configure more computers to
105 synchronize to the same server and any change to the files on one computer will
106 silently and reliably flow across to every other.")
107 (license license:gpl2+)))
108
109 (define-public qsyncthingtray
110 (package
111 (name "qsyncthingtray")
112 (version "0.5.7")
113 (source
114 (origin
115 (method url-fetch)
116 (uri (string-append
117 "https://github.com/sieren/QSyncthingTray/archive/"
118 version ".tar.gz"))
119 (file-name (string-append name "-" version ".tar.gz"))
120 (sha256
121 (base32
122 "1qzlxgq36sb1dk621nkbjw9k6y3css6q3z8xzx6nv7f327vanvp6"))))
123 (build-system cmake-build-system)
124 (arguments
125 `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
126 #:phases
127 (modify-phases %standard-phases
128 ;; The program is meant to be run from the git repo or source tarball.
129 (replace 'install
130 (lambda* (#:key outputs #:allow-other-keys)
131 (let* ((out (assoc-ref outputs "out"))
132 (bin (string-append out "/bin")))
133 (install-file "QSyncthingTray" bin)
134 (install-file (string-append
135 "../QSyncthingTray-"
136 ,(package-version qsyncthingtray)
137 "/resources/images/Icon1024.png")
138 (string-append
139 out "/share/pixmaps/QSyncthingTray.png"))
140 #t))))
141 #:tests? #f)) ; no test target
142 (inputs
143 `(("qtbase" ,qtbase)
144 ("qtwebkit" ,qtwebkit)))
145 (home-page "https://github.com/sieren/QSyncthingTray")
146 (synopsis "Traybar Application for Syncthing")
147 (description
148 "A traybar application for syncthing.
149 @enumerate
150 @item Shows number of connections at a glance.
151 @item Traffic statistics about incoming, outgoing and total throughput.
152 @item Launches Syncthing and Syncthing-iNotifier if specified.
153 @item Quickly pause Syncthing with one click.
154 @item Last Synced Files - Quickly see the recently synchronised files and open
155 their folder.
156 @item Quick Access to all shared folders.
157 @item Presents Syncthing UI in a separate view instead of using the browser.
158 @item Supports authenticated HTTPS connections.
159 @item Uses System Notifications about current connection status.
160 @item Toggle for monochrome icon.
161 @end enumerate\n")
162 (license license:lgpl3+)))
163
164 (define-public lsyncd
165 (package
166 (name "lsyncd")
167 (version "2.2.1")
168 (source
169 (origin
170 (method url-fetch)
171 (uri (string-append "https://github.com/axkibe/lsyncd/archive/release-"
172 version ".tar.gz"))
173 (file-name (string-append name "-" version ".tar.gz"))
174 (sha256
175 (base32
176 "0da7mrq2c578v2dd5x9v75l1fqrm28jvn28qkcd49y8p992nj6gl"))))
177 (build-system cmake-build-system)
178 (arguments
179 `(;; The "tests" target is broken and assumes that tests are run in the
180 ;; root directory.
181 #:tests? #f
182 #:test-target "tests"
183 #:phases
184 (modify-phases %standard-phases
185 ;; No install target.
186 (replace 'install
187 (lambda* (#:key outputs #:allow-other-keys)
188 (let* ((out (assoc-ref outputs "out"))
189 (bin (string-append out "/bin"))
190 (man (string-append out "/share/man/man1")))
191 (install-file "lsyncd" bin)
192 (install-file (string-append "../lsyncd-release-"
193 ,version
194 "/doc/manpage/lsyncd.1")
195 man)
196 #t))))))
197 (native-inputs
198 `(("lua" ,lua-5.2)))
199 (home-page "https://github.com/axkibe/lsyncd")
200 (synopsis "Synchronize local directories with remote targets")
201 (description "Lsyncd watches a local directory trees event monitor
202 interface (inotify or fsevents). It aggregates and combines events for a few
203 seconds and then spawns one (or more) process(es) to synchronize the changes.
204 By default this is rsync, which must be installed on all source and target
205 machines. Lsyncd is thus a light-weight live mirror solution that is
206 comparatively easy to install not requiring new filesystems or block devices
207 and does not hamper local filesystem performance.")
208 (license license:gpl2+)))