gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / speech.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
4 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages speech)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages autotools)
28 #:use-module (gnu packages gcc)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages pulseaudio)
32 #:use-module (gnu packages textutils))
33
34 (define-public mitlm
35 (package
36 (name "mitlm")
37 (version "0.4.1")
38 ;; No official release tarballs, so for now we use the one from Debian
39 ;; that is maintained by one of the project developers.
40 ;;
41 ;; See: https://github.com/mitlm/mitlm/issues/54
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "mirror://debian/pool/main/m/mitlm/mitlm_"
45 version ".orig.tar.gz"))
46 (sha256
47 (base32
48 "12m09xxx8jbir9cnzzaysvni5sfijpfj96z1x1520qqvmpc8lmn7"))))
49 (build-system gnu-build-system)
50 (native-inputs
51 `(("gfortran" ,gfortran)))
52 (synopsis "The MIT Language Modeling toolkit")
53 (description "The MIT Language Modeling (MITLM) toolkit is a set of
54 tools designed for the efficient estimation of statistical n-gram language
55 models involving iterative parameter estimation. It achieves much of its
56 efficiency through the use of a compact vector representation of n-grams.")
57 (home-page "https://github.com/mitlm/mitlm")
58 (license license:expat)))
59
60 (define-public speech-dispatcher
61 (package
62 (name "speech-dispatcher")
63 (version "0.8.5")
64 (source (origin
65 (method url-fetch)
66 (uri (string-append "https://devel.freebsoft.org/pub/"
67 "projects/speechd/speech-dispatcher-"
68 version ".tar.gz"))
69 (sha256
70 (base32
71 "18jlxnhlahyi6njc6l6576hfvmzivjjgfjyd2n7vvrvx9inphjrb"))))
72 (build-system gnu-build-system)
73 (native-inputs
74 `(("intltool" ,intltool)
75 ("pkg-config" ,pkg-config)))
76 (inputs
77 `(("dotconf" ,dotconf)
78 ("glib" ,glib)
79 ("libltdl" ,libltdl)
80 ("libsndfile" ,libsndfile)))
81 (synopsis "Common interface to speech synthesizers")
82 (description "The Speech Dispatcher project provides a high-level
83 device independent layer for access to speech synthesis through a simple,
84 stable and well documented interface.")
85 (home-page "https://devel.freebsoft.org/speechd")
86 ;; The software is distributed under GPL2+, but includes a number
87 ;; of files covered by other licenses.
88 (license (list license:gpl2+
89 license:fdl1.2+ ; Most files in doc/ are dual gpl2+/fdl1.2+.
90 license:lgpl2.1+
91 license:gpl2
92 (license:non-copyleft
93 ;; festival_client.{c,h} carries an expat-style license.
94 "See src/modules/festival_client.c in the distribution.")
95 license:gpl3+)))) ; doc/texinfo.tex -- with TeX exception.
96
97 (define-public sonic
98 (package
99 (name "sonic")
100 (version "0.2.0")
101 (source (origin
102 (method url-fetch)
103 (uri (string-append "https://github.com/waywardgeek/sonic/archive/"
104 "release-" version ".tar.gz"))
105 (file-name (string-append name "-" version ".tar.gz"))
106 (sha256
107 (base32
108 "11a0q9wkgbb9ymf52v7dvybfhj8hprgr67zs1xcng143fvjpr0n7"))))
109 (build-system gnu-build-system)
110 (arguments
111 `(#:tests? #f ; No test suite.
112 #:make-flags
113 (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
114 #:phases
115 (modify-phases %standard-phases
116 (delete 'configure)))) ; No ./configure script.
117 (synopsis "Speed up or slow down speech")
118 (description "Sonic implements a simple algorithm for speeding up or slowing
119 down speech. However, it's optimized for speed ups of over 2X, unlike previous
120 algorithms for changing speech rate. Sonic is a C library designed to be easily
121 integrated into streaming voice applications such as text-to-speech (TTS) back
122 ends.
123
124 The primary motivation behind Sonic is to enable the blind and visually impaired
125 to improve their productivity with speech engines, like eSpeak. Sonic can also
126 be used by the sighted.")
127 (home-page "https://github.com/waywardgeek/sonic")
128 (license license:asl2.0)))