gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / security-token.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
5 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages security-token)
23 #:use-module (gnu packages)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages curl)
29 #:use-module (gnu packages libusb)
30 #:use-module (gnu packages linux)
31 #:use-module (gnu packages man)
32 #:use-module (gnu packages perl)
33 #:use-module (gnu packages pkg-config))
34
35 (define-public ccid
36 (package
37 (name "ccid")
38 (version "1.4.26")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append
42 "https://alioth.debian.org/frs/download.php/file/4205/"
43 "ccid-" version ".tar.bz2"))
44 (sha256
45 (base32
46 "0bxy835c133ajalpj4gx60nqkjvpf9y1n97n04pw105pi9qbyrrj"))))
47 (build-system gnu-build-system)
48 (arguments
49 `(#:configure-flags (list (string-append "--enable-usbdropdir=" %output
50 "/pcsc/drivers"))
51 #:phases
52 (modify-phases %standard-phases
53 (add-after 'unpack 'patch-Makefile
54 (lambda _
55 (substitute* "src/Makefile.in"
56 (("/bin/echo") (which "echo")))
57 #t)))))
58 (native-inputs
59 `(("perl" ,perl)
60 ("pkg-config" ,pkg-config)))
61 (inputs
62 `(("libusb" ,libusb)
63 ("pcsc-lite" ,pcsc-lite)))
64 (home-page "https://pcsclite.alioth.debian.org/ccid.html")
65 (synopsis "PC/SC driver for USB smart card devices")
66 (description
67 "This package provides a PC/SC IFD handler implementation for devices
68 compliant with the CCID and ICCD protocols. It supports a wide range of
69 readers and is needed to communicate with such devices through the
70 @command{pcscd} resource manager.")
71 (license license:lgpl2.1+)))
72
73 (define-public libyubikey
74 (package
75 (name "libyubikey")
76 (version "1.13")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append
80 "https://developers.yubico.com/yubico-c/Releases/"
81 name "-" version ".tar.gz"))
82 (sha256
83 (base32
84 "009l3k2zyn06dbrlja2d4p2vfnzjhlcqxi88v02mlrnb17mx1v84"))))
85 (build-system gnu-build-system)
86 (synopsis "Development kit for the YubiKey authentication device")
87 (description
88 "This package contains a C library and command-line tools that make up
89 the low-level development kit for the Yubico YubiKey authentication device.")
90 (home-page "https://developers.yubico.com/yubico-c/")
91 (license license:bsd-2)))
92
93 (define-public pcsc-lite
94 (package
95 (name "pcsc-lite")
96 (version "1.8.20")
97 (source (origin
98 (method url-fetch)
99 (uri (string-append
100 "https://alioth.debian.org/frs/download.php/file/4203/"
101 "pcsc-lite-" version ".tar.bz2"))
102 (sha256
103 (base32
104 "1ckb0jf4n585a4j26va3jm2nrv3c1y38974514f8qy3c04a02zgc"))))
105 (build-system gnu-build-system)
106 (arguments
107 `(#:configure-flags '("--enable-usbdropdir=/var/lib/pcsc/drivers")))
108 (native-inputs
109 `(("perl" ,perl) ; for pod2man
110 ("pkg-config" ,pkg-config)))
111 (inputs
112 `(("libudev" ,eudev)))
113 (home-page "https://pcsclite.alioth.debian.org/pcsclite.html")
114 (synopsis "Middleware to access a smart card using PC/SC")
115 (description
116 "pcsc-lite provides an interface to communicate with smartcards and
117 readers using the SCard API. pcsc-lite is used to connect to the PC/SC daemon
118 from a client application and provide access to the desired reader.")
119 (license (list license:bsd-3 ; pcsc-lite
120 license:expat ; src/sd-daemon.[ch]
121 license:isc ; src/strlcat.c src/strlcpy.c
122 license:gpl3+)))) ; src/spy/*
123
124 (define-public ykclient
125 (package
126 (name "ykclient")
127 (version "2.15")
128 (source (origin
129 (method url-fetch)
130 (uri (string-append
131 "https://developers.yubico.com/yubico-c-client/Releases/"
132 name "-" version ".tar.gz"))
133 (sha256
134 (base32
135 "05jhx9waj3pl120ddnwap1v3bjrnbfhvf3lxs2xmhpcmwzpwsqgl"))))
136 (build-system gnu-build-system)
137
138 ;; There's just one test, and it requires network access to access
139 ;; yubico.com, so skip it.
140 (arguments '(#:tests? #f))
141
142 (native-inputs `(("pkg-config" ,pkg-config)
143 ("help2man" ,help2man)))
144 (inputs `(("curl" ,curl)))
145 (synopsis "C library to validate one-time-password YubiKeys")
146 (description
147 "YubiKey C Client Library (libykclient) is a C library used to validate a
148 one-time-password (OTP) YubiKey against Yubico’s servers. See the Yubico
149 website for more information about Yubico and the YubiKey.")
150 (home-page "https://developers.yubico.com/yubico-c-client/")
151 (license license:bsd-2)))