gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / scsi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages scsi)
20 #:use-module ((guix licenses)
21 #:select (gpl2+ bsd-3))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public sg3-utils
27 (package
28 (name "sg3-utils")
29 (version "1.42")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "http://sg.danny.cz/sg/p/sg3_utils-"
33 version ".tar.xz"))
34 (sha256
35 (base32
36 "1fg71rj0f1gdjmkj0z8wlv46cf9lryjdyjkbi7fjmssgi5jyvblp"))))
37 (build-system gnu-build-system)
38 (home-page "http://sg.danny.cz/sg/sg3_utils.html")
39 (synopsis "SCSI device utilities")
40 (description
41 "sg3-utils is a collection of utilities for devices that use the Small
42 Computer System Interface (SCSI) command set. It includes utilities to read
43 data from, write data to, control, modify, and query the state of SCSI
44 devices. For example, this package provides command-line tools to copy data
45 based on @code{dd} syntax and semantics (called @code{sg_dd}, @code{sgp_dd}
46 and @code{sgm_dd}), check INQUIRY data and VPD pages (@code{sg_inq}), check
47 mode and log pages (@code{sginfo}, @code{sg_modes} and @code{sg_logs}), spin
48 up and down disks (@code{sg_start}), do self tests (@code{sg_senddiag}), parse
49 sense data (@code{sg_decode_sense}), and perform various other functions. In
50 addition, this package includes a library, called libsgutils, which can be
51 used in C and C++ programs to interact with SCSI devices.")
52 ;; The libsgutils library itself is licensed under bsd-3. Some tools are
53 ;; licensed under bsd-3, also. Some tools are licensed under gpl2+.
54 (license (list gpl2+ bsd-3))))