gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages rsync)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages perl)
23 #:use-module (gnu packages acl)
24 #:use-module (gnu packages base)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
29
30
31 (define-public rsync
32 (package
33 (name "rsync")
34 (version "3.1.2")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "http://rsync.samba.org/ftp/rsync/src/rsync-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "1hm1q04hz15509f0p9bflw4d6jzfvpm1d36dxjwihk1wzakn5ypc"))))
42 (build-system gnu-build-system)
43 (inputs `(("perl" ,perl)
44 ("acl" ,acl)))
45 (synopsis "Remote (and local) file copying tool")
46 (description
47 "Rsync is a fast and versatile file copying tool. It can copy locally,
48 to/from another host over any remote shell, or to/from a remote rsync daemon.
49 Its delta-transfer algorithm reduces the amount of data sent over the network
50 by sending only the differences between the source files and the existing
51 files in the destination.")
52 (license gpl3+)
53 (home-page "http://rsync.samba.org/")))
54
55 (define-public librsync
56 (package
57 (name "librsync")
58 (version "0.9.7")
59 (source (origin
60 (method url-fetch)
61 (uri (string-append "mirror://sourceforge/librsync/librsync/"
62 version "/librsync-" version ".tar.gz"))
63 (sha256
64 (base32
65 "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
66 (build-system gnu-build-system)
67 (native-inputs
68 `(("which" ,which)
69 ("perl" ,perl)))
70 (arguments '(#:configure-flags '("--enable-shared")))
71 (home-page "http://librsync.sourceforge.net/")
72 (synopsis "Implementation of the rsync remote-delta algorithm")
73 (description
74 "Librsync is a free software library that implements the rsync
75 remote-delta algorithm. This algorithm allows efficient remote updates of a
76 file, without requiring the old and new versions to both be present at the
77 sending end. The library uses a \"streaming\" design similar to that of zlib
78 with the aim of allowing it to be embedded into many different applications.")
79 (license lgpl2.1+)))