gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / re2c.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Sergei Trofimovich <slyfox@inbox.ru>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages re2c)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public re2c
26 (package
27 (name "re2c")
28 (version "0.16")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "https://github.com/skvadrik/" name
32 "/releases/download/" version "/"
33 name "-" version ".tar.gz"))
34 (sha256
35 (base32
36 "114y0s4vmzip4hkf4cbz4yv8s498gzaylnphbzmwqhbn55j2bha8"))))
37 (build-system gnu-build-system)
38 (home-page "http://re2c.org/")
39 (synopsis "Lexer generator for C/C++")
40 (description
41 "@code{re2c} generates minimalistic hard-coded state machine (as opposed
42 to full-featured table-based lexers). Flexible API allows generated code
43 to be wired into virtually any environment. Instead of exposing traditional
44 @code{yylex()} style API, re2c exposes its internals. Be sure to take a look
45 at examples, they cover a lot of real-world cases and shed some light on dark
46 corners of re2c API.")
47 (license public-domain)))