gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / rdf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages rdf)
21 #:use-module ((guix licenses)
22 #:select (non-copyleft isc gpl2 lgpl2.1 lgpl2.1+))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system cmake)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix build-system python)
28 #:use-module (guix build-system waf)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages autotools)
31 #:use-module (gnu packages databases)
32 #:use-module (gnu packages boost)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages curl)
35 #:use-module (gnu packages cyrus-sasl)
36 #:use-module (gnu packages documentation)
37 #:use-module (gnu packages gnupg)
38 #:use-module (gnu packages linux)
39 #:use-module (gnu packages multiprecision)
40 #:use-module (gnu packages pcre)
41 #:use-module (gnu packages perl)
42 #:use-module (gnu packages pkg-config)
43 #:use-module (gnu packages python)
44 #:use-module (gnu packages qt)
45 #:use-module (gnu packages tls)
46 #:use-module (gnu packages xml))
47
48 (define-public raptor2
49 (package
50 (name "raptor2")
51 (version "2.0.15")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append "http://download.librdf.org/source/" name
55 "-" version ".tar.gz"))
56 (sha256
57 (base32
58 "1vc02im4mpc28zxzgli68k6j0dakh0k3s389bm436yvqajxg19xd"))))
59 (build-system gnu-build-system)
60 (inputs
61 `(("curl" ,curl)
62 ("libxml2" ,libxml2)
63 ("libxslt" ,libxslt)
64 ("zlib" ,zlib)))
65 (arguments
66 `(#:parallel-tests? #f))
67 (home-page "http://librdf.org/raptor/")
68 (synopsis "RDF syntax library")
69 (description "Raptor is a C library providing a set of parsers and
70 serialisers that generate Resource Description Framework (RDF) triples
71 by parsing syntaxes or serialise the triples into a syntax. The supported
72 parsing syntaxes are RDF/XML, N-Quads, N-Triples 1.0 and 1.1, TRiG,
73 Turtle 2008 and 2013, RDFa 1.0 and 1.1, RSS tag soup including all versions
74 of RSS, Atom 1.0 and 0.3, GRDDL and microformats for HTML, XHTML and
75 XML. The serialising syntaxes are RDF/XML (regular, abbreviated, XMP),
76 Turtle 2013, N-Quads, N-Triples 1.1, Atom 1.0, RSS 1.0, GraphViz DOT,
77 HTML and JSON.")
78 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
79
80 (define-public clucene
81 (package
82 (name "clucene")
83 (version "2.3.3.4")
84 (source (origin
85 (method url-fetch)
86 (uri (string-append "mirror://sourceforge/clucene/"
87 "clucene-core-unstable/2.3/clucene-core-"
88 version ".tar.gz"))
89 (sha256
90 (base32
91 "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))
92 (patches (search-patches "clucene-pkgconfig.patch"
93 "clucene-contribs-lib.patch"))))
94 (build-system cmake-build-system)
95 (inputs
96 `(("boost" ,boost) ; could also use bundled copy
97 ("zlib" ,zlib)))
98 (arguments
99 `(#:test-target "cl_test"
100 #:configure-flags '("-DBUILD_CONTRIBS_LIB=ON")
101 #:tests? #f)) ; Tests do not compile, as TestIndexSearcher.cpp uses
102 ; undeclared usleep. After fixing this, one needs to run
103 ; "make test" in addition to "make cl_test", then
104 ; SimpleTest fails.
105 ; Notice that the library appears to be unmaintained
106 ; with no reaction to bug reports.
107 (home-page "http://clucene.sourceforge.net/")
108 (synopsis "C text indexing and searching library")
109 (description "CLucene is a high-performance, scalable, cross platform,
110 full-featured indexing and searching API. It is a port of the very popular
111 Java Lucene text search engine API to C++.")
112 (license lgpl2.1)))
113
114 (define-public lrdf
115 (package
116 (name "lrdf")
117 (version "0.5.0")
118 (source (origin
119 (method url-fetch)
120 (uri (string-append "https://github.com/swh/LRDF/archive/"
121 version ".tar.gz"))
122 (file-name (string-append name "-" version ".tar.gz"))
123 (sha256
124 (base32
125 "18p2flb2sv2hq6w2qkd29z9c7knnwqr3f12i2srshlzx6vwkm05s"))))
126 (build-system gnu-build-system)
127 (arguments
128 '(#:phases (alist-cons-after
129 'remove-out-of-tree-references 'autoreconf
130 (lambda _
131 (zero? (system* "autoreconf" "-vfi")))
132 (alist-cons-after
133 'unpack 'remove-out-of-tree-references
134 (lambda _
135 ;; remove symlinks to files in /usr/
136 (delete-file-recursively "m4")
137 (for-each delete-file '("config.guess"
138 "config.sub"
139 "depcomp"
140 "install-sh"
141 "ltmain.sh"
142 "missing"))
143 ;; remove_test depends on an out-of-tree RDF file
144 (substitute* "examples/Makefile.am"
145 (("instances_test remove_test") "instances_test")
146 (("\\$\\(TESTS\\) remove_test") "$(TESTS)")))
147 %standard-phases))))
148 (inputs
149 `(("raptor" ,raptor2)
150 ("cyrus-sasl" ,cyrus-sasl)
151 ("openssl" ,openssl)
152 ("zlib" ,zlib)))
153 (native-inputs
154 `(("autoconf" ,autoconf)
155 ("automake" ,automake)
156 ("libtool" ,libtool)
157 ("pkg-config" ,pkg-config)))
158 (home-page "https://github.com/swh/LRDF")
159 (synopsis "Lightweight RDF library for accessing LADSPA plugin metadata")
160 (description
161 "LRDF is a library to make it easy to manipulate RDF files describing
162 LADSPA plugins. It can also be used for general RDF manipulation. It can
163 read RDF/XLM and N3 files and export N3 files, and it also has a light
164 taxonomic inference capability.")
165 (license gpl2)))
166
167 (define-public rasqal
168 (package
169 (name "rasqal")
170 (version "0.9.33")
171 (source (origin
172 (method url-fetch)
173 (uri (string-append "http://download.librdf.org/source/" name
174 "-" version ".tar.gz"))
175 (sha256
176 (base32
177 "0z6rrwn4jsagvarg8d5zf0j352kjgi33py39jqd29gbhcnncj939"))))
178 (build-system gnu-build-system)
179 (native-inputs
180 `(("perl" ,perl)
181 ("perl-xml-dom" ,perl-xml-dom) ; for the tests
182 ("pkg-config" ,pkg-config)))
183 (inputs
184 `(("libgcrypt" ,libgcrypt)
185 ("libxml2" ,libxml2)
186 ("mpfr" ,mpfr)
187 ("pcre" ,pcre)
188 ("util-linux" ,util-linux)))
189 (propagated-inputs
190 `(("raptor2" ,raptor2))) ; stipulated by rasqal.pc
191 (arguments
192 `(#:parallel-tests? #f
193 ; test failure reported upstream, see
194 ; http://bugs.librdf.org/mantis/view.php?id=571
195 #:tests? #f))
196 (home-page "http://librdf.org/rasqal/")
197 (synopsis "RDF query library")
198 (description "Rasqal is a C library that handles Resource Description
199 Framework (RDF) query language syntaxes, query construction and execution
200 of queries returning results as bindings, boolean, RDF graphs/triples or
201 syntaxes. The supported query languages are SPARQL Query 1.0,
202 SPARQL Query 1.1, SPARQL Update 1.1 (no executing) and the Experimental
203 SPARQL extensions (LAQRS). Rasqal can write binding query results in the
204 SPARQL XML, SPARQL JSON, CSV, TSV, HTML, ASCII tables, RDF/XML and
205 Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
206 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
207
208 (define-public redland
209 (package
210 (name "redland")
211 (version "1.0.17")
212 (source (origin
213 (method url-fetch)
214 (uri (string-append "http://download.librdf.org/source/" name
215 "-" version ".tar.gz"))
216 (sha256
217 (base32
218 "109n0kp39p966dpiasad2bb7q66rwbcb9avjvimw28chnpvlf66y"))))
219 (build-system gnu-build-system)
220 (native-inputs
221 `(("perl" ,perl) ; needed for installation
222 ("pkg-config" ,pkg-config)))
223 (propagated-inputs
224 `(("rasqal" ,rasqal))) ; in Requires.private field of .pc
225 (inputs
226 `(("bdb" ,bdb)))
227 (home-page "http://librdf.org/")
228 (synopsis "RDF library")
229 (description "The Redland RDF Library (librdf) provides the RDF API
230 and triple stores.")
231 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
232
233 (define-public serd
234 (package
235 (name "serd")
236 (version "0.22.0")
237 (source (origin
238 (method url-fetch)
239 (uri (string-append "http://download.drobilla.net/serd-"
240 version
241 ".tar.bz2"))
242 (sha256
243 (base32
244 "1lmgca2s6r7ysakcld2lrj06bgn0pr45c51b47k3apxpnj3h40vv"))))
245 (build-system waf-build-system)
246 (arguments
247 `(#:tests? #f ; no check target
248 #:phases
249 (modify-phases %standard-phases
250 (add-before
251 'configure 'set-ldflags
252 (lambda* (#:key outputs #:allow-other-keys)
253 (setenv "LDFLAGS"
254 (string-append "-Wl,-rpath="
255 (assoc-ref outputs "out") "/lib")))))))
256 (home-page "http://drobilla.net/software/serd/")
257 (synopsis "Library for RDF syntax supporting Turtle and NTriples")
258 (description
259 "Serd is a lightweight C library for RDF syntax which supports reading
260 and writing Turtle and NTriples. Serd is not intended to be a swiss-army
261 knife of RDF syntax, but rather is suited to resource limited or performance
262 critical applications (e.g. converting many gigabytes of NTriples to Turtle),
263 or situations where a simple reader/writer with minimal dependencies is
264 ideal (e.g. in LV2 implementations or embedded applications).")
265 (license isc)))
266
267 (define-public sord
268 (package
269 (name "sord")
270 (version "0.14.0")
271 (source (origin
272 (method url-fetch)
273 (uri (string-append "http://download.drobilla.net/sord-"
274 version
275 ".tar.bz2"))
276 (sha256
277 (base32
278 "16piw1s3l95cf9x3rdcplp9l52k2lxq8drwg2q50ygm4avndhmkn"))))
279 (build-system waf-build-system)
280 (arguments
281 `(#:tests? #f ; no check target
282 #:phases
283 (modify-phases %standard-phases
284 (add-before
285 'configure 'set-ldflags
286 (lambda* (#:key outputs #:allow-other-keys)
287 (setenv "LDFLAGS"
288 (string-append "-Wl,-rpath="
289 (assoc-ref outputs "out") "/lib")))))))
290 (inputs
291 `(("serd" ,serd)))
292 (native-inputs
293 `(("pkg-config" ,pkg-config)))
294 (home-page "http://drobilla.net/software/sord/")
295 (synopsis "C library for storing RDF data in memory")
296 (description
297 "Sord is a lightweight C library for storing RDF data in memory.")
298 (license isc)))
299
300 (define-public python-rdflib
301 (package
302 (name "python-rdflib")
303 (version "4.1.2")
304 (source
305 (origin
306 (method url-fetch)
307 (uri (string-append
308 "https://pypi.python.org/packages/source/r/rdflib/rdflib-"
309 version
310 ".tar.gz"))
311 (patches
312 ;; The patch has no effect under Python 3.
313 (search-patches "python2-rdflib-drop-sparqlwrapper.patch"))
314 (sha256
315 (base32
316 "0kvaf332cqbi47rqzlpdx4mbkvw12mkrzkj8n9l19wk713d4py9w"))))
317 (build-system python-build-system)
318 (arguments
319 '(;; FIXME: Three test failures. Try uncommenting the below next update.
320 #:tests? #f))
321 ;; #:phases
322 ;; (modify-phases %standard-phases
323 ;; (replace 'check
324 ;; (lambda _
325 ;; ;; Run tests from the build directory so python3 only
326 ;; ;; sees the installed 2to3 version.
327 ;; (zero? (system* "nosetests" "--where=./build/src")))))
328 (native-inputs
329 `(("python-nose" ,python-nose)))
330 (propagated-inputs
331 `(("python-html5lib" ,python-html5lib)
332 ("python-isodate" ,python-isodate)
333 ("python-pyparsing" ,python-pyparsing)))
334 (home-page "https://github.com/RDFLib/rdflib")
335 (synopsis
336 "Python RDF library")
337 (description
338 "RDFLib is a Python library for working with RDF, a simple yet
339 powerful language for representing information.")
340 (license (non-copyleft "file://LICENSE"
341 "See LICENSE in the distribution."))))
342
343 (define-public python2-rdflib
344 (package-with-python2 python-rdflib))