gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / ratpoison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages ratpoison)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((guix licenses) #:select (gpl2+))
25 #:use-module (gnu packages)
26 #:use-module (gnu packages xorg)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages readline)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages fontutils))
31
32 (define ratpoison.desktop
33 (origin
34 (method url-fetch)
35 (uri (string-append "https://sources.gentoo.org/cgi-bin/viewvc.cgi/"
36 "gentoo-x86/x11-wm/ratpoison/files/ratpoison.desktop"
37 "?revision=1.1"))
38 (file-name "ratpoison.desktop")
39 (sha256
40 (base32
41 "1rh3f4c3rhn6q2hmkraam0831xqcqyj3qkqf019ahaxsxaan3553"))))
42
43 (define-public ratpoison
44 (package
45 (name "ratpoison")
46 (version "1.4.8")
47 (source
48 (origin (method url-fetch)
49 (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
50 version ".tar.xz"))
51 (sha256
52 (base32
53 "1w502z55vv7zs45l80nsllqh9fvfwjfdfi11xy1qikhzdmirains"))
54 (patches (search-patches "ratpoison-shell.patch"))))
55 (build-system gnu-build-system)
56 (arguments
57 '(#:phases
58 (modify-phases %standard-phases
59 (add-after 'install 'install-xsession
60 (lambda* (#:key inputs outputs #:allow-other-keys)
61 (let ((rpd "ratpoison.desktop")
62 (dst (string-append (assoc-ref outputs "out")
63 "/share/xsessions/")))
64 (mkdir-p dst)
65 (copy-file (assoc-ref inputs rpd)
66 (string-append dst rpd))))))))
67 (inputs
68 `(("inputproto" ,inputproto)
69 ("fontconfig" ,fontconfig)
70 ("freetype" ,freetype)
71 ("libXft" ,libxft)
72 ("libXi" ,libxi)
73 ("libxinerama" ,libxinerama)
74 ("libXpm" ,libxpm)
75 ("libXt" ,libxt)
76 ("libXtst" ,libxtst)
77 ("libX11" ,libx11)
78 ("readline" ,readline)
79 ("xextproto" ,xextproto)))
80 (native-inputs
81 `(("perl",perl)
82 ("pkg-config" ,pkg-config)
83 ("ratpoison.desktop" ,ratpoison.desktop)))
84 (home-page "http://www.nongnu.org/ratpoison/")
85 (synopsis "Simple mouse-free tiling window manager")
86 (description
87 "Ratpoison is a simple window manager with no fat library
88 dependencies, no fancy graphics, no window decorations, and no
89 rodent dependence. It is largely modelled after GNU Screen which
90 has done wonders in the virtual terminal market.
91
92 The screen can be split into non-overlapping frames. All windows
93 are kept maximized inside their frames to take full advantage of
94 your precious screen real estate.
95
96 All interaction with the window manager is done through keystrokes.
97 Ratpoison has a prefix map to minimize the key clobbering that
98 cripples Emacs and other quality pieces of software.")
99 (license gpl2+)))