gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / pumpio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages pumpio)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages aspell)
27 #:use-module (gnu packages qt)
28 #:use-module (gnu packages web))
29
30 (define-public pumpa
31 (package
32 (name "pumpa")
33 (version "0.9.2")
34 (source (origin
35 (method git-fetch) ; no source tarballs
36 (uri (git-reference
37 (url "git://pumpa.branchable.com/")
38 (commit (string-append "v" version))))
39 (sha256
40 (base32
41 "09www29s4ldvd6apr73w7r4nmq93rcl2d182fylwgfcnncbvpy8s"))
42 (file-name (string-append name "-" version "-checkout"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(#:phases (alist-replace
46 'configure
47 (lambda* (#:key inputs outputs #:allow-other-keys)
48 ;; Fix dependency tests.
49 (substitute* "pumpa.pro"
50 (("/usr/include/tidy\\.h")
51 (string-append (assoc-ref inputs "tidy")
52 "/include/tidy.h"))
53 (("/usr/include/aspell.h")
54 (string-append (assoc-ref inputs "aspell")
55 "/include/aspell.h")))
56 ;; Run qmake with proper installation prefix.
57 (let ((prefix (string-append "PREFIX="
58 (assoc-ref outputs "out"))))
59 (zero? (system* "qmake" prefix))))
60 %standard-phases)))
61 (inputs
62 `(("aspell" ,aspell)
63 ("qtbase" ,qtbase)
64 ("tidy" ,tidy)))
65 (synopsis "Qt-based pump.io client")
66 (description "Pumpa is a simple pump.io client written in C++ and Qt.")
67 (home-page "https://pumpa.branchable.com/")
68 (license gpl3+)))