gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / protobuf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
4 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages protobuf)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix build-system python)
26 #:use-module ((guix licenses)
27 #:select (bsd-3))
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages gcc)
30 #:use-module (gnu packages python))
31
32 (define-public protobuf
33 (package
34 (name "protobuf")
35 (version "2.6.1")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "https://github.com/google/protobuf/releases/"
39 "download/v" version "/protobuf-"
40 version ".tar.bz2"))
41 (sha256
42 (base32
43 "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
44 (build-system gnu-build-system)
45 (inputs `(("zlib" ,zlib)))
46 (home-page "https://github.com/google/protobuf")
47 (synopsis "Data encoding for remote procedure calls (RPCs)")
48 (description
49 "Protocol Buffers are a way of encoding structured data in an efficient
50 yet extensible format. Google uses Protocol Buffers for almost all of its
51 internal RPC protocols and file formats.")
52 (license bsd-3)))
53
54 (define-public python-protobuf
55 (package
56 (name "python-protobuf")
57 (version "3.0.0")
58 (source
59 (origin
60 (method url-fetch)
61 (uri (pypi-uri "protobuf" version))
62 (sha256
63 (base32
64 "1xbgbfg4g43bihkyw1a2giqa2gxmqc5wkh0fzqcb90qi1z1hpi7c"))))
65 (build-system python-build-system)
66 (propagated-inputs
67 `(("python-six" ,python-six)))
68 (home-page "https://github.com/google/protobuf")
69 (synopsis "Protocol buffers is a data interchange format")
70 (description
71 "Protocol buffers are a language-neutral, platform-neutral extensible
72 mechanism for serializing structured data.")
73 (license bsd-3)))
74
75 (define-public python2-protobuf
76 (package-with-python2 python-protobuf))