gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / patchutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages patchutils)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system python)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages ed)
29 #:use-module (gnu packages base)
30 #:use-module (gnu packages bash)
31 #:use-module (gnu packages file)
32 #:use-module (gnu packages gawk)
33 #:use-module (gnu packages less)
34 #:use-module (gnu packages perl)
35 #:use-module (gnu packages python)
36 #:use-module (gnu packages mail)
37 #:use-module (gnu packages xml))
38
39 (define-public patchutils
40 (package
41 (name "patchutils")
42 (version "0.3.3")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append "http://cyberelk.net/tim/data/patchutils/stable/"
47 name "-" version ".tar.xz"))
48 (sha256
49 (base32
50 "0g5df00cj4nczrmr4k791l7la0sq2wnf8rn981fsrz1f3d2yix4i"))
51 (patches (search-patches "patchutils-xfail-gendiff-tests.patch"))))
52 (build-system gnu-build-system)
53 (inputs `(("perl" ,perl)))
54 (arguments
55 '(#:parallel-tests? #f
56 #:phases (alist-cons-before
57 'check 'patch-test-scripts
58 (lambda _
59 (let ((echo (which "echo")))
60 (substitute*
61 (find-files "tests" "^run-test$")
62 (("/bin/echo") echo))))
63 (alist-cons-after
64 'install 'wrap-program
65 ;; Point installed scripts to the utilities they need.
66 (lambda* (#:key inputs outputs #:allow-other-keys)
67 (let* ((out (assoc-ref outputs "out"))
68 (diffutils (assoc-ref inputs "diffutils"))
69 (sed (assoc-ref inputs "sed"))
70 (gawk (assoc-ref inputs "gawk")))
71 (for-each
72 (lambda (prog)
73 (wrap-program (string-append out "/bin/" prog)
74 `("PATH" ":" prefix
75 ,(map (lambda (dir)
76 (string-append dir "/bin"))
77 (list diffutils sed gawk)))))
78 '("dehtmldiff" "editdiff" "espdiff"))))
79 %standard-phases))))
80 (home-page "http://cyberelk.net/tim/software/patchutils")
81 (synopsis "Collection of tools for manipulating patch files")
82 (description
83 "Patchutils is a collection of programs that can manipulate patch files
84 in useful ways such as interpolating between two pre-patches, combining two
85 incremental patches, fixing line numbers in hand-edited patches, and simply
86 listing the files modified by a patch.")
87 (license gpl2+)))
88
89 (define-public quilt
90 (package
91 (name "quilt")
92 (version "0.61")
93 (source
94 (origin
95 (method url-fetch)
96 (uri (string-append "mirror://savannah/quilt/"
97 name "-" version ".tar.gz"))
98 (sha256
99 (base32
100 "1hwz58djkq9cv46sjwxbp2v5m8yjr41kd0nm1zm1xm6418khmv0y"))))
101 (build-system gnu-build-system)
102 (inputs `(("perl" ,perl)
103 ("less" ,less)
104 ("file" ,file)
105 ("ed" ,ed)))
106 (arguments
107 '(#:parallel-tests? #f
108 #:phases
109 (alist-cons-before
110 'check 'patch-tests
111 (lambda _
112 (substitute*
113 '("test/run"
114 "test/edit.test")
115 (("/bin/sh") (which "sh")))
116 ;; TODO: Run the mail tests once the mail feature can be supported.
117 (delete-file "test/mail.test"))
118 (alist-cons-after
119 'install 'wrap-program
120 ;; quilt's configure checks for the absolute path to the utilities it
121 ;; needs, but uses only the name when invoking them, so we need to
122 ;; make sure the quilt script can find those utilities when run.
123 (lambda* (#:key inputs outputs #:allow-other-keys)
124 (let* ((out (assoc-ref outputs "out"))
125 (coreutils (assoc-ref inputs "coreutils"))
126 (diffutils (assoc-ref inputs "diffutils"))
127 (findutils (assoc-ref inputs "findutils"))
128 (less (assoc-ref inputs "less"))
129 (file (assoc-ref inputs "file"))
130 (ed (assoc-ref inputs "ed"))
131 (sed (assoc-ref inputs "sed"))
132 (bash (assoc-ref inputs "bash"))
133 (grep (assoc-ref inputs "grep")))
134 (wrap-program (string-append out "/bin/quilt")
135 `("PATH" ":" prefix
136 ,(map (lambda (dir)
137 (string-append dir "/bin"))
138 (list coreutils diffutils findutils
139 less file ed sed bash grep))))))
140 %standard-phases))))
141 (home-page "https://savannah.nongnu.org/projects/quilt/")
142 (synopsis "Script for managing patches to software")
143 (description
144 "Quilt allows you to easily manage large numbers of patches by keeping
145 track of the changes each patch makes. Patches can be applied, un-applied,
146 refreshed, and more.")
147 (license gpl2)))
148
149 (define-public colordiff
150 (package
151 (name "colordiff")
152 (version "1.0.16")
153 (source
154 (origin
155 (method url-fetch)
156 (uri (list (string-append "http://www.colordiff.org/archive/colordiff-"
157 version ".tar.gz")))
158 (sha256
159 (base32
160 "12qkkw13261dra8pg7mzx4r8p9pb0ajb090bib9j1s6hgphwzwga"))))
161 (build-system gnu-build-system)
162 (arguments
163 `(#:tests? #f
164 #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
165 "INSTALL_DIR=/bin" "MAN_DIR=/share/man/man1")
166 #:phases
167 (alist-delete 'configure
168 (alist-delete 'build %standard-phases))))
169 (inputs
170 `(("perl" ,perl)
171 ("xmlto" ,xmlto)))
172 (home-page "http://www.colordiff.org")
173 (synopsis "Display diff output with colors")
174 (description
175 "Colordiff is Perl script wrapper on top of diff command which provides
176 'syntax highlighting' for various patch formats.")
177 (license gpl2+)))
178
179 (define-public patches
180 (let ((commit "ef1b8a7d954b82ed4af3a08fd63d2085d19090ef"))
181 (package
182 (name "patches")
183 (home-page "https://github.com/stefanha/patches")
184 (version (string-append "0.0-1." (string-take commit 7)))
185 (source (origin
186 (method git-fetch)
187 (uri (git-reference
188 (url home-page)
189 (commit commit)))
190 (sha256
191 (base32
192 "11rdmhv0l1s8nqb20ywmw2zqizczch2p62qf9apyx5wqgxlnjshk"))
193 (file-name (string-append name "-"version "-checkout"))))
194 (build-system python-build-system)
195 (inputs `(("python-notmuch" ,python2-notmuch)))
196 (arguments
197 `(#:tests? #f ;no "test" target
198 #:python ,python-2)) ;not compatible with Python 3
199 (synopsis "Patch tracking tool")
200 (description
201 "'Patches' is a patch-tracking tool initially written for the QEMU
202 project. It provides commands that build a database of patches from a mailing
203 list, and commands that can search that database. It allows users to track
204 the status of a patch, apply patches, and search for patches---all that from
205 the command-line or from Emacs via its Notmuch integration.")
206 (license gpl2+))))