gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / ots.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ots)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages compression)
22 #:use-module (gnu packages glib)
23 #:use-module (gnu packages pkg-config)
24 #:use-module (gnu packages popt)
25 #:use-module (gnu packages xml)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu)
29 #:use-module ((guix licenses) #:prefix license:))
30
31 (define-public ots
32 (package
33 (name "ots")
34 (version "0.5.0")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://sourceforge/libots/libots/"
39 name "-" version "/" name "-" version
40 ".tar.gz"))
41 (sha256
42 (base32 "0dz1ccd7ymzk4swz1aly4im0k3pascnshmgg1whd2rk14li8v47a"))
43 (patches (search-patches "ots-no-include-missing-file.patch"))))
44
45 (build-system gnu-build-system)
46 (arguments
47 ;; With '-jN', the rule to build the 'ots' command can be triggered
48 ;; before libots-1.la has been built.
49 '(#:parallel-build? #f
50
51 #:phases (alist-cons-after
52 'configure 'set-shared-lib-extension
53 (lambda _
54 ;; For some reason, the 'libtool' script (from Libtool
55 ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
56 ;; 'shrext' for the shared library file name extension.
57 ;; This leads to the creation of 'libots-1' instead of
58 ;; 'libots-1.so'. Fix that.
59 (substitute* "libtool"
60 (("shrext_cmds") "shrext")))
61 %standard-phases)))
62 (inputs
63 `(("glib" ,glib)
64 ("popt" ,popt)
65 ("libxml2" ,libxml2)
66 ("zlib" ,zlib)))
67 (native-inputs
68 `(("glib:bin" ,glib "bin")
69 ("pkg-config" ,pkg-config)))
70 (synopsis "Tool for summarizing texts")
71 (description
72 "The Open Text Summarizer is a library and command-line tool for
73 summarizing texts. The program reads a text and decides which sentences are
74 important and which are not. OTS will create a short summary or will
75 highlight the main ideas in the text.
76
77 The program can either print the summarized text as plain text or HTML. If in
78 HTML, the important sentences are highlighted.
79
80 The program is multi lingual and works with UTF-8 encoding.")
81 (home-page "http://libots.sourceforge.net/")
82 (license license:gpl2+)))