gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / onc-rpc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2017 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages onc-rpc)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (gnu packages kerberos)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (guix build-system gnu))
27
28 (define-public libtirpc
29 (package
30 (name "libtirpc")
31 (version "0.2.4")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
35 version "/libtirpc-"
36 version ".tar.bz2"))
37 (sha256
38 (base32
39 "18a337wa4amf0k21wnimp3yzs5l3cxqndz4x3x8bm993zhfy5hs5"))))
40 (build-system gnu-build-system)
41 (arguments
42 `(#:phases
43 (modify-phases %standard-phases
44 (add-after 'unpack 'remote-dangling-symlink
45 (lambda _
46 (substitute* '("man/netconfig.5"
47 "man/getnetconfig.3t"
48 "man/getnetpath.3t"
49 "man/rpc.3t"
50 "src/getnetconfig.c"
51 "tirpc/netconfig.h")
52 (("/etc/netconfig") (string-append %output "/etc/netconfig")))
53
54 ;; Remove the dangling symlinks since it breaks the
55 ;; 'patch-source-shebangs' file tree traversal.
56 (delete-file "INSTALL"))))))
57 (inputs `(("mit-krb5" ,mit-krb5)))
58 (home-page "https://sourceforge.net/projects/libtirpc/")
59 (synopsis "Transport-independent Sun/ONC RPC implementation")
60 (description
61 "This package provides a library that implements the Sun/ONC RPC (remote
62 procedure calls) protocol in a transport-independent manner. It supports both
63 IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
64 (license bsd-3)))
65
66 (define-public rpcbind
67 (package
68 (name "rpcbind")
69 (version "0.2.3")
70 (source
71 (origin
72 (method url-fetch)
73 (uri (string-append "mirror://sourceforge/" name "/" name "/"
74 version "/"
75 name "-" version ".tar.bz2"))
76 (sha256
77 (base32
78 "0yyjzv4161rqxrgjcijkrawnk55rb96ha0pav48s03l2klx855wq"))))
79 (build-system gnu-build-system)
80 (arguments
81 `(#:configure-flags
82 `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
83 (inputs
84 `(("libtirpc" ,libtirpc)))
85 (native-inputs
86 `(("pkg-config" ,pkg-config)))
87 (home-page "http://rpcbind.sourceforge.net/")
88 (synopsis "Server to convert RPC program numbers into universal addresses")
89 (description
90 "@command{Rpcbind} is a server that converts RPC program numbers into
91 universal addresses.")
92 (license bsd-3)))
93