gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / microcom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages microcom)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix git-download)
23 #:use-module (guix download)
24 #:use-module (gnu packages autotools)
25 #:use-module (gnu packages readline)
26 #:use-module (guix build-system gnu))
27
28 (define-public microcom
29 (package
30 (name "microcom")
31 (version "2016.01.09")
32 (source (origin
33 (method git-fetch)
34 (uri (git-reference
35 (url "git://git.pengutronix.de/git/tools/microcom.git")
36 (commit "v2016.01.0")))
37 (file-name (string-append name "-" version "-checkout"))
38 (sha256
39 (base32
40 "080ci5589bpyy5kcl51csmvpw9zysify189hw6awx69pi3cjnxly"))))
41 (build-system gnu-build-system)
42 (arguments
43 `(#:phases
44 (modify-phases %standard-phases
45 (add-before 'configure 'bootstrap
46 (lambda _
47 (zero? (system* "autoreconf" "-i")))))))
48 (inputs `(("readline" ,readline)))
49 (native-inputs `(("automake" ,automake)
50 ("autoconf" ,autoconf)))
51 (home-page "http://git.pengutronix.de/?p=tools/microcom.git")
52 (synopsis "Minimalistic serial line terminal program")
53 (description "Microcom is a minimalistic terminal program for accessing
54 devices via a serial connection. It features connection via RS232 serial
55 interfaces (including setting of transfer rates) as well as in `telnetmode'
56 as specified in rfc2217 and a (Linux specific) CAN mode.")
57 (license gpl2+)))