gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libidn)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages libunistring)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public libidn
29 (package
30 (name "libidn")
31 (version "1.33")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/libidn/libidn-" version
35 ".tar.gz"))
36 (sha256
37 (base32
38 "068fjg2arlppjqqpzd714n1lf6gxkpac9v5yyvp1qwmv6nvam9s4"))))
39 (build-system gnu-build-system)
40 ;; FIXME: No Java and C# libraries are currently built.
41 (synopsis "Internationalized string processing library")
42 (description
43 "libidn is a library implementing of the Stringprep, Punycode and IDNA
44 specifications. These are used to encode and decode internationalized domain
45 names according to the IDNA2003 specifications. It includes native C, C# and
46 Java libraries.")
47 ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
48 ;; the command line tool is gpl3+.
49 (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
50 (home-page "http://www.gnu.org/software/libidn/")))
51
52 (define-public libidn2
53 (package
54 (name "libidn2")
55 (version "0.16")
56 (source (origin
57 (method url-fetch)
58 (uri (string-append "ftp://alpha.gnu.org/gnu/libidn/libidn2-"
59 version ".tar.gz"))
60 (sha256
61 (base32
62 "13v8kh4d5nfkymai88zlw3h7k4x9khrpdpv97waf4ah8ykzrxb9g"))))
63 (inputs
64 `(("libunistring" ,libunistring)))
65 (build-system gnu-build-system)
66 (synopsis "Internationalized domain name library for IDNA2008")
67 (description "Libidn2 is an internationalized domain library implementing
68 the IDNA2008 specifications. Libidn2 is believed to be a complete IDNA2008
69 implementation, but has yet to be as extensively used as the original Libidn
70 library.")
71 (home-page "https://www.gnu.org/software/libidn/#libidn2")
72 ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
73 ;; GPL2+ or LGPL3+.
74 (license (list gpl2+ gpl3+ lgpl3+))))