gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / libftdi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libftdi)
20 #:use-module (guix licenses)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages libusb)
25 #:use-module (guix build-system cmake))
26
27 (define-public libftdi
28 (package
29 (name "libftdi")
30 (version "1.1")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "http://www.intra2net.com/en/developer/libftdi/download/libftdi1-"
35 version ".tar.bz2"))
36 (sha256
37 (base32
38 "088yh8pxd6q53ssqndydcw1dkq51cjqyahc03lm6iip22cdazcf0"))))
39 (build-system cmake-build-system)
40 (propagated-inputs
41 `(("libusb" ,libusb))) ; required by libftdi1.pc
42 (home-page "http://www.intra2net.com/en/developer/libftdi/")
43 (synopsis "FTDI USB driver with bitbang mode")
44 (description
45 "libFTDI is a library to talk to FTDI chips: FT232BM,
46 FT245BM, FT2232C, FT2232D, FT245R and FT232H including the popular
47 bitbangmode.")
48 (license lgpl2.1)))