gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / jemalloc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages jemalloc)
20 #:use-module ((guix licenses) #:select (bsd-2))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages gcc)
25 #:use-module (guix build-system gnu))
26
27 (define-public jemalloc
28 (package
29 (name "jemalloc")
30 (version "4.5.0")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "https://github.com/jemalloc/jemalloc/releases/download/"
35 version "/jemalloc-" version ".tar.bz2"))
36 (sha256
37 (base32
38 "10373xhpc10pgmai9fkc1z0rs029qlcb3c0qfnvkbwdlcibdh2cl"))))
39 (build-system gnu-build-system)
40 (home-page "http://jemalloc.net/")
41 (synopsis "General-purpose scalable concurrent malloc implementation")
42 (description
43 "This library providing a malloc(3) implementation that emphasizes
44 fragmentation avoidance and scalable concurrency support.")
45 (license bsd-2)))